"system volume on disk is corrupt"

#1
Hello,
I have an acer aspire 4736 laptop with windows 7 as OS, recently i faced a problem where its showing me 'windows error recovery'. Two options are there to either a)launch startup repair b)start windows normally. When i select startup repair one system recovery options window pops up giving two options a)use recovery tools that can help fix problems starting windows b)restore your computer using system image that you created earlier. I cant select (a) as my operating system is not listed so i select (b) and then click next. Error msg comes 'The system cannot find the file specified.(0x80070002)'. Then I click ok another window comes giving me 5 options a)startup repair b)system recovery c)system image recovery d)windows memory diagnostic e)command prompt. I tried (a) "startup repair cannot repair this computer automatically". I tried (b) 'restart computer, select an operating system, then select system restore' but i cant do that as the OS itself is missing.I tried (c) 'The system cannot find the file specified.(0x80070002)'.I tried (d) but cant rum windows memory diagnostic as some error is preventing windows from checking problems during startup.I tried (d) in the command prompt it came 'X :\windows\system32>'

I dont know what can be done any help would be highly appreciated.
Thx
 
#3
Same boat - step four failure

I am in "Step Four: Nuclear Holocaust"

When I run the line "bcdedit.exe /import c:\boot\bcd.temp"

I get the following result:

The store import operation has failed.
The requested system device cannot be found.

Is there any hope?
 

mqudsi

Mostly Harmless
Staff member
#4
You don't have an active partition. You need to use diskpart to make a partition active.
 
#5
Ah - this is new to me - should I set my c drive to the active partition and then start the entire process again, or pick up right where I left off?
Thanks!

Addendum:

used dispart to select drive and then make the partition active. Resumed process and got the same error. Any ideas?

Addendum:

can I create the boot area on a usb drive and then copy it over? Or will the guid not be correct if I do that?

Addendum:

detail:
List disk:
Disk 0, status: online size: 931GB Free: 100MB (this is a 1TB drive that really has over 300 GB free)

list volume:
volume 0, ltr: c, Label: "", Fs: NTFS, Type: partition, size 931GB, Status: Healthy, info: ""
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Ahh, in that case, your volume filesystem is corrupt.

Try running "chkdsk c: /f" from the command line.
 

mqudsi

Mostly Harmless
Staff member
#8
I don't understand - at the same command prompt where you ran diskpart, run the command I gave you.
 

mqudsi

Mostly Harmless
Staff member
#10
perhaps it's not drive C: ?

Paste the output of "mountvol" from the command line here.
 
#11
i entered the command in the command prompt which comes in system recovery options.
X:\sources>chkdsk c: /f
Cannot open volume for direct access

Just yesterday i explained my situation to one of my computer savvy friend. He said that i need to install drivers for my hard disk. Something with .inf extension. So i googled for my hdd drivers.
My hdd mode name is: Hitachi HTS545032B9A300
I went to Hitachi's website to download drivers but there they have put 3 to 4 different driver tests and not actual drivers. The tests which have to be done on a computer through a floppy drive which has an OS working. But mine is a laptop with no floppy drive and no OS so cant get ahead from there.
Any ideas where i can get the drivers for my hard disk?