..the usual desperate plea for help!

#1
Hi all,

Need some help here please..About 3 weeks ago I downloaded Easybcd as I had two operating systems on one drive and wanted to delete one. The drive is a 1 gig WD and was working perfectly up to this point. It had 2 partitions, c: which was the boot and had a copy of windows 7 beta...and b: on which I had installed a full version of windows 7 home premium. Everything was working fine until I decided to delete the old windows 7 beta, I got tired of being asked which operating system to use. So I download Easybcd and delete windows 7. the second one, as I thought that was the right one. Then when I rebooted, I got only the old windows 7 beta, telling me it wasn't activated, etc, etc...it sent me in circles, whenever I tried to activate it, it would restart. So I put in my windows 7 home premium disk and tried to repair, but the drive wasn't found...and has not been recognized since. It spins and I believe it is physically ok, but nothing will recognize it. I have tried it on three different systems, two win7 and one xp pro, three different bios, absolutely nothing, when I tried to put a fresh copy of either win 7 or xp, from boot disk, same thing, says no drive found..I even bought a SATA to USB cable thinking maybe it would recognize it as a USB device, but no luck..have I permanately screwed this up or is there something I can do to repair it?? MBR repair?? I don't know, not that knowledgeable..

Any help will be truly appreciated...I don't care about the operating system so much as I do getting my data off the drive.
Thanks All...
 
#2
Have you tried installing Easybcd on win7 beta or will beta not boot to a desktop.
If it wont boot to the desktop try turning the time back in the bios.
Do you need to install drivers at the point setup can't detect a drive?
To get your data off try a live Linux distro or put the drive in another pc.
Mike