Timeout Options query

JohnF

New Member
#1
I have the latest version of EasyBCD 2.2. With Windows 7 and two OS in the boot menu I can boot into either OS no problem.
However, Skip the menu does not work (I always get two options) and I cannot change the wait time from 30 secs to zero as it is greyed out.
Any ideas please? I have searched through the posts but none has given me the answer.
Thanks
John
 

Terry60

Knows where his towel is.
Staff member
#2
Why would you want to skip the boot menu if you're dual-booting ?
If you have an OS you want to boot all the time with the option to boot an alternative only very infrequently there are better options.
a) If they're on different HDDs, keep the boot files separate and use BIOS override.
b) If they share a HDD, set the preferred default and timeout=1. That will give you a near-instantaneous boot but retain the option to chose the backup system should the default crash.
"Skip" and timeout=0 will both leave you high and dry with no options if the main OS crashes.
"Skip" is designed to suppress a superfluous menu when a "no-choice" BCD incorrectly presents a menu when it shouldn't.
This last case scenario is caused by slight (non-fatal) corruption of the BCD.
Your BCD seems also to be suffering from some slight problem from the symptoms you describe.
You can fix BCD corruption by
EasyBCD > BCD Backup/Repair > Reset BCD > Perform Action.
DON'T under any circumstances ignore the warning EasyBCD will give you not to boot the PC until you've added your BCD entries again.
Use "Add New Entry" to put your required systems back into the BCD, and then you should find that the timeout option is available.
 

JohnF

New Member
#3
Thank you Terry.
I only need to boot into one OS, on a separate drive, to test some software from time to time in a different state of Windows 7.
The BCD corruption you suggested has cured the problem so timeout is now available.
Many thanks for your advice and Happy New Year to you and all EasyBCD users.
John