TimeTweaker JIT Error

#1
TimeTweaker's command line interface is working fine. but the gui isn't. it worked fine on rc1, but i just installed it on rc2, and this happens whenever i start one of the 'profiles' from the tray icon:


if i click details, i get this:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ComponentModel.Win32Exception: The system cannot find the file specified
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at GUI.Manager.MenuClick(Object Sender, EventArgs e)
at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)
at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs mea)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ToolStrip.WndProc(Message& m)
at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.308 (rtmLHS.050727-3000)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
GUI
Assembly Version: 1.0.2396.34781
Win32 Version: 1.0.0
CodeBase: file:///C:/Program%20Files/NeoSmart%20Technologies/TimeTweaker/GUI.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.308 (rtmLHS.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.308 (rtmLHS.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.308 (rtmLHS.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.308 (rtmLHS.050727-3000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
 

mqudsi

Mostly Harmless
Staff member
#2
Got it.
Fix on the way :smile:

Thanks for the report, Toxic.
 
#3
:tongueout:oint:
This is exactly what is happening to me when I am trying to load a program from work. How do I enable the debugging so the program will load all the files?
Thank you so this posting!
 

mqudsi

Mostly Harmless
Staff member
#4
Sorry about that guys - it's the "Eid" holidy season here, nothing is getting done.

I'll have a new version of TimeTweaker up tomorrow... thanks for waiting!

(BTW, welcome to NeoSmart Technologies LKQPat!)
 

mqudsi

Mostly Harmless
Staff member
#6
As promised: http://neosmart.ath.cx/TimeTweaker.zip

I have a full-plate at the moment, planning a little, no make that big, surprise for NST members and don't have time to make an official release ATM.

Anyway, it should work, just copy and paste the exe in the zip file over the original EXE. Lemme know if it (doesn't) work.

-CG
 

mqudsi

Mostly Harmless
Staff member
#9
No, my link is a different case.


It's just stupid Longhorn Server's IIS7 acting up - I *have* to go back to 2k3.

Try it again in a couple of minutes.
 
#10
this is happening again, but this time when i try to start a program from the shell.

and in "configure entries" if you press the delete button and none of the profiles are selected in the box.

and if you try to add one from the "configure entries" thing.
 

mqudsi

Mostly Harmless
Staff member
#11
OK, I'll look into it when I get the time.

I suggest you just use the command prompt for now, the entire shell needs re-writing.
We'll have documentation up shortly.. but you know how to use the CLI for now, right?
 

mqudsi

Mostly Harmless
Staff member
#13
???

I'm lost.
What does TT have to do with a video chipset?
 

mqudsi

Mostly Harmless
Staff member
#15
Oh ok..
I thought you meant using the command prompt version is hard without a video card - I see what you mean now though - no PC to use it on :tongueout: