Triple Boot: Win7 / OSX / Ubuntu from single SSD?

#1
Having some problems adding Ubuntu Netbook remix 9.04 to my setup.

The machine is a Dell Mini 9 with a single 64GB SSD.

The SSD is configured as follows:

Boot Loader: EasyBCD 2.0 beta
Partitioning Scheme: MBR
Partition 1 @ 16GB, NTFS: Win7 RC1
Partition 2 @ 32GB, HFS+: OSX 10.5.7

I booted up off the Ubuntu created USB flash drive and proceeded to create a 3rd partition of ~9GB as ext4. Installed UNR 9.04 to it and rebooted. The UNR bootloader (it's grub, I think) comes up and I tell it to boot into Win7. Since I don't want to use the UNR bootloader, I tell EasyBCD to reinstall the MBR and then add a Linux entry to it. I then reboot and the EasyBCD bootloader boots as normal, I select the Linux entry but then nothing happens as UNR doesn't load.

What can I do to link EasyBCD & the install of UNR in partition 3?

Thanks.
 

JustinW

Super Moderator
Staff member
#2
Grab the latest version of [thread=642]EasyBCD beta[/thread]. Re-add the entry. If its still not working, re-add but check "grub isn't installed..."
 
#3
Ok, that did the trick.

I was using 2.0B60 but once I upgraded to 2.0B63 and set it to "grub isn't installed...", UNR booted right up.

Thanks!
 
#5
Weird. I noticed that I had formatted my UNR partition as ext3 instead of ext4 so I reinstalled UNR on partition 3 formatted as ext4 but now when I try to boot (after rewriting the MBR and removing/insert a new boot entry), I get the following error:

Booting '/boot/grub/menu.lst'
Booting '/grub/menu.lst'
Booting ;/boot/grub.conf'

find --set-root --ignore-floppies /boot/grub.conf

Error 15: File not found

Press any key to continue...
Pressing a key will drop me into GRUB4DOS 0.4.4 with three entries:

/boot/grub/menu.lst
/grub/menu.lst
/boot/grub.conf

Selecting any of the options will give me the same error. Is ext4 not supported?

I'm going to try reinstalling as ext3 to see if I get the same error.

Thanks.

Edit: Ok, reinstalled using ext3 and it boots right up. So I guess ext4 isn't supported?
 
Last edited: