Triple Boot with XP/Vista/Ubuntu

#1
I am attempting to use the Vista Boot Manager to triple boot between XP, Vista, and Ubuntu. My first plan was to add some free space on my Nvidia SATA Raid (Raid 0). However, Ubuntu didn’t recognize my raid, and I didn’t want to risk corrupting my Raid. I’m new to Linux, so please keep that in mind. I know there are some additional linux driver support for raid setups (I may toy with those later), but this is what I did for now:

I already had XP installed on my Raid. I went out and bought Vista and installed it (I had to use partition magic to set aside some space for it). I would have used GPARTED, but it wouldn’t see my raid correctly. The boot manager now shows “Vista”, and “An earlier version of windows (I later used EasyBCD to label as XP)”. So now I have:

- Vista and XP on my 300gb sata raid
- Ubuntu Linux on an old 40gb ATA drive I had lying around

I had no problems installing Ubuntu to the ATA drive, and it boots fine if I tell the BIOS to boot directly from that drive.

I’m trying to use EasyBCD 1.52 to allow me to boot Ubuntu from the Vista Boot Manager as well, I’ve added the drive and partition info into the linux tab, but when I reboot and choose it, I just get a blinking cursor in the left corner. It installs a directory and file on the “Windows XP” MBR drive, but I’m not sure if I’m missing something. I assume the boot manager refers to that file when I choose Ubuntu from the boot screen, and points it to GRUB on the other physical drive. Please let me know if there is a simple setup I can enter to correct my problem. I’m sure it’s a simple fix, but I’m pounding my head against the desk right about now.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi 1slyfox,
Yeah, it's a simple enough thing: from a Linux CD or Recovery Disc run the program
Code:
grub-install /dev/hdxy
to install Grub on the y partition of x drive.
Then in EasyBCD add a Linux entry @ x+1 drive with y partition.
 
#3
Thanks for the quick reply Guru,

I'm still having problems, although I'm learning more about grub that I ever wanted to :smile:. What I get now when I choose Linux from the choices is Grub in the upper left corner of the screen, but the computer is locked and requires a hard boot.
I don't know if I'm any closer, but what I did was boot directly to my ATA drive by F8 during boot. This allows me to boot into Ubuntu. Before Ubuntu loads, I hit "esc" while grub is loading, then "C" for console. Ubuntu is the only thing on this drive, and I manually set up the 2 partions. Grub has no problem seeing the partions when I type root ("tab", it shows me fd0,hd0,hd1. Then root(hd0,"tab", it shows the two partions. The EXT3 partition is (hd0,0), and the swap is (hd0,1). From what I understand, you must be in the root directory of grub before you can run "setup". So I gave the command root (hd0,0) to put me in the root directory (based on running a find command). Then I ran setup (hd0,0). From what I've read, "setup" and "grub-install" do the same thing, but I could be wrong.
I know this is a linux matter and not related to Easy BCD but any help would be greatly appreciated. I will help spread the knowledge if I can get this thing to work, because based on the web searches I've done, this seems to be a common problem "grub in the left corner"...
 
#4
One thing I should add, because it bugged me. While running setup (hd0,0) There are two "embed" lines that are sent during the setup/install. They both fail with a "non fatal" response, but the setup finishes and and reports success. I've read a page that said the "non fatal" is missleading.

These are the examples that I cut/pasted from that web site. My display is similar to example 2, however I ran setup (hd0,0) not setup (hd0). The 2 embed lines fail as shown in example 2 though. Hopefully there is any easy fix to get the "Setup/Install" to work correctly, but I have no problem repartitioning, and reinstalling Ubuntu if needed.

Example 1

Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/afs_stage1_5" exists... yes
Running "embed /boot/grub/afs_stage1_5 (hd0)"... yes
Running "embed /boot/grub/aft_stage1_5 (hd0,0)"... yes
Running "install /boot/grub/stage1 (hd0) /boot/grub/stage2 p /boot/grub/menu.lst "...succeeded
Done.

Example 2

Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/afs_stage1_5" exists... yes
Running "embed /boot/grub/afs_stage1_5 (hd0)"... failed (this is not fatal)
Running "embed /boot/grub/aft_stage1_5 (hd0,0)"... failed (this is not fatal)

Running "install /boot/grub/stage1 (hd0) /boot/grub/stage2 p /boot/grub/menu.lst "...succeeded
Done.
 
#5
I read further about the "embed" command failing, and it sounds like that is normal when installing it to the a partition. However, I'm still just getting grub in the left corner with a blinking cursor. Is that because grub cannot find it's list?
 
#6
I've reformatted since the original post, and I've changed my partitions since the previous posts.

I'm attaching a screenshot of my terminal during the "install-grub" process. There are some statements about "Unknown partition table signature". I'm not sure if that is normal, but it finishes (if that isn't normal... any ideas on why it's happening)? I've also included a copy of my "grub.lst". Ubuntu boots fine if I hit F8 during boot-up directly from my IDE ATA drive. However, when I set EasyBCD up with the correct drive/partition info... In my case (HD0), Partion (2), I get grub in the left corner and a locked computer.

I've even reformatted the drive, and during installing of Ubuntu you can pick where you want grub installed to. I've told it to install to (hd0,0) during install and it still gives me the grub in left corner problem.

Any thoughs Guru?
 

Attachments

mqudsi

Mostly Harmless
Staff member
#7
ah, i know now.
It's installed to the MBR, that's why it works from the F8 button. But we need it to be installed on the *bootsector* so that EasyBCD can use it.

from the console, do a
Code:
dd if=/dev/hda2 of=/nst_grub.mbr bs=512 count=1
then get nst_grub.mbr onto your Vista, either by emailing the file to yourself or putting it on a floppy/USB.

Copy nst_grub.mbr to C:\nst\
Reboot, select the Linux entry in the Vista boot menu.
 
#8
I saw your post while at work, and couldn't wait to get home to try it. I was really hoping this would do the trick. I ran the data dump (dd) command as you stated, and emailed the nst_grub.mbr file to myself. Once booted into Vista, I copied the nst_grub.mbr to the d:\nst\ folder. I know you said to put it on the C: drive, but D: is where the NST folder is located.

I'm still getting the same outcome. Grub in the left corner with a blinking cursor. Here is a detailed view from EasyBCD display mode, maybe it will help.

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=D:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {ntldr}
resumeobject {a617c59b-b739-11db-9946-aa3d0b3674bc}
displayorder {ntldr}
{current}
{863c1d6b-b89c-11db-8612-0015f250e678}
toolsdisplayorder {memdiag}
timeout 15

Windows Legacy OS Loader
------------------------
identifier {ntldr}
device partition=D:
path \ntldr
description Microsoft Windows XP

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {bootloadersettings}
osdevice partition=C:
systemroot \Windows
resumeobject {a617c59b-b739-11db-9946-aa3d0b3674bc}
nx OptIn

Windows Legacy OS Loader
------------------------
identifier {863c1d6b-b89c-11db-8612-0015f250e678}
device partition=D:
path \NST\nst_grub.mbr
description Ubuntu
 

mqudsi

Mostly Harmless
Staff member
#9
I don't know what to tell you. It's a GRUB problem, that much is obvious.
This is the standard technique used since forever to get Linux to boot from the the NTLDR boot.ini menu.

I suggest you try another bootloader, something about your setup isn't working well with GRUB, probably residue of some old files, I just can't figure out why this happens.

Two options:
1) Install grub to a partition on the first drive instead of the second, then configure EasyBCD to use that instead?
2) Try installing LILO instead.

I don't know what's up with your GRUB, but it sure is mighty weird.
 
#10
I appreciate the help and ideas. I think it has to do with using a sata raid for XP and Vista and a different ide drive for Linux. Then again, I'm a Linux newbie so it could be me missing a step. I haven't given up hope yet, and once I get this thing whipped I'll post a topic on it. I downloaded Fedora (which has the Nvidia raid support built in). I'm going to toy around with it to see if I can get it to tripple boot using the Vista Boot Manager. Until I figure it out, I'll just have to hit F8 to boot Linux. I don't think I can get grub to boot them because it sees my raid as 2 separate devices instead of one. Thanks again for your time Guru.
 

mqudsi

Mostly Harmless
Staff member
#11
ah, that's interesting.
I think this would be classified as a GRUB problem - I only wish I could help, but quite honestly, i'm at my wit's end.

here's a tip: try using the new grub 2.0, it might take care of that. It's much more powerful, but no distros use it as of yet.
grub 2.0: http://www.gnu.org/software/grub/grub-2.en.html
 
#12
Thanks,

I'll try the new grub. I found something interesting. If I boot to Fedora by hitting F8, then hit "ESC" and choose "Other" (which I changed to read XP/VISTA), I get my Vista Boot Manager choices. That isn't the weird part. I still have Fedora as a choice after adding it's .MBR data to EasyBCD. If I choose it after booting to linux by hiting F8, choosing "other", then choosing "Fedora", it takes me back to Fedora. It actually works like it's supposed to. It won't work if I boot directly to the Vista Boot Manager though. Weird huh... It has me wondering if I should try using the map command in my grub statement.
 

mqudsi

Mostly Harmless
Staff member
#13
That certainly is interesting.
Something just occured to me: it's possible that Fedora's version of GRUB isn't kosher - i.e., they've made their own changes to it. If you don't want to try GRUB 2, try DLing the latest vanilla version of GRUB 1.95 - you never know, it may help.