Triple booting is only a dream at this point...

#1
Hey there, I am a long time Windows user, first time Linux user. Anyway, here's my issue, I hope you guys/gals can shed some light on this.

I am currently dual booting XP Pro and Vista on a 160gb drive. I have Ubunutu 7.04 installed on the remaining partitions however I cannot boot into it at all. The drive is partitioned as follows:

1 - XP Pro
2 - Vista
3 - /home
4 - /
5 - swap

The install of Ubuntu went fine. On the last step of the install questions, I hit advanced and specified that Grub be installed on (hdo,7) which is what Ubuntu listed as my "/" <or is it referred to as boot?> partition. When I reboot, I get my Vista Windows Boot Manager screen with XP and Vista. No Ubuntu.

I then used the bootpart application to create a bin file to add to my boot.ini. I used the Linux Native partition that bootpart specifies. I now have an Ubuntu option on my Windows Boot Manager, but when I choose that option I get the following error:

Loading new partition
Bootsector from C.H. Hochstatter
Cannot load from harddisk.
Insert Systemdisk and press any key.

I tried using bootpart again and various partition numbers but all the same results.

Then I stumbled upon EasyBCD. I downloaded the latest and tried to add my Linux option this way. I removed all the entries in my boot.ini that bootpart made as well as the bin file. I added Linux via EasyBCD and I received the same error as above!

Then I tried adding Linux with the "I don't have Grub installed option" and then I get the Grub prompt when I choose my Linux option from the boot manager:

Minimal BASH-like editing is supported...
grub>

I then tried reinstalling Grub manually with my Ubuntu live CD. When I did the command for find /boot/grub/stage1 it finds it without issue. I even see the files in the /boot folder.

So I am at a loss on what to try next. Does anyone have any other suggestions for me to try?
 

raul

New Member
#2
Hey, the same thing happened to me, are you sure you are using EasyBCD 1.61 and above, previous versions don't let you boot 'grubless'. Installing 1.61 and now 1.7 resolved being dropped to the grub command line for me.
 
#3
Hey, the same thing happened to me, are you sure you are using EasyBCD 1.61 and above, previous versions don't let you boot 'grubless'. Installing 1.61 and now 1.7 resolved being dropped to the grub command line for me.
Thanks for the sugg Raul. I double checked my version and it is 1.61. But I just tried 1.7 as well and I get the same results when I try just the Linux addition option as well as the "I don't have Grub installed option". Not sure what else to do.

When I hit the drop down menu on the Linux tab in EasyBCD, it shows the following:

Drive 0
Partition 0 (HPFS/NTFS - 68GB)
Partition 1 (HPFS/NTFS - 68GB)
Partition 2 (Extended - 8GB)
Partition 3 (Linux Native - 8GB)
Partition 4 (Extended - 3GB)
Partition 5 (Linux Native - 3GB)
Partition 6 (Extended - 1GB)
Partition 7 (Linux Swap - 1GB)

Partition 5 is the partition that is supposed to have Grub correct?

Any other thoughts folks?
 

mqudsi

Mostly Harmless
Staff member
#4
Welcome to NeoSmat Technologies, berserker & raul.

Berserker, it sounds like you're missing the menu.lst file - despite the fact that GRUB is installed.

Easiest option: use NeoGrub.
Delete your old Linux entries in EasyBCD.
Add/Remove Entries -> NeoGrub -> Install
Configure NeoGrub

It'll open a notepad prompt where you need to configure your menu.lst.
Create a file that looks like this:

Code:
# NeoSmart NeoGrub Bootloader Configuration File
#
# This NeoGrub menu.lst file should be located at \NST\menu.lst of the boot drive.
# Please see the EasyBCD Documentation for information on how to create/modify entries

title Ubuntu
find --set-root /boot/vmlinuz-2.6.17-10-generic
kernel /boot/vmlinuz-2.6.17-10-generic ro root=/dev/hdb2
initrd /boot/initrd.img-2.6.17-10-generic
Replace the /boot/* references with the appropriate info for your own install.
Replace /dev/hdb2 with the right partition you installed GRUB to.

Reboot, select NeoGrub from the Vista bootloader, and if your menu.lst file was configured OK you should be good to go.

More info on menu.lst & NeoGrub: http://neosmart.net/wiki/display/EBCD/NeoGrub
 

raul

New Member
#5
Berserker, Can you confirm the folder NST with the files Menu.lst and NeoGrub.mbr is present in your C or root folder and a file called NeoGrub (172.9kb) is also present in the root folder or C drive.

With previous versions of EasyBCD the NeoGrub file in the root folder presumably this is the boot loader was not present and I was being dropped to the grub command line. As soon as I upgraded to version 1.61 EasyBcd creates this file when you set up a neogrub entry and everything works seamlessly.

I just made a post on the EasyBCD 1.7 announcement post on the forums on how I resolved my triple booting problems which could be helpful.
 
Last edited by a moderator:
#6
Berserker, Can you confirm the folder NST with the files Menu.lst and NeoGrub.mbr is present in your C or root folder and a file called NeoGrub (172.9kb) is also present in the root folder or C drive.

With previous versions of EasyBCD the NeoGrub file in the root folder presumably this is the boot loader was not present and I was being dropped to the grub command line. As soon as I upgraded to version 1.61 EasyBcd creates this file when you set up a neogrub entry and everything works seamlessly.

I just made a post on the EasyBCD 1.7 announcement post on the forums on how I resolved my triple booting problems which could be helpful.
If I install NeoGrub, I do have those files in my NST folder. I also show the NeoGrub file on the root of my XP drive <same location as the NST folder>.
However, I still get dropped to the Grub command line.
Addendum:
Welcome to NeoSmat Technologies, berserker & raul.

...

title Ubuntu
find --set-root /boot/vmlinuz-2.6.17-10-generic
kernel /boot/vmlinuz-2.6.17-10-generic ro root=/dev/hdb2
initrd /boot/initrd.img-2.6.17-10-generic[/code]

Replace the /boot/* references with the appropriate info for your own install.
Replace /dev/hdb2 with the right partition you installed GRUB to.

...
Thanks for the welcome, nice to find out about this place.

Can you tell me how to get this information for the /boot/* references as well as the exact partition that has Grub installed on it? When I installed Ubuntu, I specified (hdo,7). How does that translate to /dev/?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
Well, you said
I even see the files in the /boot folder.
Basically find out what are the numbers after the vmlinuz-* and the intrd.img-* and stick those in the menu.lst to finish it off :smile:

That should do the trick. Good luck.
 
#8
OK, I booted into the Live CD and got the info that I needed. Here is my configuration info:

title Ubuntu
find --set-root /boot/vmlinuz-2.6.20-15-generic
kernel /boot/vmlinuz-2.6.20-15-generic ro root=/dev/hda7
initrd /boot/initrd.img-2.6.20-15-generic

I get the NeoGrub menu and it shows Ubuntu but when I select it, I get the following:

Error 17: File not found

I found the partition I installed Grub to by booting into the Live CD and doing a "find /boot/grub/stage1" and it showed (hd0,6).

Does my info look correct?
 

mqudsi

Mostly Harmless
Staff member
#9
OK, try changing it to:
Code:
title Ubuntu
root (hd0,6)
kernel /boot/vmlinuz-2.6.20-15-generic ro root=/dev/hda7
initrd /boot/initrd.img-2.6.20-15-generic
And see if that does the trick?
 
#10
Alright, tried changing it and now I'm getting a different error:

root (hd0,6)
Error 20: Selected cylinder exceeds maximum supported by BIOS.

Just wanted to say thanks to you guys for helping me out on this thus far. I'm pretty clueless about *nix so of course going through all this is a good way to learn. Hope y'all can shed some light on what I can do to get this working.
 

mqudsi

Mostly Harmless
Staff member
#11
Ouch.

That explains a lot of what we've seen so far.
Some motherboards do not support booting beyond the 137GB mark. Check if there is a BIOS update for your motherboard and try upgrading to it then trying again.
 
#12
Makin' some progress for sure!

I updated my BIOS and this time when I select Ubuntu, I get a bunch of text that looks like drivers loading, etc. However, it stalls for a bit and then I get the following:

Check root=bootarg cat /proc/cmdline or missing modules, devices: cat /proc/modules ls /dev

Alert! /dev/hda7 does not exist. Dropping to a shell!

You mentioned that some BIOS' may not support hard drives over 137GB. Does that mean that Ubuntu is not possible on this specific drive because I already have other OS's installed on the earlier partitions? Or is there a way to configure my curent install to work? Again, thanks for all your help. It is very much appreciated!
 

mqudsi

Mostly Harmless
Staff member
#13
Try sda7 instead of hda7, that might do the trick.
 
#14
Try sda7 instead of hda7, that might do the trick.
Woo-Hoo!!! It works! Muchas gracias!

So, this is prolly a dumb question, but what made it work? What is hda/sda and why did I need NeoGrub rather than just regular Grub?

BTW, thanks again!!! It finally works!!! Mad props to you for sticking with the troubleshooting.
 
#15
from what i know

and hello

sda an hda are two different types of hard drives, am i right?

one being a IDE and the other being a SATA, right?

also, and this was one of the err i ran into installing ubuntu. kinda lol

they have different ways of telling partitions: as you already have seen, they have letters and numbers to tell partitions, to tell the same partitions they also have numbers and such lol it can be very confusing when installing to a partition. so i just installed ubuntu on to my empty 160Gb Hard drive. ran perfect too :smile:

---

i would think you could use normal GRUB, but while you guys were getting everything to try to work, i guess neoGRUB just work better for your system and settings

okay so its all on one disk... eh.. i dont like that lol. i have a second hard drive for my ubuntu and i preferred the system that way, and i could no matter what access the linux kernal/ubuntu as well, through normally just booting the other hard drive first.


im glad you got it all working. and thing else and we will be glad to help. :smile:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#16
Woo-Hoo!!! It works! Muchas gracias!

So, this is prolly a dumb question, but what made it work? What is hda/sda and why did I need NeoGrub rather than just regular Grub?

BTW, thanks again!!! It finally works!!! Mad props to you for sticking with the troubleshooting.
w00t, congratulations berserker, glad to hear it!! :brows:

sda, as Kahai mentions, normally refers to SATA and SCSI drives while hda refers to standard IDE drives. Recent Linux distros are trying to do away with this confusion by making everything sda - it's a lot easier once you get used to it.

Now as for why NeoGrub works and GRUB doesn't - I'm not sure, I really have no clue - not being a GRUB developer myself... I can only suggest that there is some bug in GRUB that - in your particular circumstances - prevented it from working properly which does not exist in NeoGrub...

NeoGrub is based on GRUB, but highly modified to support more filesystems (NTFS included) and with a bunch of nice, time-saving features. It was largely made possible by the hard work of the Grub4Dos project, we only built on their work to make it as successful as it is now.

anyway, congrats again :smile: