Tripple booting with Vista, XP, Ubuntu on three separate drives

isg0nnarain

Active Member
hey guys sorry for being a bother again, but I had to reinstall Ubuntu since I have installed it in a different partition. This time I set up the partitions in Vista (rather than gparted) and allocated about 150GB for Ubuntu and the other 150GB I left as unallocated. After the installation I rebooted and was given the choice to boot into Vista or XP but not Ubuntu. The only way (that I know of) to get into Ubuntu is by using the LiveCD

this is my new menu.lst:

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=63bb2256-88ac-45d8-9d75-6b85d0f51785 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd2,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=63bb2256-88ac-45d8-9d75-6b85d0f51785 ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
root (hd2,0)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=63bb2256-88ac-45d8-9d75-6b85d0f51785 ro single
initrd /boot/initrd.img-2.6.24-16-generic

title Ubuntu 8.04, memtest86+
root (hd2,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Windows Vista/Longhorn (loader)
root (hd0,0)
savedefault
chainloader +1


to answer kairozamorro's question, no I cannot boot into Ubunutu's drive byistelf. I do not get that option when booting up.
 

Coolname007

Distinguished Member
So what kind of errors are you getting now? And how many partitions are on your Ubuntu drive? Did you point the Ubuntu entry in EasyBCD at the correct "drive" (partition) Ubuntu is installed to? :wink:

-Coolname007
 

isg0nnarain

Active Member
nvm I was able to get to GRUB (just set my boot priorities in a different order in BIOS) however this is what i get

Ubuntu 8.04, kernel 2.6.24-16-generic
Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
Ubuntu 8.04, memtest86+
Other operating systems:
Windows Vista/Longhorn (loader)

For all except Windows Vista/Longhorn I get

Error 17: Cannot mount selected partition

Press any key to continue
 

JustinW

Super Moderator
Staff member
So as cool suggested its either the wrong disk or wrong partition...
Keep playing around with x and y in root (hdx,y) until you get the right combination. You can use grub to edit the entries on the fly to accomplish this task, though the changes will need to be made to menu.lst when you do get into Ubuntu.
 

Coolname007

Distinguished Member
nvm I was able to get to GRUB (just set my boot priorities in a different order in BIOS) however this is what i get

Ubuntu 8.04, kernel 2.6.24-16-generic
Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
Ubuntu 8.04, memtest86+
Other operating systems:
Windows Vista/Longhorn (loader)

For all except Windows Vista/Longhorn I get

Error 17: Cannot mount selected partition

Press any key to continue

The error 17 is due to the wrong partition or disk number entered in your Ubuntu menu.lst...but that is because you switched drives in your BIOS. :wink: So in order to boot Ubuntu that way now, you would need to use (hd0,0) in your menu.lst entries. :smile: But have you tried the Vista bootloader method, yet? i.e. with EasyBCD?

-Coolname007
 
Last edited:

isg0nnarain

Active Member
Next, simply add an entry for Ubuntu in EasyBCD, under the Linux tab, leaving the box titled "Grub isn't installed to the bootsector" unchecked, with the correct "drive" (partition) that Ubuntu is installed to selected in the "Drive" drop-down menu, and the Grub option selected in the "Type" drop-down menu. And you should thereafter be able to boot into Ubuntu from your Vista bootloader, using that boot entry you created in EasyBCD. :wink:

GL and let us know how it goes.

-Coolname007
you mean this part? no but I will give it a try now.
 

isg0nnarain

Active Member
I added the entry for Ubuntu and got this error now:

BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partition
Bootsector from C.H. Hochstatter

A disk read error occurred
Press Ctrl+Alt+Del to restart
 

Coolname007

Distinguished Member
I added the entry for Ubuntu and got this error now:

BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant BootPart
Loading new partition
Bootsector from C.H. Hochstatter

A disk read error occurred
Press Ctrl+Alt+Del to restart

That is the error you get when you don't have Grub first installed to the Ubuntu partition...:wink: Make sure to do that, and it should work fine. Run the following commands in your Ubuntu terminal:

sudo grub
find /boot/grub/stage1
root (hdx,y)
setup (hdx,y)
quit
exit
The x and y of both commands should be replaced with whatever numbers the "find" command returns as the disk and partition that Ubuntu is installed to.

GL and let us know how it goes.

-Coolname007

EDIT: And remember to create a new entry for Ubuntu after you do that...:wink:
 
Last edited:

isg0nnarain

Active Member
not sure if this matters but I would rather be sure since this has been taking some time, after typing setup (hdx,y) i get this:

grub> setup (hd2,0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd2,0)"... failed (this is not fatal)
Running "embed /boot/grub/e2fs_stage1_5 (hd2,0)"... failed (this is not fatal)
Running "install /boot/grub/stage1 (hd2,0) /boot/grub/stage2 p /boot/grub/menu
.lst "... succeeded
Done.
 

Coolname007

Distinguished Member
not sure if this matters but I would rather be sure since this has been taking some time, after typing setup (hdx,y) i get this:

grub> setup (hd2,0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd2,0)"... failed (this is not fatal)
Running "embed /boot/grub/e2fs_stage1_5 (hd2,0)"... failed (this is not fatal)
Running "install /boot/grub/stage1 (hd2,0) /boot/grub/stage2 p /boot/grub/menu
.lst "... succeeded
Done.

No, that shouldn't be a problem. :wink: I got the exact same "failed" message when installing Grub to my partition, like you, but it worked fine. :smile: As you can see, it says "(this is not fatal)" on both "failed" lines.
So it wouldn't hurt to check to see if it works now. :wink: So go ahead, and try booting into Ubuntu from the entry you created in the Vista bootloader, with EasyBCD...and see if you get that same (or a different) error message.

Cheers.

-Coolname007
 

isg0nnarain

Active Member
unfortunately i get the same error

Addendum:

i must of done something wrong during the installation process. with the LiveCD in, I go to menu.lst but the thing is, that file is not on the filesystem drive its on the media drive
 
Last edited:

Coolname007

Distinguished Member
unfortunately i get the same error
Sure you selected the correct "drive" (partition) in EasyBCD in the "Drive" drop-down menu under the Linux tab, when you created the Ubuntu entry? If all else fails, we can always move on to trying NeoGrub...:smile:

Addendum:

i must of done something wrong during the installation process. with the LiveCD in, I go to menu.lst but the thing is, that file is not on the filesystem drive its on the media drive
Ok...so what is the name of the "media" drive? :wink: Time to make sure basic things have been done! :brows:

-Coolname007

EDIT: Is it by any chance the name of your Ubuntu partition? I just remembered its not called "Filesystem" (I think) when booting from the LiveCD...
 
Last edited:

Coolname007

Distinguished Member
These are the drives that come up

310.8GB Media
CD-RW/Blu-ray Drive
Windows Vista
Windows XP
Filesystem

So what does the 310.8 GB Media partition contain? You didn't mention it before...I think that is likely one of your external HDDs, but which one I have no idea ! :smile: And what does the "Filesystem" one contain? Are you sure you even installed Ubuntu to the right drive? :wink:

-Coolname007

EDIT: Is it possible you have two Ubuntus installed? For example, one on (hd0,1), and one on (hd2,0)? It sounds like you need to first verify which one is the correct one you're trying to boot, and then edit the menu.lst on that partition to point there, and reinstall Grub with those commands again (if necessary). If necessary, copy over your menu.lst from the Media drive into the Filesystem one, and make any necessary changes. Next, add an entry again in your Vista bootloader with EasyBCD, with the correct partition and "Type" selected, and see if it works.
 
Last edited:

isg0nnarain

Active Member
310.8GB Media:
bin, boot, cdrom, dev, etc, home, initrd, lib, lost+found, media, mnt, opt, proc, root, sbin, srv, sys, tmp, usr, var, initrd.img, vmlinuz

the same is for Filesystem the only difference is when I click on the boot folder

The media drive has this:
grub folder
abi-.2.6.24-16-generic
config-2.6.24-16-generic
initrd.img-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak
memtest86+.bin
System.map-2.6.24-16-generic
vmlinuz-2.6.24-16-generic

Filesystem has:
abi-.2.6.24-16-generic
config-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak
memtest86+.bin
System.map-2.6.24-16-generic
vmlinuz-2.6.24-16-generic

To be honest I am not sure if it is on the right drive. I have already tried 3x and still have the same problem

I know I am not installing it on the windows drives otherwise I would not be able to launch any window os

I also assume that during the partition part, ubuntu orders the drives starting from drive 1-3

sda should be drive one
sdb should be drive two
sdc should be drive three (place I want to install Ubuntu to)

I have even chosen the manual option just to make sure what drive I'm dealing with seeing how in manual I am able to see what space is used and not used
 

Coolname007

Distinguished Member
I also assume that during the partition part, ubuntu orders the drives starting from drive 1-3

sda should be drive one
sdb should be drive two
sdc should be drive three (place I want to install Ubuntu to)
That is correct. sda is Drive 1, sdb Drive 2, and so forth. But keep in mind Grub itself goes by a different numbering system which starts at 0, instead of 1...:wink: Which means sda4 for example = (hd0,3). This is because Grub starts counting at 0 instead of 1.

Anyhow, I'm afraid that's all I can help you for tonight. :smile: Its pretty late over here, and I need to be getting to bed, if I want to be getting up in the morning.

I will check back later to see if your problem was solved when I was gone. :wink:

Good night.

-Coolname007

Addendum:

310.8GB Media:
bin, boot, cdrom, dev, etc, home, initrd, lib, lost+found, media, mnt, opt, proc, root, sbin, srv, sys, tmp, usr, var, initrd.img, vmlinuz

the same is for Filesystem the only difference is when I click on the boot folder

The media drive has this:
grub folder
abi-.2.6.24-16-generic
config-2.6.24-16-generic
initrd.img-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak
memtest86+.bin
System.map-2.6.24-16-generic
vmlinuz-2.6.24-16-generic

Filesystem has:
abi-.2.6.24-16-generic
config-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak
memtest86+.bin
System.map-2.6.24-16-generic
vmlinuz-2.6.24-16-generic

Ok...I think I figured out your situation. :smile: Your Media drive contains right now the Grub folder, in addition to the rest of the files needed to boot, while your Filesystem drive on the other hand contains only the other files needed to boot! So to fix this, you will need to copy over from your Media drive, all the files you mentioned, into your Filesystem drive, replacing whatever files exist currently with the same filenames, create a new entry for Ubuntu in EasyBCD, with the Filesystem drive selected in the "Drive" drop-down menu, and "Grub" selected in the "Type" menu. Next, run those Grub commands again, just in case, and install Grub to whatever partition that the "find" command comes up with, and it should now work. :wink: But of course, you will booting into, in this case, the Filesytem drive now...so I hope it contains the rest of the OS! :brows:

Cheers, and let me know how it goes.

-Coolname007

Addendum:

Actually, I changed my mind about using the "find" command again...:wink: That is because it is likely to locate the Media drive again, instead of the Filesystem one, since the Media drive would be the first partition of that drive...
So just a simple question first...did you install Ubuntu that last time to the same hard drive as the other one, or was it a different drive? Because if you installed it to the same drive, different partition, that means that the "find" command will locate the other one, since the Media one would be on the first partition, and the Filesystem one would be on a partition after that...:wink:

So if on the same drive, run the following command in the Terminal, and then post its output here:

sudo fdisk -l
And that last letter is a lowercase L, not an capital i.
This will give us a clue which drive your second Ubuntu is installed to, as well as your first....:wink:

Also...I think we might just be able to get both Ubuntus booting! :grinning:

-Coolname007
 
Last edited:

isg0nnarain

Active Member
k before I go ahead and continue, I just tried to copy the files from media into filesystem and got a couple of merging requests, replace requests, and you cannot move here because you do not have authorization to. Also the file system only has 1.5GB and needs 1.8GB

why was a media drive created in the first place?
 

Coolname007

Distinguished Member
k before I go ahead and continue, I just tried to copy the files from media into filesystem and got a couple of merging requests, replace requests, and you cannot move here because you do not have authorization to. Also the file system only has 1.5GB and needs 1.8GB

why was a media drive created in the first place?

Sorry...I forgot. :smile: You will need to be first a root user, before copying and replacing files from one partition to another. So to become root, enter the following in the terminal:

And then try it, and it should work...:wink:

As for how the media drive got there...I literally have no idea! :lol: Maybe you had it before, but you didn't notice it?

Anyhow, please try what has already been suggested, and hopefully that will fix it. :smile:

-Coolname007
 

isg0nnarain

Active Member
ok after doing this as a root user I was able to try to move all the files to filesystem however since filesystem does not have enough space it will not move
 
Top