Trying to boot ubuntu with xp & vista

#1
So I followed the instructions on the wiki to dual boot linux with vista, I installed linux and put grub in its own bootsector, leaving the vista boot loader in the mbr.

I rebooted to vista after the linux installation and added the entry for linux and rebooted again. when choosing the linux option from the boot menu, it gave me the error message "Cannot Load from Harddisk; Insert Systemdisk and press any key".

I tried Neogrub and the grubless installation method but that just booted me into a grub command prompt.

So I dont know what to do now really... :O

Heres my debug information: (im using EasyBCD 1.61 Beta)

Code:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=D:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {466f5a88-0af2-4f76-9038-095b170dc21c}
displayorder {466f5a88-0af2-4f76-9038-095b170dc21c}
{6f613342-30a1-11dc-986a-a11829bc96ab}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 3
Windows Legacy OS Loader
------------------------
identifier {466f5a88-0af2-4f76-9038-095b170dc21c}
device partition=D:
path \ntldr
description Microsoft Windows XP
Windows Boot Loader
-------------------
identifier {6f613342-30a1-11dc-986a-a11829bc96ab}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {6f613343-30a1-11dc-986a-a11829bc96ab}
nx OptIn
Thanks,
Colin
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#2
Hi Colin-UK, welcome to NST.

Looks like Ubuntu misinterpreted your command and didn't install GRUB at all.

Anyway, stick your Ubuntu DVD in the drive and follow the "reinstalling GRUB" section to get that running.

Afterwards you can use the normal or grubless Linux options in EasyBCD.
 
#3
Thanks for the reply.

I tried to follow the instructions in the wiki for reinstalling grub, but i got a "file not found" error when i typed "find /boot/grub/stage1".

Not too sure what to do now, I tried searching around the filesystem but its nowhere to be seen, like it hast been installed at all :/

-Colin
 

mqudsi

Mostly Harmless
Staff member
#4
That's actually what I was thinking myself. If it said it installed GRUB it should have created menu.lst.

I think you have to reinstall - looks like it wasn't really written to the drive! :S
 

mqudsi

Mostly Harmless
Staff member
#6
Glad to hear it! :smile:

Any idea what went wrong? Always good to know so that we can help others out in the future.
 
#7
No idea tbh, I guess ubuntu just didnt install the grub for some random reason, although I didnt get any errors during install.

Guess it was just one of those quirky things, like when i started the live ubuntu cd the other day and it took me to a login screen (login for a live cd?) and wouldnt let me do anything until i restarted lol.

Thans again for the help! :smile:

-Colin
 

mqudsi

Mostly Harmless
Staff member
#8
My pleasure, Colin. Glad I could help.
 
#9
I just posted a problem related to this same issue at:
http://neosmart.net/forums/showthread.php?t=792

Not sure what is going on with it, but am starting to wonder if Grub didn't install correctly... If I boot into the Live CD, I can see the "\boot\grub" folder with the "menu.lst" file as described, however don't know what's wrong. Multiple reinstalls later, I'm thinking I may need to get some type of Grub boot CD to reinstall Grub to the Ubuntu ext3 partition.

Please see my post for full details.