Trying to move boot info to one HDD

#1
I have what I hope is not a unique situation. I have a dual boot RAID1 system, which is currently split into two drives (broken RAID array at the moment). One drive (W10) is GPT with the normal C drive and Fat32 100MB partition. The other disk is running W7 (brain dead mostly), but the System Reserve on that HDD has the boot information for the other (W10) drive.

I'm trying to figure out a way to get the boot info onto the W10 HDD, so that I can reinitialize the other drive that currently has W7 and put it back into the RAID1 array.

If I remove the "F" drive (W7) from the system, it won't boot.

I've tried:

bcdboot C:\windows /s C:

But this doesn't appear to do anything, even though it "completes successfully."

Using easyBCD, I see the following. All help is appreciated!

Default: Windows 10
Timeout: 60 seconds
Boot Drive: E:\ <- this is the problem

Entry #1
Name: Windows 10
BCD ID: {current}
Drive: C:\
Bootloader Path: \WINDOWS\system32\winload.exe

Entry #2
Name: Windows 7 Professional (recovered)
BCD ID: {00673801-64b4-11df-9417-9921c9e7568d}
Drive: F:\
Bootloader Path: \Windows\system32\winload.exe
 

Terry60

Knows where his towel is.
Staff member
#2

Terry60

Knows where his towel is.
Staff member
#4
Ah, your W10 is a UEFI GPT system
That means it should be using the winload.efi loader not winload.exe.
I'm not quite sure how you ended up booting your W10 from W7's BCD in legacy mode.
Can you see an option in your BIOS boot priority screen for "Windows boot manager" ?
That should be the native UEFI W10 boot manager in the EFI partition.
Try booting from that, and the "system" flag should disappear from E, allowing you to dismount that drive.
 
#5
Hi Terry,

Yeah, unfortunately, when I try to boot from it, it fails. The EFI partition isn't assigned a drive letter, so it's not available in the list if I try to use the repair function in easyBCD. I can assign a letter with diskpart... e.g., assign it to "U". But, I'm not sure if that would help?

Jonathan
 

Terry60

Knows where his towel is.
Staff member
#6
How does it fail ?
It's been a long while since I installed W7 and W8.1(now W10) on my new (then) GPT/SSD UEFI PC, and I've had no reason to revisit the nuances of the UEFI BIOS, so it's all a bit hazy now, but isn't there a toggle option for native UEFI v emulated legacy BIOS somewhere ?
It can get a bit catch 22 if you've installed two OSs under those different environments, where each will boot successfully but only in the appropriate mode, leaving the other apparently "broken" until you switch modes and the situation flip-flops.
 
#7
It asks for a boot disk to be inserted. :smile: I believe it's set for legacy, but in any case, I tried the other options and it made no difference. It's possible that there were other things going on at the time, so it wasn't an independent test of the options one at a time.

I would be fine if the Win7 never booted again, as there's nothing of importance on it, and I want to completely remove that drive anyway. It's mostly brain dead now, and I need to use one of the advanced options to get it to boot at all.

Jonathan
 

Terry60

Knows where his towel is.
Staff member
#8
Do you have a W10 installation disk ?
If not you should be able to download a bootable ISO and the tool for creating a bootable flashdrive from the MS site.
Probably the easiest fix would be to remove the W7 drive and boot from the installation media, then select "repair my computer" > "startup repair"
Fixing the Windows Bootloader via the setup DVD
I believe the W10 version of EasyRE is still free at the moment, and should also be able to do the same thing.
 
#9
I tried this, but the Win10 installation disk doesn't seem to find the HDD if I remove the Win7 disk. I'm sure it has something to do with the RAID1 array, but I can't seem to load the AMD drivers. EaryRE says it's free, but apparently not.