Trying to set up Ubuntu 9.10 boot from EBCD

#1
I currently have a dual boot going (7/XP) and just installed Ubuntu without overwriting the MBR. I then added a new entry, checked the box saying GRUB isn't installed to MBR, choose GRUB2, and added the entry. However, whenever I load it from startup, it just sends me to a GRUB console. I am using EBCD 2.0.
 
#3
I just noticed that with GRUB2 that option grays out. I tried it with GRUB legacy and nothing loaded at all. Damnit I've been working on this for days and I am sooooo close.
 

Terry60

Knows where his towel is.
Staff member
#4
Use build 82. The options don't "grey" any more. They disappear.
That's because EasyBCD will find everything it needs to know for itself.
You don't need to tell it any more
The other options are only needed for legacy grub. A fresh install of 9.10 will use grub2.
It only stays with grub if you upgrade in place from a previous Ubuntu release, and choose not to change.
See sticky point 7
 
#5
Tried build 82 and still no dice. Took me to the console, called "GRUB4DOS 0.4.4"

:frowning:

Also, why is it that when I highlight the Windows XP option it doesn't say "press F8 for advanced options" like it does with Win7. I can't boot into safe mode with XP.
 

Terry60

Knows where his towel is.
Staff member
#6
You need to hit F8 immediately after selecting XP from the boot menu.
(you're interrupting NTLDR for its extended boot menu, Not W7's.
NTLDR doesn't start to run until you select XP from the boot menu).

Did you delete the old Linux entry(s) and add a new one ?
If so, and the auto-detection of grub2 didn't work, please post the output from EasyBCD / useful utilities / power console
bootgrabber.exe /list
so that CG can see your configuration.