Trying to Triple-Boot Vista, Leopard, and Ubuntu

#1
I have all of them installed correctly. I want to use the Vista's bootloader, via EasyBCD. I can boot into Leopard fine, but I am having trouble with Ubuntu. This is my overview in EasyBCD 1.7.2:

There are a total of 3 entries listed in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Mac OS X
BCD ID: {5a663e86-b3f7-11dd-a889-001e6884f389}
Drive: C:\
Bootloader Path: \chain0
Windows Directory: \Windows

Entry #3

Name: Ubuntu
BCD ID: {5a663e90-b3f7-11dd-a889-001e6884f389}
Drive: C:\
Bootloader Path: \NST\NeoGrub.mbr
What am I doing wrong? It's Ubuntu 8.10, if that makes a difference.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Did you install GRUB to the MBR or did you install it to the Linux partition?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
That is done during the Linux install. That is during its setup process to select where it is installed. Did you change the options at all during setup?

Try this. Remove the Linux entry. Save your settings. Close EasyBCD. Restart EasyBCD. From there add a Linux entry again. This time select Linux, change the name if you wish. Select the partition it is installed to and then check the box at the bottom for GRUB is not loaded to MBR.

See if that helps.
 
#5
That is done during the Linux install. That is during its setup process to select where it is installed. Did you change the options at all during setup?

Try this. Remove the Linux entry. Save your settings. Close EasyBCD. Restart EasyBCD. From there add a Linux entry again. This time select Linux, change the name if you wish. Select the partition it is installed to and then check the box at the bottom for GRUB is not loaded to MBR.

See if that helps.
When I do that, I get a message: Try (hd0,0): EXT2:

I'm not going to even pretend I know what that means.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Alright so it seems that GRUB was loaded to the MBR. Remove the entry again and re add it. This time dont check the box.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
Maybe just reinstall Grub. That might help. reinstall it to the same partition that Ubuntu is installed on. Then try the steps i first listed.
 

JustinW

Super Moderator
Staff member
#14
If an entry for OS X isnt in grub either create one for Vista's bootmgr using EasyBCD or add a new entry that chainloads it from grub in /boot/grub/menu.lst. Example:

title OS X
root (hd1,1)
chainloader +1

The above should work if Darwin is installed correctly to the boot sector of the second disk, first partition in the system.