TweakUI 64 hangs on Rebuilding Icons


I am trying to run TweakUI64 on my XP box to rebuild some icons that are missing (mostly adminpak.msi icons for some reason). When I click the repair now button, Tweak goes into a "not responding mode". I thought it just needed some time so I let it sit for 30 minutes. Still no luck.

I then checked the Task Manager and noticed that none of the metrics were moving (CPU, memory, page faults, various IO counters, etc). So I ended the app and tried again this time enlisting the help of Process Monitor. It appears that TweakUI starts and is just waiting for is the output after clicking "repair now" (see the attachment)

Any help or ideas on the problem?


  • TweakHanging.doc
    35.5 KB · Views: 3
Hi kingofbytes, welcome to NeoSmart Technologies.

We didn't write the actual code for TweakUI, we only ported the application (as a whole) over to Windows 64-bit.

From your log it looks like the rebuild finished even though TweakUI hangs, so I haven't a clue what else you can try to get the .msi icon working again.
It actually never soon as you click the "repair now" button it starts hanging.....never actually does anything. I would have expected a lot of file activity to show up in Process Monitor once the repair started. Instead, there's only 15 entries....which tells us the app isn't actually firing the repair process. Any other ideas?