Two Dual Boot systems

#1
I help some of the residents with their computers here at the facility. The demise of support for Windows XP has got a few of them spooked about security and they have asked me what they could do about it. After some thought I decided to investigate how a simple operating system based on Unix would work for them. So I thought that installing Ubuntu and “Dual Booting” on my computer would allow me to get acquainted with Ubuntu. Well it is dual booting and I am learning Ubuntu. And this is the crux of my problem.
I downloaded and installed “EasyBCD” I used it to create the dual boot. Then I installed the Ubuntu. It created another dual boot. And my Bios which used to display for about 10 seconds, now displays for 100 seconds, yes 100 seconds. You don’t realize how long that is until you have to wait for the boot menu. Now to boot to W7 I wait the 100 seconds and the Ubuntu dualboot comes up with W7 as the last choice. I select W7 and then the EasyBCD menu comes up and again I select W7.
To use Ubuntu I wait the 100 seconds and hit ENTER when the Ubuntu dual boot menu appears and I go into Abuntu right away
The EasyBCD manual says that if there is only one choice on the menu the menu would not appear. However, it does appear and if I remove all choices I would not be able to boot at all into W7. Don’t want that
I know nothing about the boot up process of either OS.
What can I do about the 100 second bios?
What can I do about the two ‘dual boot’ menus? Ubuntu and EasyBCD.

Bill
 

Terry60

Knows where his towel is.
Staff member
#2
Everything you did with EasyBCD was redundant.
W7 is no longer in control of the boot.
You allowed Linux to take control when you installed it (you must explicitly prevent it from doing so if you wish W7 to keep control).
The second menu (the one you created when you added an unnecessary Linux entry to W7's BCD) is not needed. To make it disappear, use EasyBCD to remove the Linux entry from the BCD (not the W7 entry !)
To resolve your 100 second wait in the Linux boot process, you'd be better off in a Linux specific forum.
Take a look at the advice here
http://ubuntuforums.org/showthread.php?t=1751168&p=10778417#post10778417
to try finding what is causing the long wait.
 
#3
The second menu (the one you created when you added an unnecessary Linux entry to W7's BCD) is not needed. To make it disappear, use EasyBCD to remove the Linux entry from the BCD (not the W7 entry !)
Terry,
Please give me a step by step on the above. I'd like to configure the dual boot to use Easy BCD only.
Thanks in advance. I, obviously, learn by my mistakes.

Bill
 

Terry60

Knows where his towel is.
Staff member
#4
That depends on how you installed Linux.
Is it on a separate HDD or did you create space on the W7 system ?
 

Terry60

Knows where his towel is.
Staff member
#6
In that case Linux has overwritten the W7 MBR/PBR to take control away from Windows.
You can either do as I said in post #2 to remove the Windows bootmgr from the equation and leave grub in sole control (you'll need to investigate why grub is pausing during POST for so long), or you can put the Windows bootmgr back in control by restoring it to the PBR
Updating the MBR and Bootsector
 
#7
I followed the instructions in Updating the MBR and Bootsector. The bios is now down to 10 seconds or less.
Then I added ubuntu back into the mix as choice number two using EasyBCD. So far, so good.
However, although I used the EasyBCD built in grub the grub menu popped up if Ubuntu was selected in the first boot menu(EasyBCD). Prior to the grub menu coming up the was Dos-like text that displayed for a few seconds, the only txt I was able to get was "Assuming drive cache - write through".
If I could get rid of that second menu, things would look alright. Any more ideas?

Bill
 

Terry60

Knows where his towel is.
Staff member
#8
Grub will give you a menu because it comes by default with all sorts of recovery options as well as the W7 option it will have created when you first installed it.
You can alter the grub menu to timeout=0 and the second menu will go away.
That's past the point at which EasyBCD has any influence, so you'll need to do it within Linux.
You can't change the grub.cfg file directly (well you can, but it isn't persistent, the OS will undo your changes at some future point when it makes cfg changes) so you need to do it via a user override.
Grub 2 Basics
 
#9
This is where I need step by step.
I did the following:
Opened the grub.cfg file in boot....grub folder. The grug.cfg in Ubuntu 12.04 is allegedly really grub2.cfg.Changed timeout to 0 and tried to save. I couldn't do it because I did not have permission.
How do I get permission to open and save the grub.cfg file?
How do I determine, for sure, the version of the grub.cfg file that is installed on my computer?
How do I do a "user override"? Can't find any mention of it on the links.
I am not familiar with the Unix way of doing things as you can see.
Bill
 

Terry60

Knows where his towel is.
Staff member
#10
This is the relevant part of the link. I won't offer any specific advice because it's been many years since I last used Linux (pre grub2).
Manual Editing of grub.cfg
Manual editing of /boot/grub/grub.cfg is not normally encouraged, as it can be overwritten by system operations and updates. grub.cfg is created by various Grub2 scripts, and it is usually preferable to edit the content of the scripts so the changes are retained during updates. The files that should be edited are contained in the /etc/grub.d folders and the/etc/default/grub file. Users making changes to grub.cfg should recognize these changes may be overwritten or should disable the ability of the system to update the grub.cfg file.
 
#11
When I try to save the changes I made to the script that updates the grub2.cfg I get the error that I am not the owner so permisson is denied.
I have been trying for a few days now to grant myself permission to make changes. But don't seem to get it right. What must I do?
 

Terry60

Knows where his towel is.
Staff member
#12
Sorry, outside my area of expertise now I'm afraid.
Either wait around for a more current Linux user to advise, or probably faster to look in a Linux forum, where you'll probably find the same question asked and answered. (I seem to remember suffering similar difficulties updating legacy grub's menu.lst years ago when I was trying an early Ubuntu for size)

You say you've been editing scripts ?
iirc you just need to make changes to settings in etc\default\grub

GRUB 2 bootloader - Full tutorial
 
Last edited: