Two Hard Drives Win 7 and XP NTLDR error

#1
I have been trying to get Dual Booting working for two days now and have probably changed so many things it will be hard to put it right. Firstly, when I installed Windows 7, I unplugged my existing XP disk. I then plugged it back in and re-booted. I now see I should have left the old disk plugged in, but I thought it would be quick and easy to set up dual boot with Easy BCD 2.0

When I go to Computer Management I see the layout of my 2 disks is as follows:

Disk 0: Contains 2 partitions, L: (System, Active, Priamry partition) and C: (Boot, Page File, Crashdump, Primary partition). The C: Partition contains Windows 7.

Disk 1: Contains two partitions, D: (Active Primary partition) and E: (Primary Partion). The D: partion contains Windows XP

I have copied the files NTLDR, boot.ini and NTDETECT.COM to each of the four partitions (Is this correct?).

My boot.ini file looks like this and is on each of the four partitions:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Disk 0 partition 1 Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Disk 0 partition 2" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disk 1 partition 1" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disk 1 partition 2" /fastdetect /NoExecute=OptIn /sos

As far as I can tell I never get to the boot.ini menu above.

My EASY BCD set up reads as follows:
There are a total of 3 entries listed in the bootloader.
Default: Microsoft Windows XP
Timeout: 30 seconds.
Boot Drive: L:\
Entry #1
Name: Microsoft Windows XP
BCD ID: {default}
Drive: C:\
Bootloader Path: \NTLDR
Entry #2
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #3
Name: NeoGrub Bootloader
BCD ID: {528fd784-3494-11de-a53c-8a1cdb659f1c}
Drive: L:\
Bootloader Path: \NST\NeoGrub.mbr

As you can see both Windows 7 and XP seem to choose drive C: Is this correct?

Windows 7 boots fine, but when I select Windows XP I get the following message before any other menu:
"Couldn't open drive multi(0) disk(0) rdisk(1) partition(1)
NTLDR couldn't open drive multi(0) disk(0) rdisk(1) partition(1)"

Can someone hel guide me?

Should I have the three files boot.ini, ntdetect.com and NTLDR in each and every partition?
Should noth the BCD entries point to drive C:?

Many thanks for your help!

trickyt3
 
#2
I have been trying to get Dual Booting working for two days now and have probably changed so many things it will be hard to put it right. Firstly, when I installed Windows 7, I unplugged my existing XP disk. I then plugged it back in and re-booted. I now see I should have left the old disk plugged in, but I thought it would be quick and easy to set up dual boot with Easy BCD 2.0

When I go to Computer Management I see the layout of my 2 disks is as follows:

Disk 0: Contains 2 partitions, L: (System, Active, Priamry partition) and C: (Boot, Page File, Crashdump, Primary partition). The C: Partition contains Windows 7.

Disk 1: Contains two partitions, D: (Active Primary partition) and E: (Primary Partion). The D: partion contains Windows XP

I have copied the files NTLDR, boot.ini and NTDETECT.COM to each of the four partitions (Is this correct?).
Hello tricky, welcome to NST.
Firstly, you only need to copy the files to L: (the "system" partition). Copying it to the other partitions have no effect at this time.
My boot.ini file looks like this and is on each of the four partitions:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Disk 0 partition 1 Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Disk 0 partition 2" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disk 1 partition 1" /fastdetect /NoExecute=OptIn /sos
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Disk 1 partition 2" /fastdetect /NoExecute=OptIn /sos
Secondly, that boot.ini is very messed up...
All you need is one entry in your boot.ini to boot XP, and make sure its pointed at the correct drive (rdisk ( ) ) and partition (partition ( ).
So the config that will most likely work in your case is the following:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Disk 0 partition 1 Microsoft Windows XP Home Edition" /fastdetect /NoExecute=OptIn /sos
That boot.ini should work fine, but it is advised to download and install [thread=642]2.0 Beta[/thread] version of EasyBCD, and use the built-in auto-config for boot.ini (Tools menu>Auto-configure boot.ini), which will automate the process, and configure it correctly for your system.
As far as I can tell I never get to the boot.ini menu above.

My EASY BCD set up reads as follows:
There are a total of 3 entries listed in the bootloader.
Default: Microsoft Windows XP
Timeout: 30 seconds.
Boot Drive: L:\
Entry #1
Name: Microsoft Windows XP
BCD ID: {default}
Drive: C:\
Bootloader Path: \NTLDR
Under Change Settings in EasyBCD, you need to point the BCD entry at the L: partition (i.e. the "system" partition), and click Save. You don't point the BCD entry at XP (or for that matter Win 7, if it is not "system"). You point it at the boot files (which need to be on the "system" and "active" partition), which in turn points to XP.
Entry #2
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #3
Name: NeoGrub Bootloader
BCD ID: {528fd784-3494-11de-a53c-8a1cdb659f1c}
Drive: L:\
Bootloader Path: \NST\NeoGrub.mbr

As you can see both Windows 7 and XP seem to choose drive C: Is this correct?
It is wrong for XP, but it is right for Win 7. So just change the settings for the XP entry, and make sure to point it at the L: partition under Change Settings.

And then you will have a dual-boot.

Cheers.

Jake
 
Last edited:
#3
Solved!

Thanks Jake,

You solved it!

Your explanations were really perfect. I now see that the entry for the Windows XP drive must point to the System partition (and not the XP partition, nor to the Vista/W7 partition. In my case the system partition is the L: drive. However the W7 entry in Easy BCD points always to the C: drive.

Tricky t 3
 
#4
Great! :smile: I'm glad to hear it.
Let us know if you have any more problems.

Jake
 
#5
help

My EasyBCD set up sais:

There are a total of 2 entries listed in the bootloader.

Default: Windows xp
Timeout: 5 seconds.
Boot Drive: C:\

Entry #1
Name: Windows xp
BCD ID: {default}
Drive: D:\
Bootloader Path: \NTLDR

Entry #2
Name: Windows 7
BCD ID: {819ce87f-4066-11de-9d03-f603c3624cf0}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

I have one disc..tree partition..first C: Win7 (they were first OS Ive installed) second D: Xp (second installed and I want to make it defoult OS on dualboot) third on is E: Empty (storage)

With this BCD settings my dualboot works for win7 but it doesnt go into Xp:

1. http://img30.imageshack.us/img30/3371/img3697.jpg if I select win 7 it starts but if I select xp it tells me this
2. http://img390.imageshack.us/img390/3778/img3696z.jpg

If i want to see xp I have to go to EasyBCD and Uninstall vista boot loader in Manage Bootloader

please help :smile:
 
Last edited:
#6
Hi serapis, welcome to NST.
You will need to use the Reinstall the Vista bootloader option from XP, if you used the Uninstall the Vista bootloader option, so you can get back into Win 7.
And then, once you're back in Win 7, simply point the XP entry in your BCD at the C: partition (which is the "system" partition). Then, copy over NTLDR, boot.ini, and NTDETECT.COM into the root of the C partition. Next, get [thread=642]EasyBCD 2.0 Beta[/thread], and use it to auto-configure boot.ini. Tools>Autoconfigure boot.ini.
And then you will have a dual-boot.

Jake
 
#7
simply point the XP entry in your BCD at the C: partition (which is the "system" partition). Then, copy over NTLDR, boot.ini, and NTDETECT.COM into the root of the C partition.
hi

tnx for info but I dont really understand how to do this quoted part...If u can explain it more detailed I would appreciate it :smile:
 

Terry60

Knows where his towel is.
Staff member
#8
There's lots of detail (or links to it) in the sticky thread. (points 3-5 apply)
 
#9
Two Hard Drives Dual Booting XP and Win 7 - solution

Serapis, I feel your pain. I followed the instructions at the start of the thread and somehow seemed to get it working and then somehow it stopped again. I tried for days without success. finally I cracked it again. Here is my solution.

I assume you have technical knowledge so I am not going to describe each step in detail. Here is my solution

1. Unplug your XP hard drive
2. Repair Windows 7 using the ISO DVD, and check it works -
3. Important, change the boot sequence in BIOS to boot from hard drive first and check again the WIN 7 starts ok
4. Use EasyBCD 2.0 to remove the XP entries and any other entries except the VISTA one
5. Make sure you have copied the following files to the drive which is described in control panel, administrative tools, computer management, disk management as the "System, Active, Priamry partition". In the example above, it was my L: drive, and in the one below, my N drive. It is certainly not the C drive.
5. Switch off. Plug in XP hard drive, switch on, boot into Win 7, Start EasyBCD 2
6. Add the Win XP entry, accepting all the defaults as offered by EasyBCD. It should show C drive when you ADD, but under view it will show the drive which is "System, Active, Priamry partition".
7. Allow EasyBCD to configure your boot.ini file automatically.
8. Your configuration might look something like this

There are a total of 2 entries listed in the bootloader.
Default: Windows 7 Ultimate (recovered)
Timeout: 25 seconds.
Boot Drive: N:\
Entry #1
Name: Windows 7 Ultimate (recovered)
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: Microsoft Windows XP
BCD ID: {c67756af-4251-11de-8ab4-8b99e640c736}
Drive: N:\
Bootloader Path: \NTLDR
 
#10
hi

tnx for info but I dont really understand how to do this quoted part...If u can explain it more detailed I would appreciate it :smile:
Ok, this is what you need to do:

Open up EasyBCD, and go the Change Settings section. Select the XP entry in the drop-down menu, and then under "Drive:", point the entry at C or BOOT, because that is the "system" partition according to EasyBCD (though you should check your Disk Management to make sure, just in case, and whatever "system" partition is shown there, point your XP entry in EasyBCD at that partition), instead of D like you currently have it. The reason is you are pointing the BCD entry at the partition that will contain XP's boot files (which needs to be the "system" "active" partition), not necessarily the partition that contains XP. :wink:
Now, make sure your Folder Options in the Control Panel, look like this:


  • The "Show hidden files and folders" option under the View tab should be selected
  • The "Hide protected system files" option should be unselected
  • The "Hide extensions for known file types" option should be unselected

Now, hit Apply, and Ok, to close the Window.

Now, open up "Computer" (from the Start menu), double-click on the XP partition to open it. In the "root" of the partition (i.e. like X:\ instead of X:\Windows etc.), there should be three files:

ntldr
NTDETECT.COM
boot.ini

So copy over those three files into the root of the "system" partition (as seen from Disk Management) which will probably be C. Next, get [thread=642]EasyBCD 2.0 Beta[/thread], open it, open up the Tools menu (at the top of the window), and select "Auto-configure boot.ini".

Now you should have a dual-boot.

Cheers.

Jake
 
#11
Tnx to all especially Coolname007 (bow)

It took just one thing...I just had to change in Change Settings section. I selected the XP entry in the drop-down menu, and then under "Drive:", pointed the entry at C (couse it is SYSTEM partition)

:wink:
 
#12
Glad to hear it. :smile:
Let us know if you have any more questions.

Regards,

Jake