Ubuntu 17.10 won't boot

#1
For several years I have used EasyBCD to dual boot Windows (now at 10) and Ubuntu. I use the Windows boot manager and install Ubuntu in a separate partition. When I install Ubuntu, I specify the Ubuntu partition as the boot loader to avoid overwriting the Windows MBR. Then I use EasyBCD to add Ubuntu to my Windows boot manager. This has worked up until the current release (17.04) of Ubuntu.

When I select Ubuntu from the (Windows) boot manager, I get dumped into grub with the grub> prompt. Even grub doesn't seem to work properly. When I use "ls" at the grup> prompt, I get "Error 14: Filesystem compatibility error, cannot read whole file."

My system is about 5 years old and uses a BIOS. I suspect that the Ubuntu installer has placed a boot file in a location that grub cannot reach, but I don't know. Any ideas about how I can fix this?
 

mqudsi

Mostly Harmless
Staff member
#2
Hmm, this isn't the first report of issues we receive about EasyBCD and Ubuntu 17.04. I haven't personally tested that configuration, but we'll definitely do so now. There doesn't seem to be anything on Google about changes to the GRUB2 configuration in Ubuntu 17.04, but you never know. The bootloader isn't the sexiest topic for discussion when a new release comes out, and it often changes with nary a whisper.

I'm pretty sure - but not certain - from your post that you are re-creating the EasyBCD Ubuntu entry after installing Ubuntu, not just using one that previously worked under 16.10, right?

Edit: 17.04, not 17.10
 
Last edited:
#3
Thank you for the comments, mqudsi. I solved the problem, and I'm sure the fault lies with Ubuntu. On both my desktop and laptop, I had to do a fresh install of Ubuntu 16.04 and then upgrade that to 16.10. From there I upgraded to 17.04. (Ubuntu allows upgrade only to the next release.)

I have used EasyBCD both ways --- creating a new entry and reusing the old one. Both have worked. I think that creating a new one was irrelevant heating of the room. :smile:
 

mqudsi

Mostly Harmless
Staff member
#4
I will give EasyBCD + a clean installation of 17.04 a try and see what happens.
 
#5
Did you determine what the problem is? I am having the same problem with Ubuntu 17.10.

I have Windows 10 and Ubuntu 17.10 installed on two separate internal disks. I booted into Windows 10 and used EasyBCD 2.3 to add Ubuntu. When I reboot and select Ubuntu from the menu, I get dumped into grub. I use the "boot -1" grub command, which takes me into the grub boot menu. From there, I can boot either into my new Ubuntu 17.10 installation or into Windows 10.

So both my OS installations (Windows 10 and Ubuntu 17.10) are okay. And grub 2 will boot into either OS. But using EasyBCD to add the Ubuntu to my Windows boot menu is not working correctly. Or I'm doing something wrong when adding the Ubuntu. I did what I've been doing for the years I've used EasyBCD. Under "Add New Entry" I select "Linux/BSD" and "GRUB 2" with Drive being the disk partition where my Ubuntu root ("/") is located.

It's important to me to have the Windows 10 boot manager remain as the primary boot controller.
 
#7
Cezav, I stopped using Easy BCD.

I have two disks in my system. Windows 10 is on one, and Ubuntu is on the other. By changing the boot order in my BIOS, I can boot into either OS. I set it to start with the Ubuntu disk, and I use grub2 to choose Windows or Ubuntu. This configuration still allows me to change my BIOS and boot directly into Windows if need be.

I don't think this would work with only one disk, because grub2 would create its own master boot record on the disk, but I don't know enough about the details to be sure about this.

Since my configuration works for me, I have not kept up with EasyBCD development, so I don't know if they have fixed the problem on their end.