Ubuntu Advanced Button Clarification

#1
Hello all.

I currently have vista running on my laptop with 2 hard drives. I have freed up 12 gb of drive space (unpartitioned) and am attempting to do a dual-boot of ubuntu 8.04 with vista. I have read the wiki numerous times and have tried a few of the installs with limited success thus far.

There seems to be a discrepancy in the wiki documentation that has been potentially causing me problems and I've been trying the various combinations here and with easyBCD with no luck thus far. On the advanced button, it states to enter the partition as /dev/sdb1 however, the image shows hd(0,1). Which format am I suppose to use in the advanced box?

Thanks
 

mqudsi

Mostly Harmless
Staff member
#2
Hi mike, welcome to NST.

Both notations will work. We originally used (hdx,y), but it turns out that in some cases this breaks the Ubuntu installer. We talked to the Ubuntu developers, and they recommended that we use /dev/sdxy notation instead.
 
#3
Thanks for the quick response. On with my other (real problem). I successfully complete the ubuntu install, on the advanced item I select /dev/sdb2 (my / partition), reboot into vista. Then I fire up easybcd and add a new entry for Linux pointing to the write volume (my 10gb volue defined as linux native). Exit, reboot, see the new linux option in the ms boot loader, select linux and then get any error about 'Cannot load from harddisk. Insert Systems disk and press any key.'

Now some interesting facts. Within EasyBCD, my volume for linux (which was /dev/sdb2 while installing from live cd) shows as Drive 0, Partition 1. Could this be my issue that Windows is changing the drive order somehow? (this is on a laptop with an internal drive and a bay drive so cabling or making changes isn't possible) I also saw where it points to the bootloader path \NST\nst_grub.mbr. Which I find on my C:\ drive (which is Drive 1, Partition 0 - from the drive dropdown on linux).

Thoughts?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#4
Well from what i know of the NeoSmart loader is that it places all teh files on the Boot drive. In your case the C:\ and boots from them. This is to prevent confusion for the bootloader.

This way all the files needed for boot are right there. Not on several different drives.

I do know that Windows sees the drive setup differently than Linux or any other OS. Could be due to the Active Ssytem Drive always being recognized as the first partition on the drive even if it isnt.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
My only suggestion would be to remove the Linux entry. Then add it again but this time check the box that the GRUB is not loaded to the MBR. Thisis how i setup my Ubuntu to boot from the BCD.
 
#7
That seemed to work - it appears I have everything working now and all my ntfs mounts are available. Thanks for the help.

Looks like I just had to change to the new notation of /dev/XhdY and then within EASYBCD just add linux and choose grub not loaded to MBR. Little different from the docs but we got there.

Thanks again
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
The Documentation was written with Ubuntu 7.10 and needs to be updated for Ubuntu 8.04. It is a work in prgoress right now and we will get it done ASAP.