Ubuntu boot failure -- missing/corrupt neogrub.mbr

#1
Hello everyone,

The error message I'm receiving is when I choose to boot-load Ubuntu from Windows Boot Manager.

//summary:
...hard- or software change might be the cause. To fix: Insert Win disc & choose "Repair" (which did NOT help).
File: \NST\NeoGrub.mbr
Status: 0xc000000f
Info: ...could be missing or corrupt.

// end summary

Ubuntu is installed on a 4.5 GB ext3 partition. (Large enough? I plan on installing no programs at the time.)
I can find NeoGrub.mbr at <C:\Device\HarddiskVolume2\NST> though when I open (in Windows) it turns out gibberish.


I found several guides on installing a Linux distro prior to Windows Vista, and although I'm running Windows 7, I thought I'd try them. The three guides I've tried are:
APCMAG's Dual-Boot Vista w/ Ubuntu (Vista prior), EasyBCD's guide to adding Linux to the Vista bootloader, and, EasyBCD's guide to dual-booting Vista and Linux.

I'm willing to reinstall Ubuntu, no questions asked; I'd prefer not to reinstall Windows 7 (thought it can still be done). Ask for any information you need.

Thanks in advance! :smile:
 

Terry60

Knows where his towel is.
Staff member
#3
Hi marine, welcome to NST.
Are you using EasyBCD 2.0 latest build ?
Ubuntu after 8.04 changed grub syntax and EasyBCD 1.7 doesn't support the new format.
Use the Beta, delete the old Linux entry, add it again and tick the "grub isn't...." box only if Ubuntu and Vista don't share the same HDD.
 
#4
Thanks Terry.

If Ubuntu and 7 share the same HDD, but different partitions, should I still tick the "grub isn't..." box?

Addendum:

I ended up just testing it and not ticking the box. It works now!! (Woo hoo!)

(If it would be better to check that box, please tell me.) I just have one more question, now: when I choose Ubuntu, it loads grub, and then it gives me all the nice options to boot into concerning Ubuntu, but also, two Vista/Longhorn boot options. Is there a way to erase those two Vista options from the list?

Thanks again, Terry!
 
Last edited:

JustinW

Super Moderator
Staff member
#5
Sure, open a terminal:

sudo gedit /boot/grub/menu.lst

Take out the lines containing the entries you don't need and than save.
 

Terry60

Knows where his towel is.
Staff member
#6
Or just change timeout to 0 in menu.lst and you won't be presented with the 2nd menu, just default boot staight into Linux.
 
#7
Hi marine, welcome to NST.
Are you using EasyBCD 2.0 latest build ?
Ubuntu after 8.04 changed grub syntax and EasyBCD 1.7 doesn't support the new format.
Use the Beta, delete the old Linux entry, add it again and tick the "grub isn't...." box only if Ubuntu and Vista don't share the same HDD.
Thank you so much! I've spent hours trying to get Windows7 and Linux Mint to dual boot, without overwriting the MBR with grub. It seemed like it should be as simple as installing Grub to the linux partition, installing EasyBCD in Windows7, and adding an entry in EasyBCD pointing to Grub on the linux partition. But, to no avail, I couldn't get it working, and tried everything.

A simple upgrade to EasyBCD 2.0 beta did the trick. It really was THAT simple. If only I had found this sooner. :smile:
 

Terry60

Knows where his towel is.
Staff member
#8
Hi foxy, welcome to NST.
Glad Easy2 did the business for you.
By EasyBCD 10.0, I'm fully expecting Guru will have produced a version that heals all know ills by merely downloading a copy to your home.