Ubuntu Confusion

#1
Hi all,

I am having what I believe are grub related multi-boot errors, and would appreciate your thoughts. I have read the FAQS, and already experimented as much as I can with using grub and grub2, and tried checking and unchecking the key options related to grub installation.

I mucked up my Ubuntu install in an effort to decide between 32 and 64 bit versions. Right now I am on 64 bit Ubuntu 9.1. Ubuntu was installed by disconnecting all other drives and installing to a drive on SATA 2.

I can boot Ubuntu with no drives attached. I can also boot with drives attached by changing the boot order using F12 and picking the SATA 2 drive.

I can't multiboot using easybcd anymore. I have experimented with both Grub and Grub2. I started with build 60, but it did not offer Grub2. I moved to build 76, which I understand does work better for ext4 (which I what I am using).

Right now I can get to a flashing line, or a menu choice of three options, none of which boot. I one scenario I can get to a message about BASH.
My guess is that grub is installed in the wrong place on this drive. I am not a technowiz but I have read a bunch of FAQs at this point.

Is there a way tell EasyBCD to just go the root boot sector of SATA 2 to boot into Ubuntu? In other words, simulate what I am doing with the F12 key. I realize this is brute force, but it should work.

I suppose the other option is to somehow modify the GRUB or bootloader sequence for the drive on SATA 2 (perhaps from within Ubuntu itself since I can boot in?). I appears there is a command with a syntax like HDA (01,2) or something like that but I am little worried that I will really mess things up.

I am open to reinstalling Ubuntu if needed. I'll admit I am a total noob when it comes to Ubuntu/Linux, and not much better with EasyBCD though I did get it to dual-boot XP and Win7. The key to the whole process seems to be figuring how the boot system "sees" drives, as most of my problems have been with naming or selecting drives (e.g. boot from c: vs. d: vs. etc.). At one time I did have a multi-boot going with Ubuntu also, but I seem to have trashed that somehow.

Thanks!
 
Last edited:
#2
Hi originalsnuffy.
Please boot from your Ubuntu LiveCD, pick the "Try Ubuntu with no Change To My Computer" option, and once you get to the Ubuntu desktop in a Live session, go to Applications->Accessories->Terminal, and run the following command:
Code:
sudo fdisk -l
(The last letter is a lowercase "L")

Then post the results of the command.
 
#3
Thank you for the suggestion. It would appear that I needed to add additional syntax to the suggested command.

From other experimentation, it appears that severly messed up the grub type information.

I blew the install away from Windows 7, and reinstalled again. The culprit may have been my custom install the last time, where I manually set the swap area. For this time, I kept the swap area the same (2 gb) and let the install CD do the rest.

This time Grub2 worked fine right away. The auto install automatically goes for ext4.

Thanks.
 
#4
Hi all,

The suggestions above seem logical; in the effort to figure out how the system is configured. However, I believe that the syntax is incomplete...I received errors to that effect from Linux.

My brute force solution was to reinstall ubuntu. Unfortunately, that worked for about one boot cycle and then died.
For that one boot cycle, Grub2 did work.

The second time I tried to boot using the entries created by bcd, I ended back up at a Grub prompt. I also was ableo to get to the dialog referring to Bash.

I am guessing that somehow my boot files are in the wrong directory...but I will fully admit that I am a Windows person not a Linux person.

I can by hitting F12 then choosing the generic Linux installation. But I suspect that this too will stop working (it stopped the last go around).

Could somebody try some hints again?

I got the general gist of the original hint, but the syntax needed some more entries as far as I could tell.

Thanks again.



Addendum:

I thought I had removed the previous post but it is like a zombie movie; it keeps coming back!
 
Last edited:
#6
By the way I must admit I do not understand why sudo fdisk -1 did not work. The documentation clearly calls for using this command.

Maybe its a bug in 9.10?
No...the truth is, you typed the command wrong.

Its
Code:
sudo fdisk -l
(lowercase "L" at the end)

NOT
Code:
sudo fdisk -1
(number 1 at the end). I do believe I stated that in my first post. :wink:

Addendum:

Hi all,

The suggestions above seem logical; in the effort to figure out how the system is configured. However, I believe that the syntax is incomplete...I received errors to that effect from Linux.

My brute force solution was to reinstall ubuntu. Unfortunately, that worked for about one boot cycle and then died.
For that one boot cycle, Grub2 did work.

The second time I tried to boot using the entries created by bcd, I ended back up at a Grub prompt. I also was ableo to get to the dialog referring to Bash.

I am guessing that somehow my boot files are in the wrong directory...but I will fully admit that I am a Windows person not a Linux person.

I can by hitting F12 then choosing the generic Linux installation. But I suspect that this too will stop working (it stopped the last go around).

Could somebody try some hints again?

I got the general gist of the original hint, but the syntax needed some more entries as far as I could tell.

Thanks again.
When you reinstalled Ubuntu, where did you put Grub? Did you use the "Advanced" option to install Grub to the bootsector of the partition, or did you let it do the default, and install grub to the MBR?
Addendum:

I thought I had removed the previous post but it is like a zombie movie; it keeps coming back!
Lol...:lol:
 
Last edited:
#7
---Tail goes between legs---

sure thought I typed the letter l.... because I knew it stood for list....reminds me of the scene in Young Frankenstein....whose brain is this....somebody called Abby Normal.....
cuts to bottle with "abnormal" on label....

Here are the results....obtained from the terminal while in a Linux session....booted via F12 right into the Linux hard drive, with all drives attached.

Disk /dev/sda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa3043e2d

Device Boot Start End Blocks Id System
/dev/sda1 1 5 40131 6 FAT16
/dev/sda2 * 6 15183 121916487+ 7 HPFS/NTFS
/dev/sda3 15184 30393 122174325 7 HPFS/NTFS

Disk /dev/sdb: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe96f2381

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 182401 1465136001 7 HPFS/NTFS

Disk /dev/sdc: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1549f232

Device Boot Start End Blocks Id System
/dev/sdc1 8159 30401 178666897+ 5 Extended
/dev/sdc2 * 1 8158 65529103+ 83 Linux
/dev/sdc5 8512 30401 175830369+ 7 HPFS/NTFS
/dev/sdc6 8159 8511 2835409+ 82 Linux swap / Solaris

Partition table entries are not in disk order


And yes, I let the install disk do all assignments, I did not move any boot partitions using the advanced commands.

I gather I will have to move some boot command or partitions, and am awaiting further advice.

Many thanks again.
 
#8
Ok, you can try using NeoGrub manually to boot Ubuntu.

Run EasybCD.
Go to Add/Remove Entries->NeoGrub tab, and click Install NeoGrub.
Now click Configure.
In the menu.lst that opens up, add this to the end:
title Ubuntu 9.10
root (hd2,1)
kernel /boot/grub/core.img
boot
Now reboot to test the new boot entry. Click the NeoGrub entry, and the boot should start up automatically, without any menu (since there should be only one entry in the NST menu.lst).

Its strange though that the Grub2 entry worked one time, and then failed afterwards...don't know why.

Addendum:

Btw, when you say you came to a menu choice of three options, was that using Grub(legacy) or Grub2 in EasybCD?
Right now I can get to a flashing line, or a menu choice of three options, none of which boot.
 
Last edited:
#10
Ok, try typing the commands manually at the prompt:

root (hd2,1)
kernel /boot/grub/core.img
boot

and see if it boots that way.
 
Last edited:
#11
Coolname--

OK;
grub> root (hd2,1) :file system type is ext2fs, partition type 0x83
grub> kernel /boot/grub/core.img :error file not found
grub>boot :Error 8 kenel must be loaded before booting

Well, we are geting closer (I think)

thanks.
 
#12
Ahh...there's the problem. Apparently the Linux kernel (core.img) is missing from the Linux partition, and so Ubuntu can't boot.
Could you please boot from the LiveCD, access the Ubuntu partition while in a Live session, and verify if the file is indeed missing. You should find it (if its there) in the /boot/grub directory.
 

JustinW

Super Moderator
Staff member
#13
At the grub prompt have grub look for the file and report the disk/parition if it can be found:

find /boot/grub/core.img
 
#14
Hi all,

Took some time off for Turkey week.

Anyway...I am a total newbie at Linux, but I used DOS style commands and found the following.

In grub there are a few files with the img extension, but none call core.img.

The files were boot.img; cdboot.img; diskboot.img; kernel.img; preboot.img, and lnxboot.img.

These might be inexact (trouble reading my scribbles) but this pretty much what was found.

I continue to boot into Ubuntu using F12 and then picking the hard drive "manually".

I can drop into grub using EasyBCD, but I get no further.

With F12, I get a few choices, and the first one listed does boot to Ubuntu 9.10.

I am not quite sure how to search for core.img. I did all this from terminal in Ubuntu.
 

JustinW

Super Moderator
Staff member
#15
Ok, if your second drive supports booting Ubuntu on its own like you say it does the easiest way to fix this is using grub-legacy option in EasyBCD. Modify the menu.lst to the following:

title Ubuntu 9.10
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
root (hd0,0)
chainloader +1
 
#16
I appreciate the suggestion. I should clarify that the sata devices are as follows:

Device 0 main drive, has XP and Windows 7
Device 1 Blu Ray drive (optical)
Device 2 Data drive (NTFS)
Device 3 Ubuntu and Data drive

I presume that the suggested drive maps should change based on this, but I would appreciate some further guidance.

I am gratified by the support of this user community.
 
#17
Change it to

map (hd0) (hd2)
map (hd2) (hd0)
 
Last edited:
#18
It would be the 4th device (hd3) according to your description:

map (hd3) (hd0)
map (hd0) (hd3)
No, I don't think so, since the other device was a Blu-Ray optical drive (not a HDD). The hdx syntax counts only HDDs as I understand it.
 

JustinW

Super Moderator
Staff member
#19
Oh, ok... yeah, what I get for flying through posts. It would be Jake's suggestion cause the blu-ray drive would be something like (cd0)
 
#20
Hi all,

So this is what is in Neogrub:

title Ubuntu 9.10
map (hd0) (hd2)
map (hd2) (hd0)
map --hook
root (hd0,0)
chainloader +1

Unfortunately, it still drops me into the grub menu.

Did I make an error somewhere?

Thanks.