Ubuntu does it again.

#1
Hi I downloaded a tutorial on howto install ubuntu and Windows Vista together.
I install ubuntu and it hangs on reboot making everything useless. So I delete the ubuntu and repartitioned it to load windows XP so I could run mbrfix.
I tried running easybcd but does not work.
Can someone give me the commandline for doing this please?
I allready tried
Code:
mbrfix.exe /drive 0 [COLOR=#000000]fixmbr /vista /yes[/COLOR]
This didnt do anything?

Please help?

I dont have the vista DVD. Its a laptop with vista preinstalled.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi bonechair,

I have no idea what you're trying to do - can you please clarify?

Does Vista boot? What about XP? What was working before you did the Ubuntu thing? What's working now? What do you want to get as an end-result?
 
#3
Hi Computer Guru

All I want is my Vista back. Vista not boot at all. The partitions are still there.
I installed Ubuntu and that messed up my boot loader. Ubuntu froze and gave errors , also grub didnt detect Vista. I didnt even want to install grub.
SO I read that you have to run your prog or mbrfix. SO I Installed XP on a smaller partition and now Im stuck. Easybcd doesnt want to load on fresh install of xp. But I see there is a bin folder with mbrfix . Is there anyway to fix this without the Vista DVD. I dont have the DVD or recovery.

Oh and I should mention that I got rid of Grub and now it just boots into XP at start. I cleared the MBR. When I try run easybcd on fresh install it says cant find mvcr??.dll (This is most likely fresh XP)
I installed latest beta and tried others.

Please could you send me the command line to fix this.

I ruined my whole day yesterday by installing ubuntu. It was a nightmare
 
#4
Oi now I tried bcdedit /set {default} device boot
And it worked but now my windows boot loader says.

\windows\system\winload.exe is missing or corrupt.
 

mqudsi

Mostly Harmless
Staff member
#5
Ok, in Windows XP install the latest EasyBCD 1.61 beta.

EasyBCD | Diagnostics | Reset BCD Data
 
#6
I tried that and got an error about a missing dll mvcr??.dll something or other. Any idea how I can get back into winxp now after I " bcdedit /set {default} device boot" Sorry I was bit impatient.
 

mqudsi

Mostly Harmless
Staff member
#7
Yeah, it says there is a problem with a missing msvcr71.dll, and that you may continue without any problem! You should have pressed OK, and went along your merry way installing EasyBCD.

Stick your XP CD in the drive, Recovery Console:
Code:
fixmbr
fixboot
exit
 
#8
Thanks for the quick reply. I did press ok and I got another error when I tried to run it. Im not at pc now to see error. Will be there in another 2 half hours.
 
#9
Ok install 1.61
I get Application error when trying to run
error(0xc0000135)

THanks the xp is up again. Now to get Vista Back
Im gonna install .net framework now.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
Yeah, that's a .NET 2.0 error.
 

mqudsi

Mostly Harmless
Staff member
#12
That means the drive you have set for your Vista entry in EasyBCD isn't correct.
What is it?

When you open this drive in My Computer, do you see your Vista files?
 
#13
Yes C: is Vista. The first time I ran easybcd it said it could not detect boot drive sO I had to choose c: . Then I ran bcd reset and restarted same thing. Winload.exe missing or corrupt
 

mqudsi

Mostly Harmless
Staff member
#14
IS C:\ the boot drive? The boot drive is the one with "boot.ini" "ntldr" and "bootmgr"
 
#15
Yes but I cant see those files on the c: . I tried to save boot.ini to c and it said cant overwrite boot.ini. I also ticked show hidden folders and files. Dunno why I cant see them

Oh I figured out to see and make it readable. But still no luck in getting vista back

man how can i delete the boot directory and recreate?

I give up this has taken away 2 days of my life.
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#16
OK, boot from your Vista DVD | Repair Options | Command Prompt:
Code:
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd
exit
That should take care of it.
 

mqudsi

Mostly Harmless
Staff member
#17
Please don't make so many posts after one another.

It doesn't make a difference if this took 2 days of your life or 200 days - making a hundred posts in a row complaining about it won't get me to help you any faster.
 
#18
I thank you for your help, you have been very helpfull.

Gonna goto a computer shop now and see if they can borrow me a DVD quick.
 
Last edited:
#19
Thank you Thank you Thank you

Oi couldnt get hold of installation cd.
I tried various things to fix this and then I just rebooted and tried your program again, went to reinstall Vista Bootloader and its fixed. Didnt need to rebuild bcd.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#20
That's awesome news! :grinning: