Ubuntu hangs with: "Try (hd0,0): EXT2"

#1
My situation:

/dev/sda1 - Ubuntu 9.10 ext4
/dev/sda2 - Ubuntu Swap
/dev/sda3 - Data partition
/dev/sda6 - Windows 7 NTFS

Since I'm tired of reconfiguring GRUB2 after each "update-grub" because it automatically erases all of my customized, working, settings, I decided to let GRUB boot Ubuntu and use the Windows 7 bootloader to dual-boot.

I first installed Ubuntu, then installed Windows 7, overwriting GRUB2.
If I use the latest EasyBCD 2.0 Beta Build, I use the "GRUB2" option for /dev/sda1.

But if I want to boot into Ubuntu, it just hangs with "Try (HD0,0): EXT2".
It won't go any further than that.
It's the same problem as in this thread: http://neosmart.net/forums/showthread.php?t=2995
 
#2
First is this all on one drive? Second, do you see a menu.lst when it hangs?

Sometimes there is a small partition on the drive for recovery and I believe Win 7 puts one on there as well on a fresh install. So you should be booting to (h0,1) or (h1,0) depending on how many drives you are using.

On my Fedora dual boots, grub was always written incorrectly with the wrong (h0,0) when mine should have been (h1,0). I actually got a menu.lst so I hit "e" on the first line to edit the change the run time line to (h1,0) and once I logged into linux I fixed grub.conf. Maybe similar to what you have been doing but to fix Grub2 it is a little different as you noted.
 
#3
First is this all on one drive? Second, do you see a menu.lst when it hangs?

Sometimes there is a small partition on the drive for recovery and I believe Win 7 puts one on there as well on a fresh install. So you should be booting to (h0,1) or (h1,0) depending on how many drives you are using.

On my Fedora dual boots, grub was always written incorrectly with the wrong (h0,0) when mine should have been (h1,0). I actually got a menu.lst so I hit "e" on the first line to edit the change the run time line to (h1,0) and once I logged into linux I fixed grub.conf. Maybe similar to what you have been doing but to fix Grub2 it is a little different as you noted.
Only one drive (laptop).

I partioned my disk before I installed Windows 7, so it would not be possible to create another 100MB partition. And it seemed to work, as all bootfiles are on /dev/sda6 and there's no 100MB partition.

I don't see a GRUB2-menu. There's no ''menu.lst" file in C:\NST\ either, but I think that's correct when selecting GRUB2 in EasyBCD.

I think NeoGrub doesn't recognize my S-ATA controller or something alike.
 
#4
That all makes sense except for neogrub not seeing the contoller. If it is recognized in BIOS and Windows sees it, I would think neogrub does not care.

Sorry not much help. All the systems I have done I installed windows first.
 
#5
I'm having exactly the same problem with exactly the same setup. I have a 1.5TB HD with Ubuntu installed first (has worked fine on its own), and today I installed Windows 7. I used EasyBSD 2.0 to add a Grub2 boot option, but it doesn't work. Windows boots fine, but with Ubuntu I get the same 'Try HD(0,0)' with an unresponsive blinking cursor.
 

mqudsi

Mostly Harmless
Staff member
#6
Does Ubuntu come before Windows in terms of partition order?
 
#7
Yes. It's similar to the OP:

sda1 - Ubuntu
sda2 - Windows Reserve Space
sda3 - Windows 7
sda4 - Ubuntu Extension Space
sda5 - Ubuntu Swap Space
 

mqudsi

Mostly Harmless
Staff member
#8
We've brought this up with the team that worked on the Linux booting code that we rely on in certain cases. Still waiting to hear back from them, though.
 
#9
I encountered the same issue with the following setup:

Ubuntu Maverick on /dev/sda1 (primary partition)

Windows Vista installed later on /dev/sda2 (also a primary partition)

There is one more logical partition that contains the swap partition (sda5) for Ubuntu.


The linux grub2 bootloader is able to handle both installations fine
 

mqudsi

Mostly Harmless
Staff member
#10
Will be fixed in next EasyBCD 2.0.3 beta build.