Ubuntu x64 and windows7x64 dual boot, grub2 failure

#1
Ok ill try to keep it short and sweet.

I installed xp pro x86 , then windows 7, and then ubuntu 10.10 x64 EXT4.


*extra info*
I am now seeing the windows boot loader via the repair disk and bootrec /fixboot commands (thank you neosmart forums) I was able to get in and use the Easy bcd 2.02 or whatever (the new one that supports grub2) I deleted my XP drive since i never use it anymore and fixed my MBR since it was on that drive and then used Super grub to boot into windows 7 and reinstal my boot loader. If I use the "super grub disk ver 2" i can load the option that states "load the grub config even if the MBR is overwiten " this option gives me two options and with it I can boot Ubuntu BUT i dont want to use the super gub disk every time to load linux. I COULD go in and re install grub2 and make it work again but then i would have to chain load into windows and would prefer to not do that. Is there a option I am missing in BCD to fix this? Also i know the "use legacy" option will not work since im using EXT4.

My question is how to be able to boot ubuntu again? It only loads the minimal screen and has "grub>"

I have tried to type "boot" and is says "kernal is not loaded"

:rage:

Addendum:

Last time i set up my quad boot i got help from

"computer guru" and "terry" << you guys rule and thank you.

I think now with my second machine and it running only 2 OS's now i should be able to get it, but im not :frowning: I think its the grub 2 and EXT4 not playing nice with windows......
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hi Rave Junkie :smile:

Just add a new GRUB2 entry in EasyBCD and check the box that says "GRUB is not installed to the MBR"
 
#3
HA HA love you guru, helping me again. I hope its that simple and i will feel sorta dumb but as long as it works.

I am at work now then get off in a hour and will go to gym, then will go home and shower and then test this and post my findings.

Thanks again guru *props*
 
#5
Nope, no luck the "grub is not installed to the mbr" is not a option when you select the grub two. I can use that option when selecting grub legacy but that dont help since im using 10.10 and it uses EXT4 :frowning:

*bangs head on wall*

Addendum:

When i get off work (working 12hour, network admin) I am going to load super grub, boot ubuntu, reinstall grub2 IN ubuntu, then im going to run repair disk and reinstall BCD loader, then edit it with easy BCD edit when i can get back into winblows.....
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Good luck >.<
 
#7
FIX update

FYI for any others, i was having a issue with grub 2 due to i made partions for boot, root, and swap, so the Easy bcd was not figuring it out or something, i reinstalled grub via the alternate install cd for ubuntu then repair disk for winblows and BAM all good now.
 

mqudsi

Mostly Harmless
Staff member
#8
Great to hear, RaveJunkie! Thanks for sharing that with us.