Unable to boot Ubuntu using EasyBCD with Win 7

Mark Phelps

Active Member
Am experimenting with different ways of multi-booting my tablet PC. I have three OSs installed (in the following order): Vista, Win 7 RC, Ubuntu 8.04. I had previously set this up with GRUB installed to the MBR and used the menu.lst file to select the OSs.

Yesterday, when trying to boot into Win7 got an error message of no operating system found! So, last night, restored Win 7 boot from the Win 7 DVD -- which, of course, overwrote the MBR.
So, I used the SuperGRUB disk to restore GRUB to the MBR and I can boot OK now.

But, every time I get a Vista or 7 problem, I have to go through this reloading GRUB each time, and I thought I'd try using EasyBCD -- since I'm planning on migrating to Windows 7 nearly full-time.

So, I installed Beta 2 Build 63 (which I what I had downloaded a while back), went into EasyBCD, and added Ubuntu as a boot selection from the Linux tab.

But when I choose that, the screen blinks for an instant and returns me to the boot menu.

So, this morning, I downloaded and installed EasyBCD Beta2 build 65 -- and did the same thing again. Same results.

So, I used the Ubuntu LiveCD to install GRUB to the Ubuntu partition. And tried again, thinking, that maybe if GRUB is there, the menu option would work.

I tried two different options -- with and without the GRUB is installed to the MBR box checked -- no success either way.

I'd like eventually to just use EasyBCD and leave the MBR alone but if I use the Win7 DVD and restore the MBR, without EasyBCD working, I would lose all access to Ubuntu (which I need for the short term), and would only have to go through the restoring GRUB to the MBR stuff again.

So, I'm puzzled what to do next. Any ideas?
Hi Mark, welcome to NST.
After Ubuntu 8.04, grub syntax changed and EasyBCD 1.7 didn't support the change.
Support was included in EasyBCD 2.0, but to be honest, I've never come across the situation where someone used Easy2 with an old release of Ubuntu, and I'm not sure whether Guru included backwards compatibility or not.
Try using EasyBCD 1.7 to add the Linux entry (don't tick the box, unless Linux is on a different HDD from the BCD. Ticking the box installs Neogrub to bridge between the HDDs (overcoming a grub bug))
If you need Neogrub, uninstall any previous version first.
Last edited:

Thanks for the rapid response. Have just downloaded EasyBCD 1.7.2.

As to NeoGRUB, I installed legacy grub from Ubuntu 8.04 disk, so do I need to download and install NeoGRUB as well? OR is that automatically incorporated into EasyBCD?
It's automatically installed if you tick the box, but it can be manually installed /uninstalled from the Neogrub tab in EasyBCD
Sorry ... didn't work. Same results.

Here's the contents of the BCD panel:
There are a total of 3 entries listed in the Vista Bootloader.
Bootloader Timeout: 30 seconds.
Default OS:

Entry #1

Name: Windows 7 RC Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Windows Vista (TM) Business
BCD ID: {d1893ae3-c3de-11de-84f7-eb7369700847}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #3

Name: Hardy Heron 8.04 LTS
BCD ID: {d1893ae9-c3de-11de-84f7-eb7369700847}
Drive: D:\
Bootloader Path: \NST\nst_grub.mbr

Here's the stanza in the menu.lst file for 8.04:
title Ubuntu 8.04.3 LTS, kernel 2.6.24-25-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-25-generic root=UUID=ae6180dd-5e7f-4dc1-8f1e-77350e4eb979 ro quiet splash vga=792
initrd /boot/initrd.img-2.6.24-25-generic

Is the BCD ID the same thing as the UUID? If so, and I manually edit the BCD ID of the Hardy Heron entry to match the UUID in the menu.lst file, should that work?
If I were you, I'd switch back to the latest Beta build, and upgrade 8.04 too, but I have no attachment to Linux (I just use it like a large utility to circumvent Windows security) and can happily reinstall it at will without losing any user data.
If you are concerned to keep the HH level, you'd better wait around for one of our Linux boys to appear.
I'm afraid you've run up against the limit of my Linux expertise, and my hunch about old Ubu/new Easy was evidently mistaken.
No the BCD ID and UUID are two separate things. BCD ID just identifies an entry in Windows BCD. The UUID identifies a paticular disk/partition. Fix that and try this entry with the right UUID:

title Ubuntu
find --set-root /boot/vmlinuz-2.6.24-25-generic
kernel /boot/vmlinuz-2.6.24-25-generic root=UUID=ae6180dd-5e7f-4dc1-8f1e-77350e4eb979 ro quiet splash vga=792
initrd /boot/initrd.img-2.6.24-25-generic
If I were you, I'd switch back to the latest Beta build
Tried that first and was told to use the 1.7.2 build instead.

, and upgrade 8.04 ...
Sorry ... can't do that. Newer versions don't detect the hardware properly, so I'm stuck with 8.04 on this box.


No the BCD ID and UUID are two separate things. BCD ID just identifies an entry in Windows BCD. The UUID identifies a paticular disk/partition. Fix that and try this entry with the right UUID:

OK, will try that.
Last edited:
You don't necessarily have to use UUID mode. It's preferred, but not imperative.

i.e. this will also work:
title Ubuntu
find --set-root /boot/vmlinuz-2.6.24-25-generic
kernel /boot/vmlinuz-2.6.24-25-generic root=/dev/sda4 ro quiet splash vga=792
initrd /boot/initrd.img-2.6.24-25-generic

Of course, a4 is specific to this example.
Well, THAT could have gone a lot better!!

Made the changes indicated -- to the stanza in the menu.lst file. Rebooted.

Selected that entry from the GRUB menu. Failed on GRUB error 15!

But, I figured, maybe NeoGRUB would work anyway. Rebooted. Selected Hardy Heron entry from the Windows & boot loader menu. Quick screen flash. Back to the same menu.

So I thought, OK, this doesn't work either, so I'll boot back into Windows 7, remove the Hardy Heron entry (so I don't forget and accidentally choose it) and post this message.

Selected Windows 7 -- loading screen comes up -- BSOD! Stop code 7B. Tried again. Same thing.

Tried again, pressed F8, hoping to see a selection that would allow me to run startup repair. No such option (that I could see). DID boot into SAFE mode, though.

Booted from Windows 7 DVD. It offered to run repair. I let it start. 15 minutes later, still have sliding cursor but no reboot. Shutdown machine.

Rebooted. Still get BSOD. OK, didn't expect it to work since I had shutdown the machine.

Rebooted from ATI Home CD. Restored from backup made this morning. Rebooted. OK now.

... so NOW it REALLY gets interesting!!

Booted into Ubuntu. Modified menu.lst to remove the changes. Saved the file.

Rebooted. Selected Windows 7 again. BSOD -- again!! Flashed quickly but it had the same stop code as before.

Did the ATI restore again. Back to working again (or I couldn't be posting this).

Installed the lastest Beta of EasyBCD 2.0. Used it to remove the Hardy Heron entry (since it doesn't work anyway).

I think that's it for EasyBCD experimentation for now.
OK ... I'm back!

My tablet PC crashed over the weekend and was unbootable. Good news is that, due to the tutorials here and EasyBCD, I was able to get it booting again.

But, had to rewrite the MBR in the process.

Given the HOURS it took to get the machine working again, I'm now nervous about messing with the MBR to reinstall GRUB to get to my Linux install. So, I booted into an Ubuntu LiveCD, installed GRUB in the Linux partition, rebooted into Seven, added an entry to the boot loader menu for Linux. Rebooted.

Selected the Linux entry, get "GRUB" briefly on the screen, get message that it's starting up -- quick flash and back to the OS menu.

As an alternative, I had first tried NeoGRUB, hoping that I could simply substitute my existing menu.lst file for the one that NeoGRUB uses -- but the syntax is evidently very different between the two menu.lst files.

So, I'm trying to get the simpler version working.

Anything else I could try?
Did you select GRUB2 or GRUB (Legacy) in the EasyBCD drop-down menu?

Since I'm running Hardy (8.04), it uses legacy GRUB, so I selected GRUB (legacy).

I've actually tried two different approaches:
1) Using legacy GRUB installed to the Ubuntu partion, adding a Linux entry in EasyBCD (Beta 2 build 76). Just get a brief flash and return to the boot selection menu.
2) Installing NeoGRUB, adding an entry in EasyBCD using NeoGRUB, modifying the menu.lst file to add two stanzas -- one for Ubuntu, one for ISOLinux. Boots into a text mode screen with GRUB version at the top and GRUB> prompt.

One option I'm not clear on is the "GRUB is not installed to the MBR" check box. Since GRUB is NOT installed to the MBR, I check this, but when I do, it greys out the entry above that points to the partition on the drive where GRUB is installed. I would think that when you have GRUB installed to the Ubuntu root partition, you WOULD want this box checked and EasyBCD would need to know which partition contains GRUB.
OK, that option is a weird one. We didn't know what to call it so that's the name we gave it, but what it means is "I have a /boot/grub/menu.lst file that came with my default installation, but GRUB itself isn't installed to the MBR or Bootsector so use NeoGrub with the existing configuration file" :smile:
The "Grub is not installed..." box installs NeoGrub, and configures the menu.lst to search all partitions for Grub's menu.lst, and uses it to boot. Try checking it, and see if you can boot then.
I too would love to know what can be done when selecting the NeoGrub option on the Windows boot manager drops you into a grub prompt. I have the same problem after updating from EasyBCD stable release to the beta version (the current build). NeoGrub from the stable release didn't work for me to boot into Linux Mint because I installed into an ext4 partition, but the 2.0 version works fine -- except that I can't get an actual NeoGrub menu, I just drop into a bare shell like Mark reports when he tries to use NeoGrub.

The weird thing is, if I type the commands into the shell that are listed in my menu.lst file (like root (hd0,2) and kernel /boot/vmlinuz-whatever), Linux Mint boots just fine. I just can't get the menu to appear instead of the bare prompt. And I used the same menu.lst from before I updated to EasyBCD 2.0 beta, where NeoGrub would show me a menu like it's supposed to but it just couldn't read the ext4 file system. I'd love to know what can be done to fix this, and I bet if Mark could get into his NeoGrub menu instead of dropping to a bare grub prompt then he could fix his problem too.
Golly do I feel stupid!!

The reason is was not working is because some idiot (me) forgot to reset the GRUB menu to its earlier state.

I had to change the menu a while back to force the loading of Windows 7 by default and suppress the GRUB menu -- because the other person using it wanted it that way. I THOUGH I had changed it back, but apparenly had not. So, what it was doing was launching GRUB, reading the proper menu.lst file, defaulting to OS stanza "0" (which is Windows 7), and trying to launch that -- which failed. Because I had "hiddenmenu" uncommented, I wasn't seeing anything -- explaining the quick screen flash and return to the menu.

So, I did the following:
1) uncommented "hiddenmenu"
2) removed the Windows 7 stanza from menu.lst
3) rebooted

NOW, the Linux menu selection works!! (As is should have all along, had I made the right changes)

You can mark this one as SOLVED.
What doesn't kill us - makes us stronger.
(Isn't it a relief when you finally get that Eureka! moment)