Unable to boot Win 7 64bit with EasyRE or BCD 2.2

#1
Machine is an i7 with 9GB RAM RAID 0 (Two ~500GB drives) with 20+% free). Running Win 7 64 Ultimate.

Can see the drives using System Recovery Options from Win 7 install disk. Tried the usual routine of repairing the boot files. Startup Repair tells me there is a bad driver issue. Most likely problem is removal of Acronis - which will never be installed again!

There are restore points but those will not work. The message is there are no restore points.

EasyRE said it does not see an installed OS. The program was burned to a CD.

EasyBCD 2.2 is on a clean thumb drive. When trying to boot using it the error message said "Error loading operating system."

Suggestions appreciated.

Thanks.

Addendum

To clarify the 'restore' points, they show up but none work using the 'System Restore' recovery option.
 

mqudsi

Mostly Harmless
Staff member
#2
I would guess it's the RAID0 that's giving you a hard time, both with Startup Repair and EasyRE.
Have you updated your RAID configuration or drivers anytime recently?
 
#3
I would guess it's the RAID0 that's giving you a hard time, both with Startup Repair and EasyRE.
Have you updated your RAID configuration or drivers anytime recently?
No driver change recently nor update of the RAID0 config.

The system is always updated using tools like Scunia to keep software current.

Last driver update was about two months ago with Driver Genius.

Everything worked fine until a few days ago after trying to clean up the Acronis files...which I suspect are the source of the problem and other unused files.

Two restore points were set before that process but none work now when using System Restore.

Addendum

Seems there are two options to try at this point. One is to use diskpart to setup a separate partition upon which to install Win 7. This provides accessibility to the files.

The second is to replace the registry with a complete backup available made a few days before the system crash. If this is a feasible option I am not certain how to perform the operation in DOS, aside from carefully or not at all.
 
Last edited:

Amadeus

New Member
#4
Back trying to solve this boot problem after a short holiday.

The error code when trying to boot into Windows is 0x07b

The automated repair function of the Windows 7 version of EasyRE results in the following message:
"Unable to find any valid Windows partitions on this computer! Make sure all hard disks are attached. If they've been lost due to disk corruption, you can try to manually recover the partitions with testdisk at the command prompt."

TestDisk does not see the drive.

Browse/Backup sees only a /home/neosmart partition of 2.9 GB.

Using a Win 7 CD booting into the repair section - the drive displays the correct OS and size. Getting to a command prompt in the 'repair' section and using 'dir /p' command, the complete file structure shows up on the drive.

I've been through the 'bootrec' commands: bootrec /scanos; bootrec /rebuildbcd; bootrec /fixmbr; and, bootrec /fixbootas. bootmgr and other options related to trying to boot the system. The '/rebuildbcd' option shows it is successful each time it is tried. The 'Total identified Windows Installations' shows up at 1. However, the boot still fails. When the 'Windows Installs' is checked again it has reverted to 0.

Are there any other steps to try aside from a clean install? Is there a way to use the backup copy of the registry (made about 2 days before the crash) to replace the existing one - or will that just be a cut and paste exercise with no functional outcome?

Any further suggestions to solve this issue would be greatly appreciated.

-Mike
 

mqudsi

Mostly Harmless
Staff member
#5
My advice would be to copy the files from the RAID 0 to a single-drive setup, get into Windows, and reinstall all storage-related drivers from there before re-creating the RAID 0 setup.
The reasoning being that this is almost certainly an issue with Windows (both installed and recovery) misunderstanding something about your RAID setup.

(You are certain this is a RAID 0 and not a RAID 1 config? I don't mean to be insulting or anything, just want to verify that as all this makes perfect sense for a RAID 1 config where changes are being made to one of the mirrored volumes and not the other, and on boot via RAID drivers the changes that do not sync are being automatically reverted.)