Unable to get Ubuntu to multiboot.

#1
I have 4 OS's on this computer on 3 hard drives.
Vista, storage and Susu Linux on C:
Windows 7 and storage on E:
Ultimate Edition Linux (Ubuntu 9.04) G:

Everything was going fine with the Vista and Windows 7.
I then pulled the power on Vista and Windows 7 drives and installed Ubuntu on the new Drive.
The first part was NTFS storage and the Linux partitions were at the upper end of the drive.
It boots good and the program ran properly..
I connected all drives back up updated EasyBCD to the latest 2 beta, reinstalled the things on the boot C: drive (Vista) and installed a Linux boot function using the primary Linux partition for the boot partition.

I have tried everything.. I can't get the new Linux to boot. I even tried to boot it from the primary partiton (G:smile: , no luck

The new linux will boot properly when I set up G: for the Boot option in the BIOS..
There has to be a simple way for me to get this to run.. I have tried most of the things I see on the forum. I assume that the "primary linux" partition is what I am supposed to use in the EasyBCD linux set up??

Help.. It's probably something simple I'm not doing..
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Jim, welcome to NST.
Delete the Linux entry in EasyBCD then add it again, selecting the Linux partition from the dropdown where grub was installed and tick the "grub isn't installed..........." box. (Grub on a different HDD to Vista has a problem recognizing it's not the boot drive, and EasyBCD will workaround the problem by installing Neogrub and effecting a chain to the grub on the other HDD)
 

shinji

New Member
#3
Ahh... That explains my issue then. When I tried to boot it just showed "GRUB" and that was it. I didn't realize that would be an issue. My Windows 7 install is on one drive with the Ubuntu install on the other drive (kinda in the middle).

EDIT: Yep. Worked like a charm. Still wondering why it fails to shutdown the computer. Happen on the live cd though too. Just goes to a black screen with a flashing cursor (underline). That is something for another thread though and on the ubuntu forums actually.
 
Last edited: