Unable to load Windows after using EasyBCD to write MBR

#1
Hi, I have a dual-boot Ubuntu/Windows 7 Thinkpad x120 that I'm trying to remove Ubuntu from (decided running Wubi is sufficient for my purposes). I used EasyBCD (The Non-Geeks Guide To Safely Uninstall Ubuntu From A Dual-Booting Machine) to write MBR. Now Windows won't load! I get an error Windows failed to start... 1. Insert your Windows installation disc... 2. Choose your language.. 3. Click "Repair your computer" If you do not have the disc, ... File: \Boot\BCD Status: 0xc0000098 Info: The Windows Boot Configuration Data file does not contain a valid OS entry. The Operating System Recovery Disc from lenovo (thanks Lenovo for sending it) boots to Lenovo Rescue and Recovery 4, or in "Safe mode with command prompt" but immediately crashes. Any advice on what to do?? Many thanks.
 

mqudsi

Mostly Harmless
Staff member
#2
#3
I don't think this is the problem, as I never got to the resize partitions stage. The failure to load windows came right after rebooting after writing MBR using EasyBCD...but I'm clearly in over my head here so that may be the problem.
It seems that the Windows Recovery Disk (High Speed System Recovery Disc Downloads) from NeoSmart may fix my problem. One question (maybe not the right place to ask this) - what is the best way to install the Recovery Disk onto a usb drive, as I do not have DVD drive on the computer I'm trying to save.
 

mqudsi

Mostly Harmless
Staff member
#4
You can use EasyBCD on another Windows Vista+ PC to create a bootable USB, copy the ISO to the USB, and add an entry to that ISO image to boot from.
 
#5
Ok...I paid and downloaded the Windows 7 recovery cd (32bit and yes my system is 32), formatted the USB drive, copied over the extracted files from the Windows 7 recovery cd, used EasyBCD to create a bootable USB (http://neosmart.net/wiki/display/EBCD/Creating+a+Bootable+USB+Drive), added an entry for Windows 7, and started up my computer with this usb.

Still, no success. This time I get the Windows Boot Manager with the error:

"File: \Windows\system32\winload.exe
Status: 0xc000000e
Info: The selected entry could not be loaded because the application is missing or corrupt."

I tried again but without the EasyBCD step (just copying the Windows recovery files to the usb) and this time I at least got into Windows Recovery...but still no luck. I couldn't even do System Restore because the program couldn't find the operating system.

Again, all this started when I used EasyBCD to install the Windows bootloader to the MBR on a system that was dual-booting Windows 7 and Ubuntu. Ever since I did "Write MBR" I have been unable to boot either system.

ANY idea what I'm doing wrong here?

Addendum:

UPDATE: at least part of the problem appears to be that System Recovery can't load my operating system because I need to load drivers for it to find the operating system. But, I have no idea what drivers to load...any ideas here?
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#6
Sorry, but that guide you were using is wrong.

Then go to “Bootloader Setup“, choose the partition that you want to boot from and click “Install BCD“. Continue by choosing your version of Windows under “MBR Configuration Options” and click “Write MBR

You'll note that the section referred to in red above is "Create bootable EXTERNAL media" (my capitals) It's for creating e.g. a bootable flash drive. Your HDD is already bootable and just needed the "install Vista/7 bootloader" from the other half of that page.
The two functions are quite separate.

You should still be able to recover your W7 boot with the repair disc as in CGs first reply, but that inability to find an OS to repair, can happen if you have multiple HDDs.
Try removing all but the one with W7 on if you have more than one, then boot the CD. (USB drive)
If that's not the case, don't go to the "install drivers" page, just click "next" without picking an OS.
That will sometimes complete the first repair anyway and the OS should reappear for the second and third repairs.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#7
Nice catch, Terry. I completely missed that, I guess I just assumed that guides are always right :smile:

I can't find the dude's email anywhere, but he's going to mess up a lot of peoples' computers... :S
 
#8
Wow...thanks for looking into this!

Though, I'm still having trouble. It won't Repair and Restart because "Failed to save start options" and when I select next I get the error "The system cannot find the file specified. (0x800700002)

I've learned my lesson about following guides online...I also thought that they were "right".
 

mqudsi

Mostly Harmless
Staff member
#9
Now that we know what you did wrong, I can tell you what's the problem: your boot partition is no longer active. You need to use the command prompt utility from the repair console to use diskpart to set the partition active.
 
#10
Okay...so I need to change the active partition? I used DISKPART and see 5 partitions in DISK 0 (my only HDD). Based on size, I think partition 1 is the SYSTEM DRV and partition 2 is the C: drive. I tried setting the active partition to both and restarting, and neither worked.

When I boot using the Windows Recovery usb and try to do Repair and Restart, I get the error message "Failed to save startup options". When I click view details, I see the following:

The following startup option will be repaired:​
Name: {bootmgr}​
Identifier: {9DEA862C-5CDD-4E70-ACC1-F32B344D4795}​

The following startup options will be added:​
Name: Windows 7 Home Premium (recovered)​
Path: Windows​
Windows Device: Partition=C: (54042 MB)​

Name: Windows Recovery Environment (recovered)​
Path: Recovery\WindowsRE\Winre.wim​
Windows Device: Partition=D: (1200 MB)​

A copy of the current boot configuration data will be saved as: C:\Boot\BCD.Backup.0002​

but Windows 7 is still not loaded as an operating system. What can I do so that these startup options are saved and Repair and Restart can work?

THANKS again!
 
#11
SOLVED!

Whew...after LOTS of messing around, I finally was able to get back into Windows.

In case anyone else runs into similar difficulty following maliciously wrong online guides, here's what I did:

1) Use Windows Recovery to access command prompt.

2) Use DISKPART to set C: partition as active (this was a bit confusing as my Lenovo had 3 partitions, a SYSTEM_DRV of 1.2GH, C: and Lenovo Recovery Q: partition of 10GB. The C: partition needs to be active as this contains the Windows operating system).

3) In command type:

bcdboot c:\windows /s c:


This regenerates the BCD file needed on C: drive so Windows can install. Kudos to: http://www.hanselman.com/blog/SwitchingMyWindows7BootDiskFromDToCWithBCDBootRatherThanBCDEdit.aspx
for pointing this out.

4) Reboot (without recovery media) and Windows is restored!

A note: I could never get the Manual Repair or Nuclear Holocaust options http://neosmart.net/wiki/display/EBCD/Recovering+the+Vista+Bootloader+from+the+DVD
to work for me.
If i typed "bootrec /RebuildBCD" it asked if I wanted to add C:Windows installation to the boot list (which I really did!) but it would then give the error "The requested system device cannot be found"
If I used

bcdedit.exe /store c:\boot\bcd.temp /create {bootmgr} /d "Windows Boot Manager"bcdedit.exe /import c:\boot\bcd.temp
I would get errors that either couldn't write the file, or couldn't find it...not sure why, but bcdboot works so use it!

Finally, I want to emphasize that this was NOT a problem with EasyBCD which appears to work great and do everything as promised, but my own failure to naively follow a guide that appeared online that misapplied EasyBCD.
 

Terry60

Knows where his towel is.
Staff member
#12
I think maybe you set the wrong partition active and that's why the "startup repair" from the repair disc wouldn't work.
W7, by default, doesn't put its boot files on the C disk with the OS, it creates a "System Reserved" partition for the boot files.
OEMs often turn this into a custom boot/recovery partition.

If I'm right, you should find remnants of the old boot process on (probably) the "SYSTEM_DRV" you mentioned, and what you did with bcdboot is effectively what EasyBCD does for you with the "change boot drive" function.
 
#13
Please help - I have a similar problem

Hello

I was trying to remove Ubuntu from my Windows 7 Vaio because it doesn't even work and now I can't boot windows. Same error you were getting but I don't seem to have a recovery disk. I'm only accessing the internet now by using an old IBEX Ubuntu disk I found and booted it without changing my computer. I believe I followed that same guide you did - installed EasyBCD, followed instructions and got to the part where it says to try booting the system to make sure it works before moving on. Well, it doesn't work.

I'm a little confused as to how to proceed now. You said in your last post to access windows recovery to access the command prompt. but since I can't even access windows I can't really make a disk then? Unless I can access another computer with windows 7? my computer at work has vista but not 7. Will I have to purchase one?

Can I do what you said in the ubuntu command prompt? I tried but it says bcdboot: command not found

Please help - I'm not panicked yet but getting there.

thanks so much.
 
Last edited:
#15
Thank you. I'm not especially educated on the ins and outs of this so sorry if this sounds ignorant. I looked over the page you sent me to but it seems to assume you have a recovery disk - which I unfortunately don't have. Do I have to have one to fix this problem or is there a way around it?

Addendum:

Hello again, I'm back. It's a new day and my mind is a little clearer now. Looking at the instructions again, should I just go ahead and download the Windows 7 Recovery Disk? My windows isn't shot - just the bootloader correct?
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#16
That's the most likely scenario, and the recovery CD should fix that.

The only case where it would be actually gone for good is if in removing Ubuntu you accidentally deleted the Windows partition, which I highly doubt.

Good luck.
 

Terry60

Knows where his towel is.
Staff member
#17
If you know someone else with W7, you can get them to create a free copy for you.
Control Panel > Backup & Recovery > Create Repair Disk
 
#18
Thanks! Got a hold of a friend's windows 7 recovery disk and was able to fix it easily and reclaim the disk space ubuntu was using. Tomorrow's task - make my own system recovery disk. Thanks for all the tips. One day I will hopefully get back into Ubuntu when I have time to play with it.