Unable to read system disk

khoma

New Member
#1
Hello

I seem to have a mistake in my configuration somewhere, was hoping someone might be able to spot it. I am getting an error saying:

Code:
BootPart 2.60 Bootsector (c) 1993-2005 Gilles Vollant http://www.winimage.com/bootpart.htm
Loading new partion
Bootsector from C.H. Hochstatter
Cannot load form harddisk.
Insert Systemdisk and press any key.
I realize other people have had this problem, and I have tried searching for a solution, but unfortunately it seems the most common occurence of this message is usually followed by Grub booting upon pressing a key. Mine doesn't, it just stops there.

I think I have a fairly simple setup. My computer contains three drives:

Drive 1:
Simply one partition containing Windows Vista

Drive 2:
- 200MB /boot partition ext2 with grub installed on boot sector
- 8GB swap (I may want to open 100 instances of firefox some day!)
- 100GB / partition ext3.
- 80GB NTFS partition.
The partitions are listed in order of appearence on the drive.

Drive 3:
Pretty much irrelevant, just one 500GB NTFS partition with nothing on it atm.

The /boot partition on drive 2 would thus be hd(1,0) in grub and easybcd. I have followed the guide in the Wiki, and added a Linux grub entry on Drive 1, Partition 0. This should be it, shouldn't it? Yet it's not working. I'm not really sure what kind of additional info might be useful here.. settings look like this atm:

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {45b65a40-1f56-11de-8a1f-dbe32dae6e68}
displayorder            {45b65a40-1f56-11de-8a1f-dbe32dae6e68}
                        {59aeb707-1f8f-11de-82b5-00179abb20ec}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 20

Windows Boot Loader
-------------------
identifier              {45b65a40-1f56-11de-8a1f-dbe32dae6e68}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  en-US
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {45b65a41-1f56-11de-8a1f-dbe32dae6e68}
nx                      OptIn

Real-mode Boot Sector
---------------------
identifier              {59aeb707-1f8f-11de-82b5-00179abb20ec}
device                  partition=C:
path                    \NST\nst_grub-ED77CB55E60D194EE0FDDD83C037D5D4.mbr
description             Arch Linux
I've tried using NeoGrub as well, didn't really help much. Any help would be greatly appreciated!
 
#2
Hi khoma, welcome to NST.
Have you tried the [thread=642]latest beta release of EasyBCD[/thread]? It supports more Linux features. Try adding a new entry with the beta to boot Linux with the "Grub is not installed..." box *unchecked*, and if that doesn't work, try it again with it *checked*. :wink: That should soon see your Linux install booting from the Vista bootloader.

Cheers,

Jake
 

Terry60

Knows where his towel is.
Staff member
#3
If Vista is your "system" partition, since it's on a different disk to Linux you'll need to tick the "grub is not installed" box and go the Neogrub route.
Do as Jake says and use the 2.0 Beta.
1.7 is not compatible with the latest grub syntax in the newest Linux builds.
 
#4
Terry's right. I'm sorry. I "forgot" about the standard Linux option not working when Linux is on another hard drive. So you will most certainly have to check that box then. :wink: And if its still not working after that, then we can help you setup the NeoGrub menu.lst manually.