Unable to restore Vista

#1
Hi All.

This is the first time EVER that I've posted anything on any forum, so please be kind...

My parent's laptop was stolen. We do have it back now, but the perpetrators installed Windows 7 - thankfully mum had a password on her account.

I was able to use the 'move' command (F8 - Repair Computer>Command Prompt) and move the Windows 7 files to a temp directory then copy Vista files from Windows.old which seems to be fine, but I'm a tidy person and Vista is not allowing me to delete the Windows 7 installation files - even though I am administrator, so I thought that a full restore would be easy. :brows:

Anyway, I'm trying to restore it back to Factory settings. I don't have the Vista CDs, but I do have D:\RESTORE. I'm having a major headache trying to access it. I've downloaded the Windows Vista Repair Disc. It asks to press any key to boot from CD which is fine. It comes up with the Windows Vista install screen and I select "Repair your computer". The System Recovery Option only lists Windows 7 as the operating system. Because Vista is not listed, it asks to load drivers...(?) If I cancel this, it gives me the same options as pressing F8, however when i choose Option 3 - Windows Complete PC Restore, it gives the message "No valid backup locations could be found". I OK this message and then insert the DVD with the Factory.wim image, but it just doesn't see it.

I cancel this and select the Command Prompt option. It allows me to see the partition (D:\RESTORE) but I don't know which file to use.

Someone, please help. I've been sitting here for the last 7 hours messing about, searching the internet, pulling my hair out trying to restore this thing.

I hope I've not gone on too much. I just want to give as much info as possible.

Thanks

Addendum:

Sorry...Should have said it's a Dell Inspiron 1318 - Thanks.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
#3
Hi Terry.

Thanks for the website. Still no luck though. It 'looks' like Vista O/S when it's switched on, but I think it's actually still using Windows 7 files. When I press F8, and select 'Repair' the splash screen is Windows 7 with the Windows 7 options as described above.

I think all the 'Move' command did was just move Vista files from the Windows.old directory. I should have then been able to restore to factory settings using the RECOVERY partition. I've searched the internet and it's so confusing. "...Copy the image file from the Dell directory to CD, but make sure you create a bootable CD using this software or that software because it won't automatically boot after restore..."

Why have they made it so difficult to restore to Factory settings? How hard can it be. Bring back the days when PCs where shipped with Restore CDs....!!!!

Please, please, please...do you have any other suggestions that I can try??

Thanks in advance.
 

Terry60

Knows where his towel is.
Staff member
#4
You did the "Dell factory Image Restore" from F8 and it worked but the spash screen is still W7's ?
What does it say when you click start > run and type winver ?
 
#5
Hi Terry,

No. I wasn't able to do the "Dell Factory Restore". When I click F8, it gives me the Advanced Boot Options. It asks me to "...Choose Advanced Options for: Windows 7...". When I click 'Repair Your Computer" it loads the files, but it gives me the Windows 7 splash screen. I select the Keyboard and then it asks for a user with Admin credentials. It lists the Windows 7 user and not the users that have been created in Vista. I select the user and the System Recovery Options window appears. There are 2 options:

1. "Use recovery tools that can help fix problems starting windows. Select an operating system to repair. If your operating system isn't listed, click Load Drivers and then install drivers for your hard disks." Windows 7 O/S is the only one listed.

2. "Restore your computer using a system image that you screated earlier."

When I select Option 2, it can't find a system image on the computer. I retry with the Factory.wim that I copied to a DVD, but it still can't find it. When I cancel it it gives me the usual 5 options after clicking F8 and Repair Computer.

When I use the Vista Repair Disk it takes me straight to the 5 options. I click Windows Complete PC Restore. It lists the Windows 7 O/S. When I click 'Next' it gives me the same message as option 2 above.

Should I not have moved the Windows Vista files from WIndows.old...?

Sorry about this. Thanks in advance for your help.
 

Terry60

Knows where his towel is.
Staff member
#6
No you shouldn't have copied files from .old.
That's there for Windows 7 to use if you ask it to backlevel to Vista.
If the thieves have been kind enough to donate a £200 upgrade to W7, why don't you keep using it ?

Can you see the contents of the D:\Restore folder ?
You might be able to identify the "factory reset" program and execute it directly.
 
#7
Hi Terry,

Should I copy the Windows 7 files back to Windows and then ask it to revert back to Vista? I can see the contents of D:\RESTORE, but I don't know what to do with it. Where is the 'Factory Reset' program and how do I execute it?

The Windows 7 installed is not genuine. It keeps popping up with the Authenticate Windows message.

THanks for your time Terry.
 

Terry60

Knows where his towel is.
Staff member
#8
Can you post a list of what's in the Restore folder.
 
#9
There are 6 directories
  • dell
    • image<dir>
      • Factory.wim
  • Program Files
    • Common FIles<dir>
      • microsoft shared<dir>
      • System<dir>
    • Internet Explorer<dir>
  • Sources
    • en-US<dir>
    • recovery<dir>
      • en-US<dir>
        • PssWiz.exe.wim
        • RecEnv.exe.wim
        • StartRep.exe.wim
      • Tools<dir>
        • winreconfig.xml
      • PssWiz
      • RecEnv
      • StartRep
  • Tools
    • imagex
    • intlcfg
    • PCRestore
    • wimfltr
    • wimfltr.sys
    • wimgapi.dll
    • wimscript
  • Users
    • Default<dir>
    • Public<dir>
  • Windows
    • Boot<dir>
    • Branding<dir>
    • debug<dir>
    • en-US<dir>
    • Fonts<dir>
    • Globalization<dir>
    • Help<dir>
    • inf<dir>
    • L2Schemas<dir>
There are more files in some of the directories, but there are loads to list.

I did try double clicking the PCRestore file, but it didn't work - a DOS screen flashed up and disappeared. I did also try it through the commant promts (F8 at startup) but nothing happened.

In my infinite wisdom, I decided to undo the 'Move' commands I ran in the beginning and copy back the backup of the Windows 7 files (Windows, Program Files, Program Data, Users, Documents & Settings) using the Command Prompt (F8 at startup). (I did copy the contents of D:\RESTORE to DVD before hand though!) Now when I boot up, it boots to Windows 7, however, it displays the message:-

The procedure entry pointDwmHintDxUpdate could not be located in the dynamic link library USER32.dll

This indicates to me (I could be wrong) that the Users dir has not copied over correctly. It logs me in with a temporary profile, but I can't do anything. When I select anything from the start menu - My Computer, Control Panel, I get the message No such interface supported.

I have, however, managed to get a Reinstallation DVD for Vista (It came with my friends Dell system). The only thing is it's 64bit. Will this make a difference? I guess I can't make it worse that I alread have...:scared:

Just want to say that your help is very much appreciated - thanks!
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#10
#11
One word...

GENIUS!! :booyah:

I am so happy. I actually had the Windows Vista Repair Disk in the drive as opposed to the Vista Installation DVD and it allowed me to do it.

Thanks so much Terry. Really appreciate it