Unbootable Win 7 64 RAID 0

#1
I have a Gigabyte Intel based MB. Running Win 7 64. My boot "drive" is a RAID 0 array built and controlled by the Intel chipset and BIOS components. I uninstalled an application called BCU (I think it was u, it has been weeks), rebooted and -

The INACCESSIBLE_BOOT_DEVICE bug check has a value of 0x0000007B. This bug check indicates that the Microsoft Windows operating system has lost access to the system partition during startup.

I have tried repair many times when booting, and with the Win 7 distribution disk and recovery disks. It always says the repair can't be done.

I built a disk with UBCD4Win on it. It uses win XP. The RAID array seems functional.

There is a hidden partition that was created, I believe, by the Intel RAID system.

Here is what I see on the reserved space Win 7 puts on the disk for RAID. I am including the file dates because it gives a sense of where the files are from. March is when the system was built. It failed toward the end of June. I believe everything after June is something added by the attempted repair process.

Boot Folder:

A whole bunch of little files that I believe are language related
BCD 7/19
BCD.log 7/19
BootStat.dat

BootWiz Folder:

asm.bin 7/18

Sys Vol Info:

EFAData folder 6/24
lighteningSand.cfd 6/24
Mountpointmanaagerremotedatabase 7/19
tracking.log 3/27

On the C drive

.md 6/12
aawtboot.log 7/7
csb.log 3/27
install.log 3/27
mbam-error.txt 5/3 contains - error not registered
rhdssetup.log 3/27
vkit_ea 4/21

I don't see boot manager in the root of c.

I have tried following manual repair instructions at a number of places, but no joy.

Among other things I am getting confused over drive letters. There are those from the actual installed system. The reserved partition (space?) does not normally get a drive letter, but when looking from an external OS, it gets assigned one. And the C drive is of course changed. I have been unable to understand properly which set of letters is applicable for each of the multiple steps described in various repair scenarios. Many are UNIX based and are incomprehensible to me. That further increases my concerns for doing something bad.

Is there a fix this problem for dummies somewhere? I am really not getting anywhere.
 
#2
I have backed up the system partition and reinstalled it on a single drive. I went through the nuclear holocast boot recovery process. Booting starts but quickly gives me a 7b. The drives appear to be fine. Since I can't get it to boot, thee is no way I can see to fiddle with the drivers. At various times in doing all this I have managed to get to "use last good" and once the install disk seemed to think things were fixed.

Does anyone have any other ideas for me to try?