Unrecognized partition table, linux partitions don't start

#1
I have installed fedora 9, suse.11 and ubuntu 8.04 (all 64 bits) on a sata disk and use the ubuntu grub bootloader on the boot sector of this disk for the three distro's. On two striping disks I have installed vista with easy bcd. I used neogrub to access the linux distro's from the striping disks. I copied the menu.lst from ubuntu, mended the drive number and then tried to start the linux distro's with neogrub. While loading grub I get warnings for all distro's on an unrecognized partition table prior to the projection of the grub bootloader on the screen.
When I try to start the distro's I get the warning again and only ubuntu actually starts up. The other two give also other errors.

The warning reads for ubuntu:

Warning: Unrecognized partition table for drive 80. Please rebuild it using a Microsoft-compatible FDISK tool (err = 23) Current C/H/S/=16383/255/63.

The C figure may vary and the Fedora distro is given a different drive number: 83.

If I start up from the sata disk all distro's start up and no warning or errors are displayed.
What is wrong?
 

JustinW

Super Moderator
Staff member
#2
Probably something to do with your striped array. Not to mention that the entries in grub are not dynamically updated just because you switch around the boot sequence. They are stored in menu.lst and must be changed manually or temporaily at boot time when the setup changes. Regardless, I'd go ahead and use the one disk that does work and can boot all of the distributions without fail as the primary boot device.
 

eekie

New Member
#3
Hallo Justin,
I am familiar with all the things you mentioned so I settled for the practical solution: I now use grub again and start from the linux distro's disk using ubuntu's grub. I made a super grub disk to access suse and fedora after kernel update and as root I copy the changed item from menu.lst into ubuntu's menu.lst in order to update the bootloader.

However I have no answer yet to my original problem.
It was not simply a matter of adjusting the disk number assignment as I just copied ubuntu's menu.lst into NeoGrub. It is something else, I have never seen before on my other computers with comparable configuration.
Still wondering someone can explain me how I can modify the Easy BCD entries to get them working properly.
The reason is, I have a lot of trouble setting the right boot sequence in the bios of my motherboard. In many cases the bios hangs on saving when I have put the sata disk at pall position or if it does not hang it changes the sequence again by itself putting the other sata disk first. A hard reset of the bios is often required which entails manual setting of many parameters again. Sometimes I can't start the computer due to spontaneous reordening of the boot sequence.
I don't have the guts to safe my profile or to upgrade the bios as a lost already two MSI motherboards (chip death) because of that (lucky me within the warranty period).I have put this problem at the MSI forum but nobody has an answer although the problem is not uncommon on various MSI motherboards .
 

JustinW

Super Moderator
Staff member
#4
Alright, don't even bother with NeoGrub. It can be configured automatically for you when adding a new Linux entry to Vista's bootloader through EasyBCD. Saves ya a lot of time just copying w/e you need from one menu.lst to another (the one NeoGrub picks up on when you add an entry... it is usually the first linux partition on the disk with a menu.lst file that is used.)

Are you using an ide drive as well? You refer to one of your disks as sata but not the other one so I'm guessing that's the case. This also might be the reason for the BIOS symptons you are experiencing or problems in Windows where the disk is seen first.

For the most part EasyBCD (it may be very well problems with grub's entries) is really easy to configure. Let's assume for now that all of your Windows entries are working and you want to add a Linux entry to point to your disk containing all your various Linux distros. To do this, you would:

1) Open EasyBCD and click the "Add/Remove Entries" button
2) Go to the NeoGrub tab. If it has already been installed, uninstall it. Elsewise, just leave it alone.
3) Go to the Linux tab, and:
a) Enter a name for the Linux entry (you should prob. just refer to it as "Linux" since you have multiple distros on the disk.
b) Select the first disk/partition from the drop down that looks like a linux disk (Well usually have ext2fs by it if that is what it is formatted in)
c) Check the "grub is not installed to mbr" checkbox)
d) Add the new entry
Depending on whether or not you have added all of the entries from the other menu.lsts to the one that is being used (Again its most likely the first found on the linux disk, but check for ovbious clues such as the names of the first entries that appear on the screeen.), it may or may not display all of your Linux entries. Verify that you can boot into w/e is available, and if not take advantage of grub's edit feature. It'll allow you to temporairly change an entries parameters long enough to help you get your OS booting correctly.

If you need to use this feature, you'll most likely only need to mess with the "root (hdx,y) line where x represents the disk and y represents the partition. Try various combinations from 0 to 1 for the disks/x (if you only have two disks in the system) and y ammount of partitions (best trying out every number from 0 on up until you reach the max number representing one of your disks with the most (y) ammount of partitions.

Now if you have other problems with OSes like Windows, post any error messages/symptons you are seeing, your disk management screeenshot, and your boot.ini file so we can help you with that.
 

eekie

New Member
#5
My system consists of a MSI K9N2 sli platinum motherboard, AMD Phenom quadcore 9500 AM2 processor, MSI NX8800 GTS video card 4x corsair 1024 MB DDR2 memory, 2 striping sata raid disks, 2 sata disks and one IDE disk. What you describe in detail has been common practice for quite a while. I have tried the linux entry with the box not in the boot sector checked as well as neo grub.
Both produce the desired grub bootloader with prior error messages about the partition table.
Summarizing the bootloader:
Ubuntu 8.04.1, kernel 2.6.24-21-generic
Ubuntu 8.04.1, kernel 2.6.24-21-generic (recovery mode)
Ubuntu 8.04.1, kernel 2.6.24-19-generic
Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
Ubuntu 8.04.1, memtest86+
openSUSE 11.0 - 2.6.25.16-0.1 (on /dev/sdd2)
Failsafe -- openSUSE 11.0 - 2.6.25.16-0.1 (on /dev/sdd2)
Fedora (2.6.27.4-58.fc10.x86_64) (on /dev/sdd6)
Fedora (2.6.27.4-51.fc10.x86_64) (on /dev/sdd6)
Fedora (2.6.26.6-79.fc9.x86_64)
Fedora (2.6.25-14.fc9.x86_64)
Windows Vista/Longhorn (loader)

Only the ubuntu entries actually start up

The errors I get when starting f.i. Fedora:

Booting Fedora (2.6.26.6-79.fc9.x86_64)
root (hd0,5)
warning: Unrecognized partition table for drive 80. Please rebuild it using a Microsoft-compatible FDISK tool (err. 23). Current C/H/S=16383/255/62
Error 27:No such partition
Press any key to continue ...

When I edit the disk number, substituting 1,2,3,4 I get different error messages like file not found e.o.

The bootloader configuration is exactly the same I get when starting from the sata disk. And this one starts every entry flawlessly.
 

JustinW

Super Moderator
Staff member
#6
The bootloader configuration is exactly the same I get when starting from the sata disk. And this one starts every entry flawlessly.
If it starts every entry flawlessly then use it...

I never claimed to be a linux expert, but typically you want to stick to what works. When something does work correctly, then why complicate things?
 

eekie

New Member
#7
Hello Justin
Shear curiosity! I just want to know how the terra ingognita of the bootsectors works. I also outlined there are still unsolved problems with my bios making me long for the easy-bcd option.
There are always fields the high priests of computing want to keep to themselves in order to maintain their priviliged position. Good tools ( hard and software) to program death Bios or to create and modify bootsectors are rare. Standalone bootloader software like f.i. super grub and Bootit NG enable you to access any O.S. but don't let you gain insight into the bootsector programs.
Anyway for the moment being I will stick to the grub solution.
Thanks for your help