*Urgent* Vista/XP Will Not Boot

dstar

New Member
#1
Hello. I was doing a couple of things on my computer at the time that may have led to my computer being, well, inoperable. Ok, so first I edited the registry to allow Chkdsk to run at startup, because I wanted to make sure my disk was ok for partitioning. Also, there was an icon on the shutdown button indicating there were updates to be installed. So after rebooting, I put in a BootCD that had Partition Magic on it. I was planning on partitioning then. I started up the program and (I can't really remember it verbatim) it said that something was miss-matched, data or file systems or something, and would I like to correct it. I said yes. Then I restarted and low and behold I can't boot into Vista. It said that Windows failed to start, it may be due to a hardware change. It then gave me the option of starting the recovery console or starting windows normally. I chose the first. It scanned for Windows directories, and it couldn't find any. I then ran diskpart from the cmd to see what the deal was and I now had 1 recovery partition that shipped with the laptop, and 1 partition of 288Gb of unallocated space! I made peace with the fact that I would have to reformat, so I put in the recovery disk and selected disk 0 and the unallocated space. It gave me an error message, like windows couldn't find a drive with the correct specifications or something like that. I can't reformat, can't resize, nothing. I restart a couple more times, then I the "start windows normally" option, which just makes it flash blue and restart. It was then that when I selected recovery console and tried to install to the partition on disk0 that it said it couldn't find any harddrives. I also popped in my XP disk just to try and I got the same result. What should I do?

*Update* It's now saying my recovery disk is incompatible with this version of windows. This is the disk I got with my dell.
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Dstar, welcome to NST.
Vista uses the latest partition alignment standards, adopted because of the huge size of modern disks.
Old 3rd party apps, in the main, still use the old standards.
When you said "yes" to realligning , you b*gg*r*d your hard disk, and now nothing can be found.
Your best option would be to contact your PC manufacturer and acquire a bootable recovery disk from them.
Then you'll need to reinstall from scratch, unless you can locate a tool for realligning the partitions back to where they were.
 

dstar

New Member
#3
Alright I'm posting this just in case anyone else ever has a problem like mine. I talked to Dell and had to go into my BIOS and change my harddrive from ASCI to ATA. Then I was able to reinstall.
 

mqudsi

Mostly Harmless
Staff member
#4
Good to hear you got it to work. Sounds like it was a problem of not having the right SATA drivers on the installation disk.