USB Boot Menu is All Gibberish

Discussion in 'EasyBCD Support' started by brother.gabriel, Jan 30, 2016.

  1. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Using EasyBCD 2.3 (after the corrupted version was replaced), I created a boot menu on my usb disk composed of various ISO files. The machine is running in Legacy mode unsecure.

    When I attempt to boot from the USB, instead of a boot menu, the screen displays simply gibberish composed of all sorts of non-standard letters. When I push enter, then it says, "Selected boot device failed. Press any key to reboot the system".

    I tried to use "Reset BCD configuration" from "BCD Backup/Repair" and still get this problem.

    What else can I do?
     
  2. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Okay, I am just erasing everything and starting over. Only problem is the time it takes for EasyBCD to "defrag" each iso file.
     
  3. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    All right, so....
    I rebuilt the entire boot USB disk (I'm using Windows 7 x64) as admin.
    I used the "install BCD" option like in the docs. In fact, I have done as what is in this tutorial (except I have added multiple ISO files to choose from in the menu).
    and I still get gibberish when the computer boots with the USB disk.

    I'm trying to boot a Dell Optiplex 7010 and I've tried both UEFI boot and Legacy boot non secure.

    What's going on, and why doesn't this work?
     
    Last edited: Jan 30, 2016
  4. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,317
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    Chicago
    Can you upload a picture of the gibberish you see, please?
     
  5. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Well.... I would, but I was playing around with the Metro setting, and, having unchecked Metro menu, now I either get
    R04
    or just a blinking cursor line:
    _

    But before I had four or five lines of what looked like unicode characters of all sorts - you know, like some kind of spam where they try to disguise the text by using similarly shaped characters. If I can get it back I'll take a photograph.

    At any rate, no matter what I do, I get "Selected boot device failed"
     
  6. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I've tried with and without the Metro bootloader setting; I've tried booting Legacy and UEFI (with matching settings in the BIOS). The drive is formatted FAT32.
    There's nothing I can do to get the machine to boot with my USB drive.
     
  7. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I tried the USB drive on another computer and I just get a blank cursor.
     
  8. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Anyone have any ideas or clues here? I'm rather stuck!
     
  9. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Is there some way I can provide more information?
     
  10. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I guess nobody can help me out here. At this point I am thinking the problem arises from some sort of compatibility issue between EasyBCD and the flash drive, which is a Silicon Power Jewel J80 (32GB USB 3.0). I've tried redoing everything over again on a different computer (via a USB 2.0 port) and always have the same problem:
    When I choose to boot from the USB Boot Menu, I just get a blank screen with a blinking cursor.

    Or, maybe I just can't make a boot drive using FAT32?
     
    Last edited: Feb 8, 2016
  11. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Okay, I have a copy of Visual BCD Editor so I can check the actual values of any of the settings so we can debug this (if someone will help me out here).

    Why, when I boot with the flash drive (I've tried with two separate drives now) won't I get the boot menu?
    So I enter the bios F12 menu and choose USB from the list.
    The USB's boot menu is always blank - it's as if it's just not getting loaded or is broken or something. Instead of a menu I just get _ a blank cursor.
    What can I check to see if the menu is broken?
     
  12. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
  13. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,317
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    Chicago
  14. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I reformatted the flash drive, installed version 2.2.
    Then I installed the BCD (in BCD Deployment) using EasyBCD 2.2.
    Then I added two items to the boot menu.
    I was able to boot to the USB and the boot menu loaded as you would want!
    Then I ran the test again with EasyBCD Beta 2.3.0.183 and it worked, too.

    In fact, I've used EasyBCD for years and never had this problem before version 2.3.

    Once you install the BCD it asks you if you want to load the BCD for editing. I always click yes.
    One thing I noticed is that in version 2.2 and the 2.3 beta, after I deployed the BCD that the Overview says:
    Path: X:\Boot\\BCD
    There is an extra slash there. I chose to select store to load the BCD manually in order to correct the wrong path.

    In the new version 2.3 this path error is fixed in the overview.
    However, just for the sake of the test,
    Instead of adding new items here, I went and did Select Store ANYWAY.
    And I was able to build a menu that worked correctly.

    This confirms my other works where I have successfully edited existing BCDs and the menus did not break.

    So the problem is here: when you deploy the BCD and it asks whether you want to load it, IT LOADS IT INCORRECTLY.

    Mystery Solved!
     
  15. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,317
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    Chicago
    @brother.gabriel

    In 2.2, right?

    As for the rest - you're saying USB boot when created with 2.2 and 2.3 beta 183 work, but in 2.3 final doesn't work?
     
  16. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    When you deploy a BCD, when it is finished deploying, it asks you if you want to load the BCD.
    This is where the problem lies - the auto-loading of the BCD.

    In version 2.2 and 2.3 beta when you auto-load the BCD, the path is wrong - it has an extra slash. So I always used "Select Store" in the File Menu; therefore, I don't know if the auto-load is broken in those versions.

    But in 2.3, when you auto-load the BCD, the path is correct. So I was using the store that was auto-loaded - it is THIS that doesn't work.

    Also, I had an issue where I worked with the auto-loaded BCD and messed up my own system's BCD and I had to do tricks to get it working again. I wonder what BCD the auto-load really loads. It seems to load the BCD menus correctly - but the reference the BCD itself is not correct. And I'm referring to 2.3 in particular. I don't know if the other versions are broken too because I always used Select Store on account of the path being wrong.
     
  17. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    14,317
    Likes Received:
    30
    Trophy Points:
    48
    Location:
    Chicago
    The extra slash in the path in 2.2 and some of the 2.3 beta builds is merely cosmetic, it shouldn't affect the way EasyBCD operates. It's probably a different change that is responsible.

    I'm having some trouble following your train of thought; let's put EasyBCD 2.2 and EasyBCD 2.3 beta completely aside for a minute. In EasyBCD 2.3 (final), if you load the BCD via the File menu instead of pressing yes when asked if you'd like to load the newly-created USB automatically - this fixes the problem? Do you press "Yes" then use File | Load BCD, does that work? What about if you press "No" then use File | Load BCD?

    Also, whether or not you write to the BCD at all shouldn't cause the USB to load to an _ as the expectation is that you'll see *something*, be it an error message or an empty boot menu in such a case. In your testing you re-deployed to the USB each time? Perhaps after deploying to the USB with 2.2 you are able to deploy with 2.3, but only because of files that were copied to the USB by 2.2? Are you formatting the USB between each test?

    Thanks for helping get to the bottom of this.
     
  18. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I don't think the problem is writing to the BCD. The configuration is there and EasyBCD always writes the configuration okay.
    But when I boot with the USB disk, I get the __ *instead* of a menu. I think that the code that displays the menu is getting messed up.

    First, I formatted the disk each time before proceeding.
    So, when I deploy the BCD, I click "yes" to "Would you like to automatically load the newly-created BCD store in EasyBCD now?"
    THEN before I do anything else, (if I want it to work) I go to File > Select BCD Store and I manually browse for the BCD file.
    In this manner I can get EasyBCD 2.3 to create the menu that works.

    However, I have tried simply deleting all the boot files and bcd from a drive so I could start over without having to reformat the drive, and the menu does not work; you have to do this on a freshly formatted drive - you can't fix it once it's done.

    Haha - I can't seem to get the gibberish to appear again.
     
    Last edited: Feb 9, 2016
  19. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Something is out of whack in EasyBCD, at least in version 2.3.
    There may be something about this other issue that has bearing on the one at hand.
    Here is the thread.
     
    Last edited: Feb 11, 2016
  20. brother.gabriel

    brother.gabriel New Member

    Joined:
    Jul 30, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1

Share This Page