usb external dvd player blocks boot

#1
Hello all,

I'm new to linux, dual booting and all the rest, but I've managed to get Ubuntu and Vista dual booting on my HP dv9000 with EasyBCD. Boots with Vista as a default, with option to flip to Ubuntu. My problem is that, if I have a usb external DVD writer plugged into the computer, it blocks while trying to read from DVD player (even if it's empty). I never even get to the EasyBCD screen where I can pick the operating system. If I then unplug the DVD, the boot process will go forward. Also, after I've booted into either Vista or Ubuntu, I can then plug the DVD player back in and it works fine. I never had this problem before I installed Ubuntu and EasyBCD. I assume that the problem is related to EasyBCD and not Ubuntu, since the problem comes right at the beginning.

Any ideas anyone? Thanks.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi gopher, welcome to NST.

Actually, this problem is occurring even before EasyBCD's bootloader is loaded.
You need to go into your BIOS and disable the option of booting from a removable USB drive.
 
#3
Hello Mr. Guru,

Thanks for the reply. Perhaps I'm dense, but it doesn't appear as though I can disable USB boots in my BIOS. I can disable CD-ROM boots and Network boots, and I can change the order of all the different types (HD, USB floppy, USB drive, network, etc), but I can't disable any of the USB boot sources (or I'm too stupid to figure out how). I tried moving the USB sources to the bottom of the boot list, but it still tries to read from the USB drive and blocks. Does this sound possible to you? Could it be possible that you can't disable UBS boots? If it truly isn't possible to disable USB boots, do I have any other options?

Also, does anyone know why this would be causing a problem now, when it never did in the past?
 

mqudsi

Mostly Harmless
Staff member
#4
Do you have an option for disabling booting from removable media/devices?
 
#5
Thanks for replying. I appreciate it.

In response to your question, no, I can't disable all removable devices. I'll tell you what I've done so far, because the whole thing is a bit curious.

First, I upgraded the BIOS, thinking that maybe they had added some more options, but that's not the case. I've read on other threads that HP disabled almost all options in this BIOS (and that in many of their newer consumer focused laptops) because they didn't want to deal with people downgrading to XP. For instance, you can't disable/enable SATA disk support.

Regarding boot options, I can:

Enable/Disable
-- CD-ROM Boot
-- Floppy Boot
-- Internal Network Adapter Boot

And I can change the order (not enable/disable) for:
-- Notebook Hard Drive
-- ATAPI CD/DVD ROM Drive
-- USB Diskette on Key
-- USB Hard Drive
-- USB Floppy
-- Network Adapter

If I disable all three things above, the order shows:
ATAPI CD/DVD Rom Drive (disabled with an exclamation point)
Network Adaptor (disabled with exclamation)

and all the rest enabled. So there's no way to disable either the Notebook Hard Drive or any of the USB devices.

I'd also read somewhere that there was a similar issue that some people solved by putting some commands such as:
noapic, nolapic, apic=OFF
in /boot/grub/menu.lst, so I tried that also, with no effect.

Anyway, here's the weird part. I then removed EasyBCD to see what that would do, and I now boot directly into Vista, which is what I expected. What I didn't expect though, is that even booting directly into Vista without Ubuntu or EasyBCD still has this problem with the USB blocking the boot. But this is basically what I had before I started trying to install the dual-boot Ubuntu. I really don't understand the boot process very well, but I thought that I was completely bypassing Ubuntu during the boot, and booting as I did in the past, but that doesn't seem to be the case. There must be a BIOS or Vista related boot file that has changed somehow during this process, but I don't know what it is.

I'm going to keep experimenting, but if anyone has any insights, I'd appreciate them. I'm tempted in my next step to restore the laptop with the recovery disk and see if I can get back to the normal booting (I'll be really disappointed if I can't).

Thanks.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#6
Was there ever a time when this *didn't* happen?
As in, at some point in the past, were you able to boot your PC normally with the USB drive plugged in?

Also, is there a BIOS update available for your PC?
 
#7
Hello again,

Yes, perhaps I wasn't clear enough but I've always been able to boot without this problem in the past. I bought the laptop at Xmas, so I've been using it for roughly two months booting with multiple usb devices plugged in, and I've never had a problem booting. This just started after I installed Ubuntu, and then afterwards EasyBCD. So either Ubuntu or EasyBCD must have modified something somewhere.

And, yes, I updated the firmware during this process (after I found that this problem had developped), but that didn't change anything.

Thanks.
 

mqudsi

Mostly Harmless
Staff member
#8
lol, one more question then :wink:
Are you saying you updated the drive's firmware? or the motherboard's BIOS?
 
#9
Hello again. I was just reading up on MBRs to try to figure out what I broke. :smile:

Anyway, it's the motherboard BIOS. I went to the HP website and downloaded the link:

"BIOS - WinFlash for HP Notebook System BIOS (for Notebooks with AMD Processors) - Microsoft Windows/Vista-Based"

But like I said, I don't think that this affected anything.

a. Computer was working (no usb problem)
b. I loaded Ubuntu and then EasyBCD
c. Computer started having this usb problem
d. I updated the BIOS, hoping that it would fix it, but without success. :frowning:
 

mqudsi

Mostly Harmless
Staff member
#10
I guess we can rule out the BIOS as the source of the problem then....

Can you reinstall EasyBCD, then try "Bootloader Management" -> "Reinstall Vista Bootloader"