USB not being recognised

#1
OK, i have a Fujitsu Siemens Esprimo Mobile V5505 notebook running vista and when I plug in my 8gb PNY usb it does not recognise it at all. The usb flashes and then stops. I've tried a 1gb PNY usb and this seems to work but am puzzled as to why the 8gb doesn't, the 8gb usb works on xp but not on vista, any ideas?

thanks,
random123
 

JustinW

Super Moderator
Staff member
#2
I got a PNY 8GB i'm very disappointed with myself. At the time it was 150$ and no matter how many times I formatted it I still had corruption issues. It probably is working though, just not popping up a window automatically like you would expect. Check "Computer" for the drive. If its not there, open disk management where it should be and give it a drive letter (sometimes devices don't recieve letters automatically).
 
#3
You may have to right click while in the DM tool to reformat it in order to see a logical drive letter assigned. Most flash drives just like external hard drives see a factory Fat32 volume which isn't seen in Vista without an installer for some software appearing first. XP could be installed on Fat 16/32 primaries seeing that type of backward compatibility.

Reformatting it to NTFS is advised for Windows use. Windows will then auto detect the device as a new drive and install it as a logical drive at that time.
 
#4
ok, well windows wouldn't let me format it into ntfs so i used command prompt and it formatted to ntfs, i also changed the drive letter but still not working in vista but xp it seems to work fine, any ideas at all???
 
#5
Go to the manufacturer's support site and download the replacement software usually in a zip file. Once saved to a folder on your main drive unpack the contents onto the external drive and reboot into Vista with it unplugged. Once Vista is up plug it back into a usb port to see if the installer will appear.

The installer should come up right away or at least the auto play prompt. Since XP saw the drive right away with the reformat you know there's no problems with the drive but in the copy of Vista on. The installer may help Vista to properly detect and install it.
 

JustinW

Super Moderator
Staff member
#6
Again, check disk management to see if it was found. Try ejecting the drive and re-inserting it. Go into device manager and if its listed uninstall it, eject, and than re-insert. This should cause Windows to act as if the drive was plugged in for the first time again.
 
#7
@kairozammoro its not coming up at all even when inserting and ejecting
@ pceye there are no drivers available from pny because vista doesn't need them
 
#8
If the flash sees a factory Fat volume it won't be seen in Vista besides in the Disk Management tool. XP on the other hand sees backward support for Fat.

Without an installer as you would normally with any external drive you would need to boot into XP in order to use the Disk Management tool there to see the Fat reformatted to NTFS. This has nothing to do with drivers but the file system that comes on the drive already.
 

Terry60

Knows where his towel is.
Staff member
#9
Have you tried all of your USB ports ?
This could be a problem with the port not being recognized on Vista.
I have a similar problem where my card-reader "disappears" from Vista until I unplug it from the internal USB connection on the mobo, boot without it, then connect it again. The integral USB port on the card-reader is u/s at this time too.
Also, unpowered USB hubs can fail to recognize a new device if the other attached devices are using the full power capacity of the PC port they're attached to.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#10
There should be drivers called Mother Board Ultiltity or Chipset Drivers that are available from the mother board web site. Those will be the ones needed.
 
#11
There should be drivers called Mother Board Ultiltity or Chipset Drivers that are available from the mother board web site. Those will be the ones needed.
There are no drivers required for the PNY Attache USB in vista according to the PNY website
Also I have tried every USB port,

any other ideas?
 

Terry60

Knows where his towel is.
Staff member
#12
No. Mak was saying to get the mobo chipset drivers (from the mobo site) which run the USB controller, not drivers from the flashdrive site.
 

JustinW

Super Moderator
Staff member
#14
You don't happen to be plugging this drive into a keyboard/monitor provided port? Stick to usb ports on the computer itself if this is the case or self-powered usb hubs plugged into one of the ports on the system. Go into your BIOS and make sure the front and back USB ports are enabled.
 
#15
If the usb ports weren't already active it wouldn't be showing up in XP. The following might help here.

"If you plug in your USB flash drive and you are not prompted to install a driver for the new hardware then drivers may already be installed, however they may be the wrong drivers or out of date. To delete the drivers so that you can install the most recent and correct version open the Start menu and right-click on Computer and select Properties. Click on Device Manager and then expand Universal Serial Buscontrollers to display all the USB devices connected to your computer. Right-click on your USB flash drive (it must be plugged into your computer to show up here) and then select Uninstall. You may need to uninstall and reinstall Genetic USB Hub and other USB controllers as well to fix the problem. Once the device has been uninstalled right-click on Universal Serial Bus controllers and then select Scan for hardware changes and this will begin the new driver installation process described at the beginning of this article. It is worth checking the web site of your USB flash drive manufacturer, as the latest software driver may be available there for download." http://www.windowsvistamagazine.com...ta-does-not-recognise-my-usb-flash-drive.html

Another article is titled: "Make Windows see any USB flash drive as local disk" http://www.lancelhoff.com/2008/06/19/make-windows-see-any-usb-flash-drive-as-local-disk/

These are a few ideas to try out since you know the drive works in XP.
 
#19
PC Eye, i love you, it works!!! Finally

Can i just thank everyone who helped and made suggestions, thank you all, happy new year!!!!
Great! You're off to a good start for the new year. When you mentioned seeing in the disk management tool that showed the drive was good and not seeing any defects.

Device manager, isn't that what I mentioned in post 6? Oh well, glad its working :smile:
You referred to both terms in two sentences when first mentioning to look in the disk management to see if it showed up there amd in the second for using the right click uninstall method in the device manager to see if Windows would detect it fresj once plugged back in later.