Using Easy BCD 2.0.1 and not Booting with Grub and Grub2 Work Around

#1
Problem
If I install CentOS 5.5 to sdb1 partition and boot using EasyBCD legacy grub I get a message Grub (Not the Prompt)
If I boot from Neogrub using
Title centos 5.5
find –set-root /boot/vmlinuz -2.6.18.194.el5PAE
kernel /boot / vmlinuz -2.6.18.194.el5PAE ro root=/dev/sdb1
initrd /boot/ vmlinuz -2.6.18.194.el5PAE
When it boots it stops at kernel panic – not syncing: VFS: unable to mount root fs on unknown-block (0,0)
If I use parted magic 5.0 and set the boot flag to on the partition loads fine.

Workaround
Use Parted magic 5.0 to make your partition and swap file.
Load Linux as normal installing it to sdb1.
Install grub to root or sdb1. Not to the MBR
When done boot parted magic. Click mount drives icon.
Mount your windows 7 drive and your sdb1 drive.
Open sdb1 drive change directories to /boot/grub.
Copy the menu.lst file to a folder on your Windows drive.
Boot to Windows 7 Pro.
Install Neogrub
Click configure.
Open Menu.lst with Microsoft Word.
Copy the startup lines to Neogrub config file.
Here’s what My neogrub file looks like.
Highlighted in blue what I use for Grub2 entries.
Highlighted in red is what I use for Grub entries.

# NeoSmart NeoGrub Bootloader Configuration File
#
# This is the NeoGrub configuration file, and should be located at C:\NST\menu.lst
# Please see the EasyBCD Documentation for information on how to create/modify entries:
# EasyBCD Documentation Home - EasyBCD - NeoSmart Technologies Wiki
#This is the first entry
title Windows 7 Pro
root (hd0,0)
chainloader +1
#end of windows entry
#This is the second entry
title Ubuntu 10.04 Lucid Lynx
root (hd1,0)
kernel /boot/grub/core.img
#end of ubuntu entry

#This is the third entry
title OpenSUSE 11.3
root (hd1,2)
kernel /boot/vmlinuz-2.6.34-12-desktop root=/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP6930HD14JJAF-part3 resume=/dev/disk/by-id/ata-Hitachi_HDS721010CLA332_JP6930HD14JJAF-part6 splash=silent quiet showopts vga=0x3
initrd /boot/initrd-2.6.34-12-desktop
 

mqudsi

Mostly Harmless
Staff member
#2
So CentOS requires the active flag to be set on the boot partition, if loaded via the default copy of GRUB? And using NeoGrub fixes this?
 
#3
I just used Centos as one example. I have mulitple versions of different flavors of linux 12 to be exact and had booting problems with most of them.
 

mqudsi

Mostly Harmless
Staff member
#4
I don't understand - what's the workaround for?