Using EasyBCD to dual boot Win 10 and Ubuntu on separate disks

Hello,

I just installed EasyBCD to help dual boot Win 10 and Ubuntu on separate disks in my laptop. In the main SATA location is an SSD with Win 10 and in the DVD drive bay is an HDD with Ubuntu. Both are Legacy BIOS. Win 10 uses MBR in /dev/sda1 and Ubuntu GRUB2 which is at /dev/sdb.

I am trying to use the Windows bootloader to give me a selection screen where I can choose Win 10 or Ubuntu and have a configurable timeout.

I think I am almost there. I installed EasyBCD and added Ubuntu to the bootloader. When I boot up I can choose between Win 10 and Ubuntu... if I choose Win 10 it continues booting into Win 10 but if I choose Ubuntu it actually reboots first then takes me to the GRUB2 menu for Ubuntu.

Is that normal behavior? Why does my laptop have to reboot if I choose Ubuntu from the Win 10 bootloader screen? Did I set it up wrong with EasyBCD?

Cheers,

Flex
 

mqudsi

Mostly Harmless
Staff member
I think the next EasyBCD point release will need to programmatically toggle that option when "Use metro bootloader" is unchecked, as recent Windows 10 updates now even hide that menu altogether on initial (cold) boot (making it only visible on a warm reboot) unless fast startup is disabled.
 
@Terry60

Thank's for the suggestion. But I had already disabled fastboot in Win 10. I also asked about this on another forum and got the answer: "Because the grub bootloader can only be loaded by the system BIOS when the computer boots." I think that might be the issue. I actually swapped locations of my two disks so now when I boot up the disk that is first used is one containing the Linux GRUB2 boot manager. Now when I choose to boot Ubuntu OR Windows from the GRUB2 menu I am not hearing a reboot happen.

It seems to me I need a much deeper understanding of Boot managers and Boot loaders to really understand what is going on. Either way, swapping my disks seemed to avoid the "extra boot" and I am so glad I discovered EasyBCD which made dual booting way less scary than I expected :smile:

Flex
 
OK I read the document. It's very well written and gives a great explanation. But it doesn't answer my question.

I am dual booting Windows 10 and Ubuntu. Each are on their own disks. I default boot in to the Ubuntu disk. When I choose to boot or Ubuntu) from the GRUB2 menu I am not seeing or hearing the laptop restart, Windows just loads.

When I default boot in to the disk containing Windows I get the bootmgr screen. From here if I choose Ubuntu I DO see and hear my laptop restarting before presenting me with the Ubuntu GRuB2 menu. I KNOW I can alter the GRuB settings to NOT show the GRuB menu but that doesn't change the fact that Windows had to restart itself just so I could load Ubuntu from the Windows 10 bootmgr dual boot menu.

Is this standard behavior or is my set up wrong somehow? I don't want my PC to have to restart just because I chose to load Ubuntu from the Windows bootmgr screen.

Any help on this would be very much appreciated. Thank you.

Flex
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
mqudsi's post #3 implies that W10 is now toggling fast start back on if the Metro menu box is ticked.
I have no experience of that (I use the legacy boot menu) but I do know that in the past WUD has turned that option back on on my PC with some W10 updates and I've had to go back and turn it off again.
Have you checked that the fast start status is still turned off even though you already did it once ?
Your symptoms still sound exactly like it's turned on.
 

Hypogriph

Member
The reason why your PC is rebooting is because the Metro bootloader actually loads into Windows before showing the boot options. Hence why when you select Linux, it restarts the PC with a different boot priority.
I have the same issue which is not an issue.
To fix it, just use Linux Bootloader.
 
Top