valid BCD Registry not Detected

#1
Hi, I hope you can help this oldie find the answere to this querie,
I have after trying several Linux distros found that SuSe will see my sata hd( on a MSI board) where non of the others would. It installed Ok but on boot up I get GRUB, then Vista bootloader with the menu from the last time I tried using EasyBCD to load a Linux distro. When I try to load EasyBCD to alter the settings I get this error " Valid BCD Registry not Detected " ,and then the option to have the MBR repaired,i think using this may stop me from booting SuSe which after the time its taken me to find a distro compatable with my machine I obviously want to use.
I have seached around for an aswere but no luck,if this has been answered before I would be grateful if you could point me to it.
I am sorry this is such a long post.
Best regards jacko.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Okay let me see if i can get this right.

You have Vista installed. You loaded EasyBCD on it. But when you run it you get no valid BCD Registry error?

Guru will have to tell you what that one is all about. I have not seen that yet. But i do know that once you get the BCD working again you can just Add a entry for SuSe and use the BCD for all your booting.
 

mqudsi

Mostly Harmless
Staff member
#3
Hi Jacko, welcome to NST.

Can you run Start | Run | Cmd.exe
then run
Code:
bcdedit.exe /enum
and paste the result in a reply here?
 
#4
My apologise for the delay in responding to your rapid responce.
Here is the result of the suggested command.

Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.
C:\Users\AGH>bcdedit.exe /enum
The boot configuration data store could not be opened.
Access is denied.

For what its worth I think SuSe has overwriten the MBR,I did once corrupt the MBR myself once when trying to get a Linux distro to install (NOTHING to do with EasyBCD), after using my recovery disk Vista bootloader now states "Vista bootloader (recovered)"
Thanks for your time,
Best regards jacko
 
#6
Thanks Guru since my last post things with Vista got really wierd,to cut a long story short I had to do a reinstall,so it only remains for me to thank you for all your advice and time.
Thanks and best regards jacko
 

mqudsi

Mostly Harmless
Staff member
#7
Hey Jacko, sorry to hear you had to format & reinstall - but I guess the silver lining is that fresh, new OS feel and the snappy response times :smile:
 
#8
Hi Jacko, welcome to NST.

Can you run Start | Run | Cmd.exe
then run
Code:
bcdedit.exe /enum
and paste the result in a reply here?
Hey There :smile:
got the same problem.
got like this:
HDD split to 3 partitions.
installed Vista64 on first part.
second part for storage
third MacOS (after vista)
automatically Darwin is loading (with an option for vista)
when loading Vista and running Easy BCD 1.72 i get an error window with title as the subject. "EasyBCD has detected that your BCD boot data and MBR are either not from the latest version..."
when running bcdedit /enum
i get: "The boot configuration store could not be opened. The system cannot find the file specified"...
any idea what to do?
i ran chkdsk /f and everything is good. it's a brand new notebook.

Shablool
 

Terry60

Knows where his towel is.
Staff member
#9
Hi shablool, welcome to NST.
When you installed OSX, you let it take over the Vista boot process.
If you're happy to let OSX boot Vista, then you don't need to do anything, but you can't use EasyBCD because you aren't booting via the BCD any more.
If you want Vista to be in charge again, you'll need to boot your Vista DVD, run "repair your computer" / "startup repair" 2 or 3 times until Vista is booting unaided.
Then download EasyBCD 2.0 (don't use 1.7) and add your OSX entry to the BCD.