Vista 2005 C++ assembly issues

#1
I seem to be having an issue with microsoft visual C++ 2005 which is preventing me from loading certain programs that require it. I also seem to be having issues with downloading the newest version of windows installer which is effecting windows update.

Picture of problem:



A friend suggested to me to repair windows via the vista disk but I couldn't find it, so he provided me with the link to burn the repair disk from this site. I get to the repair computer options and I select the top option "startup repair" but it comes across no problems and when I try to load visual C++ again it still doesn't work. I have tried all the different Visual C++ apps from the microsoft site with no luck. No support is available for this issue from Microsoft, SEGA or Steam and several questions about it on various other forums by other people got no respones. I've heard that I might need to reinstall the whole of vista, which will be a problem without the disk.

Help?
 
#3
Yes and it has the same problem

I have tried all the Visual C++ from the microsoft site and none work. 2005 editions come up with the issue in the picture, while 2008 doesn't appear to be recognized so it tries to install 2005 anyway.
 

JustinW

Super Moderator
Staff member
#4
I have a feeling this game's installer decided to install it on its own and didn't do so correctly. Did you uninstall it before you tried to re-install with the download from MS's site? You may also be able to get it through WU. If you're running 64-bit Windows you need the x64 download if they have one and not the x86.
 

JustinW

Super Moderator
Staff member
#6
Ok, just checked over the page CG provided a link to and it requires that you have Windows Installer installed before you can install it. In addition to that, I see the supported operating systems do not mention Vista at all, so it may not be possible under Vista any way because things like .net for example are included with the OS unlike previous versions of Windows where you had to go download and install everything.

You can go into Windows components under Programs in Control Panel. If its listed there, make sure its enabled. Next, check the system files for corruption with system file checker. From the command prompt:

Code:
sfc /scannow
If none of the above works, you're looking at a re-install of Vista completely. Not much more can be done here to fix it.

Edit: Here's a link to the x64 download if you're using Vista 64-bit.
 
Last edited: