Vista 32-bit + Vista 64-bit Dual-boot setting

BearZ00

Member
ok so I have Vista x64 and Vista x86 on separate hard drives. my "System" hard drive is the one that has the x86 OS installed which shows up as C:\ when logged into x86 OS, but shows up as D:\ when logged on to x64(marked in yellow highlight and red underline)
On the other hand im currently on the x64 OS running EasyBCD(screenshots on x64). on this OS, the x64 boot drive shows up as C:\ also but not as the "system" (highlighted in green)
heres a screenshot to help me illustrate

now my question is, in EasyBCD what do I set these(highlighted in aqua) to?

^x64

^x86

keep in mind im running x64 OS right now and have both set to C:\ (as seen in highlighted aqua) im afraid to restart, I just want to get confirmation that these are the correct settings. again my "system" drive shows as D:\ on x64OS but as C:\ everywhere else. so do I need to set it to D:\ or keep it as C:\? should I keep both the same? or will it/should it be different?

I phrased this problem the best I could, if you have trouble understanding any of it please let me know and I will try to clarify

thanks in advance for the help! wont restart until I get an answer...please hurry :lup::tongueout:oint:
 

JustinW

Super Moderator
Staff member
Hi BearZOO, welcome to NST

Yes, that's a normal behavior of Windows as of Windows Vista and later when you've installed each by booting from thier install media. This is so legacy programs that count on the system drive being C: will function in compatibility mode as expected.
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
EasyBCD uses the lettering of the system you are running it in.
Tell it the running system is on C: and the other is on D:, exactly as you see them in Explorer.
(when you "display settings" from the other system, they will appear to have "flipped" because that system is using what it letters things as - remember the BCD doesn't actually use letters, it uses the drive id, but EasyBCD displays the letters as seen by the running system)
 

BearZ00

Member
thanks for the replies guys! I just left the settings as is and it correctly booted into x64...:grinning:
I havent tried booting into x86 yet, but im sure it should work, they both show up on the boot menu...thanks for the help! and thanks for the welcome too
 

JustinW

Super Moderator
Staff member
If both entries get C: inside Win 64, than you'll need to change the other entry to w/e partition holds 32-bit Vista. While the above is true, they should be different drive letters in any given system. So if you use the 32-bit entry and still find yourself in 64-bit Vista, you'll need to open EasyBCD and change the drive letter used accordingly for the 32-bit entry.

Edit: From your disk management screenshot above, the 32-bit entry should reference D: in EasyBCD. Otherwise, it'll just boot 64-bit Vista.
 
Last edited:

BearZ00

Member
If both entries get C: inside Win 64, than you'll need to change the other entry to w/e partition holds 32-bit Vista. While the above is true, they should be different drive letters in any given system. So if you use the 32-bit entry and still find yourself in 64-bit Vista, you'll need to open EasyBCD and change the drive letter used accordingly for the 32-bit entry.

Edit: From your disk management screenshot above, the 32-bit entry should reference D: in EasyBCD. Otherwise, it'll just boot 64-bit Vista.

ah sweet, thanks!
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Didn't I say that 3 days ago ?!
"Tell it the running system is on C: and the other is on D:, exactly as you see them in Explorer." (post #3)
 
Top