Vista 64 and Ubuntu grub wont load

#1
I originally had Vista 64 on the first partition then the rest was just for downloads. I shrunk the downloads partition so there is about 50gb of non partitioned space. I followed this guide with the ubuntu installation.
How to dual-boot Vista with Linux (Vista installed first) -- the step-by-step guide with screenshots

When i restart after the ubuntu installation it just boots straight to vista and grub doesnt even load to give me an option.

So i installed EasyBCD and went to Add/Remove entries. I went under Linux Tab chose Grub set the drive to the proper partition and checked the box GRUB isnt installed to the boot sector since as far as i can tell its not installed at all. I restarted tried booting to Linux and it loaded Grub DOS and just sat at a command prompt.

Ive tried booting to ubuntu with the disc and opening terminal and using the find command to locate grub and it cant find the file so it seems like it wasnt installed at all when ubuntu was installed. I even tried installing twice and neither time did grub get installed.

What can i do to add Ubuntu to my windows boot loader with EasyBCD that it will work or what can i do to install grub without messing up my windows booting. Im kind of against installing grub because ive read on multiple forums people saying they cant boot to vista at all after installing grub.
 

Terry60

Knows where his towel is.
Staff member
#2
Hi zexeta, welcome to NST.
If you followed the guide, you should have used the "advanced" button and installed grub into the Linux partition, not the MBR.
When you reboot, the untouched MBR will invoke the Vista boot as before.
You should have added a Linux entry in EasyBCD, with the "grub is not...." box unticked. (grub is installed to the Linux bootsector).
Just go back and delete the entry you did before, then add it again without ticking the box and you should be fine.
 
Last edited:
#3
Make sure to use the [thread=642]latest beta release[/thread] of Easy since it has far more Linux support, and supports UUID lines (the 1.7 release doesn't) in the boot/grub/menu.lst on the Ubuntu partition.
 

rdsom

New Member
#4
Unable to dual boot Vista and Ubuntu

Hi,
I am facing similar problems, trying to dual boot Vista and Ubuntu 9.04 on two separate internal hard disks. Vista boots up fine but Ubuntu is either not recognized or reaches the grub shell and sits there.

I am using NeoSmart EasyBCD 1.72 and made the recommended changes as given in Ubuntu - NeoSmart Technologies Wiki

I see the following two scenarios:

1) When I have the "grub is not ..." unticked then I see the following error on choosing Neo Smart Linux option after a reboot:

<BEGIN MESSAGE>

Bootpart 2.60 Bootsector (c) .....

Loading new partition
Bootsector from C.H. Hochstatter
Invalid system disk

Replace the disk and then press any key

<END MESSAGE>


2) When I have the "grub is not ..." checked then it sits there on the grub prompt.

I would like option (1) as I do not want to overwrite the MBR.

Thanks,
RD

Hi zexeta, welcome to NST.
If you followed the guide, you should have used the "advanced" button and installed grub into the Linux partition, not the MBR.
When you reboot, the untouched MBR will invoke the Vista boot as before.
You should have added a Linux entry in EasyBCD, with the "grub is not...." box unticked. (grub is installed to the Linux bootsector).
Just go back and delete the entry you did before, then add it again without ticking the box and you should be fine.
 

Terry60

Knows where his towel is.
Staff member
#5
Hi rdsom, welcome to NST.
Ubuntu changed grub syntax since 8.04 and the new syntax is not supported in EasyBCD 1.7.x.
Download EasyBCD 2.0.
Delete the Linux entry and add it again with the "grub is not......." box ticked.
(you are not touching the MBR by ticking the box. You're telling EasyBCD to install Neogrub and use it to make the chain. There's a problem with grub (not EasyBCD) when it's on a different HDD to Vista, whereby it can't be chained directly.
If you had installed Ubuntu to a new partition on the same HDD as Vista, you wouldn't need to tick the box)
 
Last edited: