VISTA audio

#1
I have a Soundblaster Live Soundcard, and when i install the drivers from the CD, they work, but when i restart my PC i get a blue screen saying "A problem has occured and Windows had to shut down inder to prevent damage from your computer" and i have to go to Safe Mode and Uninstall the drivers in order to turn my PC on again. Also if i disable and enable the driver in the Device Manager, i also get the Blue Screen While enableing.
Any ideas on what to do?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Sadly this product is no longer even supported by Creative. Which can guarentee that it doesnt have sufficent drivers needed to run on Vista. This was mainly a XP card. Only thing i can even think of is to install the drivers from CD but do it with XP Compatability. But i highly doubt that will solve you problem. Only thing that might do that is to upgrade your sound card to a more recent one which is supported by Creative and Vista.
 

mqudsi

Mostly Harmless
Staff member
#3
No, no, that's the card I have! :tongueout:

It works just fine, with the right drivers. I've been meaning to repackage and upload them, never got the chance. I'll do it later today.

There are two drivers, one is for the 5.1 Digital and the other is for the standard SB Live! card.
 
#4
I know it is supported by vista, since last time i had vista it worked just fine. I've been installing the drivers from the original CD that came with the sound card. The only difference is that last time i had One of the Home editions of Vista (or the business one) i don't remember, but this time i have Vista. Do u think that may be the problem, since on the other edition it worked fine?
 

mqudsi

Mostly Harmless
Staff member
#5
No, if anything it is a Windows Update that broke it. In Longhorn Server, Microsoft has hard-coded the fact that SB Live! isn't supported on Vista. I'll get the files up soon.
 

mqudsi

Mostly Harmless
Staff member
#6
Topic Moved
 

Ex_Brit

If you're going through hell, keep going
Staff member
#8
He means he moved it to where you see it now. :wink:
 

Sarge

Active Member
#9
levskarcheto said:
i get a blue screen saying "A problem has occured and Windows had to shut down inder to prevent damage from your computer"
That is called Blue Screen Of Death (BSOD :evil: ).
 

mqudsi

Mostly Harmless
Staff member
#10
I uploaded the drivers that day, I assume they worked for levskar...

http://neosmart.net/blog/2006/vista-sound-drivers/

The section for Creative Sound Blaster, extract them to your disk with WinRAR, PowerArchiver, WinZip, etc. and then point your device manager to that folder.