Vista BCD and Boot Record corruption after iTunes install

#1
Hi Folks,
I ran into an issue after installing an iTunes update, typical error: \boot\bcd
Info: 0xc000000f etc, I rebuilt the BCD following intructions from this web site and other postings, but I am still not able to make the recovery partition work using the F11 key. I have tried every combination posted (F12, F8, F11, F10 etc. etc). I used the bootable ISO Recovery Console to perform the Vista startup repair, and it is detecting the O/S on partition D and does not see the Recovery Partition at all. When I viewed the details of the BCD using EasyBCD it shows the O/S on partition C not D, and has the recovery partition shown. My goal is to repair either the BCD or Boot Record correctly without having to purchase the recovery DVD's from HP, this will allow me to learn a great deal more about Vista, BCD and Boot Records, below see images showing these issues.



Your help is appreciated, thank you.
Aaron
 
Last edited by a moderator:
#2
You might to try using the command prompt option for entering the "bootrec /fixboot" and "bootrec /fixmbr" commands you type in there in order to see the boot information rewritten and the BCD rebuilt where the recovery partition won't be needed. The idea is to simply get this corrected where Windows will load up normally again.
 

JustinW

Super Moderator
Staff member
#3
iTunes casuing bcd corruption.... I've heard of BSODs with it on Windows but not this. Can you get into safe mode? Press F8 as the system is booting repeatedly until you get the advanced options boot menu. If you can get into safe mode, go ahead and restore the system to a previous time where the computer was running fine using system restore (iTunes installer should have automatically created a restore point for you that you can go back to to revert the changes).
 
#4
A bad install wouldn't effect the boot information on the drive itself but simply cause Windows problems while allowing you to get past the initial post tests and onto the Grub boot options screen seen first. Something had to have removed the Windows entry there.
 
#5
PC Eye, I have done as you stated prior to my post. Below is a copy of my current BCD, the OS boots normal, what will not work is the F11 key, it will not no matter how you fuss with it work, using F8 as an alternate does not work either, I can get to the safe mode option etc etc, but when you select the WINPE RAM DISK option which is what should be loading the recovery partition it goes back to the BIOS loading page and starts the OS.


Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {cce58f38-b2c6-11dd-b39a-806e6f6e6963}
displayorder {current}
{572bcd55-ffa7-11d9-aae0-0007e994107d}
toolsdisplayorder {memdiag}
timeout 5
Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows Vista (TM) Home Premium
osdevice partition=C:
systemroot \Windows
resumeobject {cce58f38-b2c6-11dd-b39a-806e6f6e6963}
Windows Boot Loader
-------------------
identifier {572bcd55-ffa7-11d9-aae0-0007e994107d}
device partition=D:
path \WINDOWS\SYSTEM32\BOOT\WINLOAD.EXE
description WINPE RAMDISK
recoverysequence {572bcd55-ffa7-11d9-aae0-0007e994107d}
recoveryenabled Yes
osdevice partition=C:
systemroot \WINDOWS
nx OptIn
detecthal Yes
winpe Yes
 
#6
The thing that comes to mind now since the recovery partition is still presenting problems would the heads on the drive itself as one possible cause. A simple bad install of ITunes is not going to trash that as well as the boot files and information at the root of the drive as mentioned before.

A failing drive or something corrupting the factory recovery partition when going to download Itunes like a virus being spread would be two main causes for raising havoc with a working dual boot. Linux being the much smaller OS is still loading since it is getting past the problem.
 
#8
Using the system restore feature only back clocks the system registry and has nothing to do with the boot loader, mbr, or recovery partition for a preinstalled OS. That will only help get Windows running after simply seeing a bad install of something but not fix the factory restore option that no longer seems to be working.

I would recommend using a sweeper like Trend Micro's House Call and a drive diagnostic tool to rule out a possible hardware problem since this seems to more widespread then a bad download of ITunes.
 
#9
OK, before I use Trend, is there a MBR tool I could use allowing me to examine the contents and hopefully fix it. I am really opposed to restoring, or installing the OS as a solution to the problem, that does not allow me to learn like I would prefer, basically I get not root cause for failure which is really what I am after. As for anti-virus software I am using Symantec End-point which has spyware protection etc. etc. If anyone is up to the task of tutoring me in my quest it would be much appreciated.

Thanks again
Aaron
 

Terry60

Knows where his towel is.
Staff member
#10
Aaron, Your 1st post screenshot is quite normal. Vista recovery only displays partition(s) containing Vista installations.
I don't know how HP boot has been modified to give you the F11 option, ( I don't own an HP) but I would speculate that the Vista repair removed the HP option.
I believe that you should be able to enter the HP recovery directly from Vista with something like
"C:\hp\recovery\splash.exe", and presumably they'll have some kind of option to repair their customized boot.
This is all complete speculation on my part (following a quick google), so your best course of action would probably be an email to HP support asking them how to get your F11 back after a Vista "repair startup".
 
#11
Tech support should be able to explain what entries were seen in the BCD itself if the only problem was when trying to rebuild it yourself. There are also ways to create your own set of recovery disks as long as the recovery partition is still intact that should correct that as well.

The recovery disks would be based on that particular machine's product information there preserving what was original seen in the preinstalled copy of Windows. Ask about that as well.