Vista Black Screen from recovery disk

#1
Hi everybody! This is the first message for me here.. I know the argument "KSOD" has already been discussed many times, but I think my case is particular, and I could not resolve it though I've read a lot of tutorial to fix the problem.
Here is my story:
I have a laptop Hp pavillon dv6520el, I've installed Windows Vista Home and Linux Mint on my system in different partitions.
One day, while the computer was working on Vista, it fell to the floor --_- and then I had to restart it because the system stopped to respond.
When I restart the system I could use Linux perfectly but not the partition with Vista, when I try to start Vista I obtain the "Microsoft Corporation" progress bar loading for the eternity... and Windows doesn't appear.
I tried to repair the partition from Linux (with ntfsfix and testdisk) but I could not repair it. Note that with testdisk I can see my files and directories, but anyway I cannot mount the partition and the boot sector is ok.
Then I tried to use my recovery cd of Vista (I made it when I installed the system for the first time and it worked well in the past) but when I insert it I obtain:
- Windows is loading files
- Microsoft corporation progress bar
- Black Screen
- Black Screen with white cursor: KSOD
Same thing with your special Recovery Disk for Vista that I downloaded and ran but with the same result as my recovery disk.

I tried also this solution but pressing five times the left shift key doesn't seem to work.. :x


The final solution (I suppose) could be to format the entire HD and then run the Vista recovery Disk and then install Vista from the beginning, but if I could avoid it I would be happy because in that case I'll lose all the configuration I made in Linux.. I don't mind about the data because I've already saved all the data in an external HD.
And also I'm makins an issue of it because is not possible that a RECOVERY DISK does not make his job: RECOVER! hehe

PS: sorry if my english is not perfect, I'm from Italy, hope is all clear in the post.
 

mqudsi

Mostly Harmless
Staff member
#2
Hello zandr, welcome to our forums!

You need to clear your MBR, which is damaged.

You can do so by booting into a Linux live CD, and running this command:
Code:
dd if=/dev/zero of=/dev/sda bs=446 count=1
 
#3
Hi! Thanks for the welcome and for the reply! :grinning:
It is not a problem of the MBR which is ok, I run the command you suggest, then I restarted and there was not any boot menu, so I went into a Live Linux and I ripristinated Grub and now I'm in the same situation of before, nothing changed hehe