Vista boot loader nowhere to be seen

#1
I multiboot Vista (boot loader on partition 1) and Grub/Mandriva with Grub on partition 2 (not MBR).

Grub will properly boot Vista when its partition has the boot flag, but everytime I use Vista it resets the boot flag to its own partition (!) then no more Mandriva... No comment...

I first tried bcdedit, then easybcd, to add the Grub partition to the Vista boot loader, but in both cases the result is the same : the computer boots straight into Vista, with the boot loader nowhere to be seen : what should I check ?

I have gone the bcdedit way on another computer, and it worked well.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi medor, welcome to NeoSmart Technologies!

Things to check:
Change Settings -> Bootloader Timeout. Is it set to 0 or a really low number?
Do you have more than one BOOT folder on multiple drives?
EasyBCD | Bootloader Management | Reinstall Vista Bootloader

Let me know how it goes.
 
#3
Hi Guru, and thanks for the lightning-fast reply.

The timeout was/is at 10 seconds. I reinstalled the Vista bootloader, still no go, the computer boots straight into Vista. No boot loader.

I have a question : in the easyBCD settings, I can choose C, E, or BOOT : what is BOOT ?



I attach my partitions as seen by Vista. The second smallish partition is where Grub resides, it is /boot for Linux :
 

mqudsi

Mostly Harmless
Staff member
#4
Can you go to Diagnostics | Copy Debug Data (it'll copy some stuff to your clipboard) then paste it here in a reply?
 
#5
Here is the debug info. The "mandriva" entry is the one I created with Vista's bcdedit.

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=C:
description             Windows Boot Manager
locale                  fr-FR
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {f23c10c2-68d0-11dc-9049-decb6231f525}
displayorder            {f23c10c2-68d0-11dc-9049-decb6231f525}
                        {4c60b96f-8171-11dc-a9a2-000c6e3b5892}
                        {4c60b971-8171-11dc-a9a2-000c6e3b5892}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10

Windows Boot Loader
-------------------
identifier              {f23c10c2-68d0-11dc-9049-decb6231f525}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  fr-FR
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {f23c10c3-68d0-11dc-9049-decb6231f525}
nx                      OptIn

Real-mode Boot Sector
---------------------
identifier              {4c60b96f-8171-11dc-a9a2-000c6e3b5892}
device                  partition=C:
path                    \pundit-linux.bin
description             Mandriva

Real-mode Boot Sector
---------------------
identifier              {4c60b971-8171-11dc-a9a2-000c6e3b5892}
device                  boot
path                    \NST\NeoGrub.mbr
description             NeoSmart Linux
 

mqudsi

Mostly Harmless
Staff member
#6
OK, this is weird :grinning:

Do you have more than one folder called BOOT on your machine? (It'd be in the root of a partition)

If not, give Diagnostics | Reset BCD Data a shot.
 
#7
I can see only one \boot directory in the Vista partition. The other partition that Vista sees doesn't have a \boot directory. I assume you don't want me to check the ext3 partitions !

C:\>
23/10/2007 19:35 <REP> NST
22/09/2007 07:14 <REP> $Recycle.Bin
22/09/2007 07:59 <REP> Boot
23/10/2007 17:20 <REP> System Volume Information
22/09/2007 06:51 356 Boot.BAK
22/09/2007 07:59 356 Boot.ini.saved
05/08/2004 14:00 4 952 Bootfont.bin
02/11/2006 11:53 438 840 bootmgr
22/09/2007 07:59 8 192 BOOTSECT.BAK
23/10/2007 19:39 1 576 640 512 hiberfil.sys
22/09/2007 05:58 0 IO.SYS
22/09/2007 05:58 0 MSDOS.SYS
05/08/2004 14:00 47 564 NTDETECT.COM
05/08/2004 14:00 251 712 ntldr
23/10/2007 19:39 1 890 566 144 pagefile.sys
18/09/2006 23:43 24 autoexec.bat
18/09/2006 23:43 10 config.sys
23/10/2007 15:53 512 linux-pundit.bin
14/06/2007 23:19 177 049 NeoGrub

I post, then test the "reset data" option...
 

mqudsi

Mostly Harmless
Staff member
#8
Nothing out of the ordinary there - and you're right, definitely don't expect the EXT3 partitions to have any Vista-related data! :lol:

I don't know what to tell you though. Everything looks good :S

Hopefully resetting the BCD data will do the trick. You'll have to re-add the Linux entries though, because when you reset you'll lose them.
 
#9
Ok, easyBCD Diagnostics, Reset BCD storage, Rescue my system.
Reboot.
No vista boot loader.

I want to boot on the 2nd partition, I have carefully partitioned my drive, and this ill-behaved Vista OS just won't let me, for reasons I don't want to second-guess...

Addendum:

When I re-create the entries, I'm not too sure what "GRUB isn't installed to the bootsector" means : should I check it ? Grub is in the 2nd partiton, not in the MBR.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#10
No, don't check it. Instead, select the second partition from the drop-down partition list and add entry.
 
#11
Ok, no way to boot from the Vista boot loader. This is an Asus Pundit barebone, bought without an OS, where I installed a legit Vista Business edition. Then I installed Mandriva.

The symptoms are :
- Vista resets the boot partition to its own everytime it's run.
- Whether the boot options are done with easybcd or bcdedit, when the Vista partition has the boot flag, the computer boots straight into Vista, I can't get the boot loader to run.

On the Asus laptop, with Vista Pro and Mandriva, none of these 2 symptoms are present : I can multiboot either Vista from Grub or Grub from Vista, no problem. I did it with bcdedit.

I quit for the time being, that's a mystery all right.
 

mqudsi

Mostly Harmless
Staff member
#12
Hi medor, welcome to NeoSmart Technologies.

Can you please paste the contents of your clipboard after running EasyBCD | Diagnostics | Copy Debug Data
 
#13
Hi Guru, how are you today ?

Actually, I did just that in the comment #5 of this thread.
Let me know if you want me to do it again.

Cheers !
 

mqudsi

Mostly Harmless
Staff member
#14
Oops - sorry about that... I somehow thought that was the first post in the thread!

Addendum:

OK, try this:

Go to the change settings page, and change the drive for the Linux entry from "BOOT" to C:
 
Last edited:
#15
Did it, but no, still boots straight into Vista. This edition of Vista is a "Vista Professional", which can only be installed as an update of an XP. On The CD, it show as a "Business edition". It has no administrator account, just an administrative password to startup such utilities as easyBCD.

So I wonder : maybe it just won't do what easyBCD wants it to do. It will not use the bootloader. It will reset the boot partition everytime it is run. I have never experienced this kind of behavior before, and I have multi-booted just about every version of Windows with Linux since the beginnings of time.

Again, on the laptop with Vista Pro pre-installed, everything runs just fine.

I should hunt through Internet to see if I can find something.
 

mqudsi

Mostly Harmless
Staff member
#16
If there is a program actually actively reseting the bootloader/MBR every time you restart, then this is indeed out of EasyBCD's hands.

Good luck - let us know what you find.