Vista boot problem Autochk not found.

#1
Hi,
I have managed to break vista booting, possibly by trying to hide said drives from Kunbuntu.
The vista bootloader and neogrub still loads as normal and I can boot XP or linux as if everything is ok.
It's only when vista actually tries to boot I get the stop error and Autochk not found.

Any ideas?
 

mqudsi

Mostly Harmless
Staff member
#2
Hi,

Can you tell me what you tried to do? How does your current configuration look?
Copy debug data from the EasyBCD diagnostics screen and post here, too.
 
#3
I'm not exactly sure what I did as it was a while since I actually booted into vista.
I know I added hide (hd0,0) to the Kubuntu entry in neogrubs menu.lst
EasyBCD is on the vista install I can not boot into.
I think the partition is somehow hidden from vista even though I boot vista from it's own bootloader, not neogrub.
 

mqudsi

Mostly Harmless
Staff member
#4
Is (hd0,0) Vista?
 

mqudsi

Mostly Harmless
Staff member
#6
I don't understand why you are hiding it..

NeoGrub is special :smile:D) and does stuff that Vista can't do. (It's how we make things work when they're broken!)

NeoGrub can access the Vista drive, but Vista can't access it.

You need to run `unhide (hd0,0)` in a GRUB console to be able to boot Vista - like I said though, there is no need to hide Vista from Linux in the first place.
 
#7
OK thanks, I'll give that a try.
The reason I tried to hide it is that Kubuntu 7.10 temporarily breaks my software raid (see here) on this partition, 7.04 never did this, but then Feisty never shut down cleanly either.

Also, anyone having problems configuring menu.lst for 7.10:
All drives are sda type now, root=/dev/hda2 was what I used with 7.04, in 7.10 it is now sdc2.

edit: yes this worked just fine :smile:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#8
hmm - for me all drives have been sd** since Feisty.

At any rate, glad it's working now.
 

mqudsi

Mostly Harmless
Staff member
#10
Yeah.

HD** is for ATA/IDE devices, and SD** is for SCSI/SATA

However, Ubuntu since Feisty has been using SD** for all drives in order to do away with the confusion.

Here's some (interesting) history/backstory on the topic: Drive Letters and Numbers - NeoSmart Technologies Wiki