Vista bootloader problem

#1
Hello,

I seem to be having trouble with my 64 bit copy of Vista. When I try to boot, it tells me that theres a problem with the bootloader and to insert the dvd to fix it. I do that, and then it fixes it and I am in vista and everything, but after maybe 2 restarts it happens again. I have tried everything that is located here to Repairing the Windows Vista Bootloader - NeoSmart Technologies Wiki

And all the same results. Any idea before I reinstall vista?
 

Terry60

Knows where his towel is.
Staff member
#4
Have you done a Virus scan to make sure there's nothing lurking in your system which is playing tricks with the MBR ?
 
#5
I dont think Its a virus, its a fresh install of vista on a new hard drive. I deleted the old boot entry though, and had vista rebuild it from the dvd and it seems to be fixed..for now
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#6
Just because it is a fresh install doesnt mean that it cant get infected. If you have any stored files on the PC that are previously infected or if you go to the internet to download a anti-virus you can most certainly be infected right from the get go on a brand new install. Have seen it many times.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#8
It would be advised. Could have been a boot sector virus or something like that. With the Vista format it is only a quick format to erase the data on the drive. Which is never really recommended. I dont know why microsoft only included that type of format with Vista as it is the worst ype of format.

Using something like GParted and pre-formatting the drive to NTFS has also worked out for me. It seems to me that when i have a issue with my hard drive and i use Vista to format it that the issue gets compounded even with a fresh install. Going this route always seems to work out better.
 

JustinW

Super Moderator
Staff member
#10
When sfc can't fix corrupted system files you know its time for a clean re-install. Even if you could comprehend the cbs.log, it is just about impossible for you to replace any of the files in question without re-installing. Not to mention that SP1 well fail to install when this occurs and you really need the latest security updates as a bare minimum now days. Typically I only find this problem with pre-installalations or computers that have been upgraded, but a re-install I found was the only way...
 

Terry60

Knows where his towel is.
Staff member
#12
Download the latest versions of AVG 8 and Comodo (or whatever you use) and have them ready on a flashdrive, and install them on Vista immediately you've finished setup, before you let Vista connect to the net. When you've got a working AV and Firewall, start WUD and bring the system and all the drivers fully up to date.
You shouldn't be vulnerable to an early infection that way.
 
#14
Well that didn't fix it. I think its SP1 thats causing it. It seems to happen right after that installs. I am going to try letting auto update do its thing, then install SP1 and see what happens.
 

Terry60

Knows where his towel is.
Staff member
#15
SP1 definitely replaces bootmgr.
All of us using HnS (which pretends to be bootmgr by renaming the real one) found that out when we updated to SP1 and the boot reverted to vanilla Vista.
It didn't cause the sort of problems you're having though. That's mysterious if you're not doing anything else with another 3rd party boot manager ?
 
#16
Not using any 3rd party boot managers. Even disconnected the hard drive I had OpenSuse 11 on thinking maybe there was some conflict. I am about to install SP1 again, hopefully it doesn't screw up the bootmngr

Addendum:

This time I let windows update install a bunch of updates before SP1, and now I got SP1 through windows update as well. I'll install it through there this time instead of the standalone version and hopefully it wont corrupt the bootmgr
 
Last edited:

JustinW

Super Moderator
Staff member
#17
SP1 shouldn't corrupt the bootmgr at all. It may change it, but Vista should still be booting properly. Make sure you're letting the updates finish installing. SP1 especially through Windows Update may have appeared to stall, but it really hasn't. It should take about 30 minutes for the inital stages through WU, and then it should ask you to restart to finish the rest of the installation which may also take up to another 30 minutes or an hour in whole.
 
#18
Well I let windows update do its thing and install SP1, and it seemed like it was fixed. But now the bootmgr is screwed up again. I am out of ideas.
 

JustinW

Super Moderator
Staff member
#19
This is a new install right?

Don't concentrate on anything else until all of the updates have been installed. Run sfc again to verify the new install hasn't been comprised.
 

Terry60

Knows where his towel is.
Staff member
#20
Yes, several people have come here saying SP1 hung during update and broke their system.
They probably experienced the same as me - an apparent hang at 98% complete - black screen - frozen cursor. Careful observation revealed continuing HDD activity, so I left the system till the LEDs had quiesced (then another half hour), and only then hit reset. The system rebooted with a completely successful SP1 update, but I suspect that others were less patient and interrupted the invisible final stages.