Vista Bootloader Problems

#1
My windows vista bootloader is always crashing for reasons I can't understand. For every time before this, I used the installation disc to repair it, and that worked, but now it doesn't anymore. It says "Windows cannot repair these problems". So, I tried re-installing vista, but it gets stuck at 0% at "Extracting Files". I tried to redo the installation, but now, the disc won't even load anymore! When I try to load the installation disc, after the loading bar goes away, all I have is a blank screen. What can I do to get vista working again? Note: I have vista dual-booted with ubuntu, but ubuntu is working fine. Also, it says that the file that is missing or corrupt is "winload.exe", and the status is "0xc000000f". Please respond as soon as possible.

-ametur_poet
 

mqudsi

Mostly Harmless
Staff member
#2
Haven't seen you in a while, poet.

Unfortunately, these are all textbook indicators of a bad MBR.

Boot into Ubuntu, and run this command:
Code:
sudo dd if=/dev/zero of=/dev/sda count=1 bs=446
Assuming /dev/sda is the hard drive that Vista is installed to.

I'd recommend first formatting the Vista partition in GParted in Ubuntu, then running this command, then installing Vista by booting from the DVD.
 
#3
Thanks for the reply, but I have good news and bad news. My Ubuntu installation doesn't start up correctly unless I have successfully shut down windows first. I didn't do that last time, so I can't start either windows or linux. The good news is that I am running Knoppix on a live CD. Would that work?
 

mqudsi

Mostly Harmless
Staff member
#4
Should work :smile:

The Ubuntu-boot/Windows -shutdown problem is probably also caused by the same MBR issue.
 

mqudsi

Mostly Harmless
Staff member
#6
It means your MBR was scrubbed - that's what we want :smile:

You won't be able to boot into Ubuntu now, because you no longer have GRUB in the MBR.

Booting from the DVD and installing should do the trick :smile:
 
#8
It didn't work. Well, it half-worked. The install disc successfully loaded, but the installation is still stuck at 0% at "Expanding Files". Would there be any way to fix this?
 

mqudsi

Mostly Harmless
Staff member
#9
That's still a sign of a bad MBR :S

Disconnect all other drives?
 

mqudsi

Mostly Harmless
Staff member
#11
No, the MBR is partition-independant.
So long as it is sda* that is all what matters.

Do you have any other hard drives physically attached to the system?

Addendum:

Or, if you have a Windows XP cd, try booting into the recovery console and issuing a "fixmbr" command from there.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#13
Definitely.
 
#14
Removing the external HD didn't work, but my ubuntu partition still shows up in the menu of hard drives I can select to install Vista on. Should I delete the Ubuntu partition?

Addendum:

I deleted the Ubuntu partition, but now it just shows it as 10 GB of unallocated free space; and it's still stuck at 0% when I try to install. Please help me with this; I'm starting to get worried that I wouldn't be able to re-install Vista.:frowning:
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#15
Like I said, try running "fixmbr" from the XP CD's recovery console. A Windows 2000 or 2003 CD will also work.
 
#17
I'm so close to fixing it! I found some information about the fixmbr command in vista, and now when I start up, it gets me to the login screen, but after I enter my password, it gives an error that says "The User Profile Service failed the logon. User profile cannot be loaded." How can I fix this?
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#18
You will have to go into safe mode where the Admin account is unlocked and try to restore your profile from there.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#20
Well to get into Safe Mode you have to hit F8 while the PC is loading if you have GRUB after you select Windows on the GRUB menu hit F8 right away. It should give you a selection of commands. It should look something similar to this:



After that you have to know if you setup a Admin password. Cause the Admihn account will now show. Log into to that and try to restore your profile. Either that or create a new profile and copy your data over...

How to copy data from a corrupted user profile to a new profile