Vista boots, 2003 doesn't

#1
I thought this would be easy. I have a vista computer and a second computer that has 2k3 installed. I pulled the hard drive from 2k3 and plugged it into the vista computer as a second drive. Vista is on C: disk 0, partition 0. HP puts a couple other partitions with their stuff on it so they are on partitions E (1) [HP Recovery] and F (2)[OSTools]. Wooo, thanks HP.

The 2k3 disk is G. disk 1, partition 0. I used easybcd to config like so:
Code:
Windows Boot Manager
--------------------
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
resumeobject {a0744f8b-705a-11db-918f-0018716ebb75}
displayorder {3a5dc7c0-3985-11dc-801e-001a4bc251a8}
{a0744f8a-705a-11db-918f-0018716ebb75}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 5
Windows Legacy OS Loader
------------------------
identifier {3a5dc7c0-3985-11dc-801e-001a4bc251a8}
device partition=C:
path \ntldr
description Windows Server 2003
Windows Boot Loader
-------------------
identifier {a0744f8a-705a-11db-918f-0018716ebb75}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale en-US
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence {572bcd56-ffa7-11d9-aae0-0007e994107d}
recoveryenabled Yes
bootdebug No
osdevice partition=C:
systemroot \Windows
resumeobject {a0744f8b-705a-11db-918f-0018716ebb75}
nx OptIn
pae ForceDisable
sos No
debug No
boot.ini:
Code:
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Windows 2003" /noexecute=optout /fastdetect
I put boot.ini, ntldr and ntdetect in C:\. When I boot 2k3, the splash screen comes up for a couple of seconds then I get a blue screen of death that flashes by too quickly to read, or pause. then it goes back to the boot menu where you can continue the 2k3 cycle or boot into vista. Vista boots fine.
Arrrrg. What to do?
 
Last edited by a moderator:

mqudsi

Mostly Harmless
Staff member
#2
Hi portland,

Welcome to NeoSmart Technologies! For the first time, I'm sorry to say that you have done everything right :frowning:

EasyBCD, Windows Vista, BCD, and Boot.ini have all done their jobs.

It sounds like it's time for a repair install for Windows Server 2003 (try booting it in safe mode?).

Let us know how it goes, and good luck!
 
#3
I bet Win 2003 has some device / hardware conflicts, since you moved the entire drive from one PC to another, all the devices and hardware drivers that are trying to load has issues with your new hardware and it may not be easy to repair unless you reinstall..


once you get it to work you will have to reactivate your windows too, depending on our server licenses you may or may not be able to
 
Last edited:

Sarge

Active Member
#4
I bet Win 2003 has some device / hardware conflicts, since you moved the entire drive from one PC to another, all the devices and hardware drivers that are trying to load has issues with your new hardware and it may not be easy to repair unless you reinstall..
Yep. That's it. I think so.
 
#5
You guys were exactly right. Im duhhh, that seemed obvious as soon as you told me. I was having a brain fart. These two machines are both HP Compaqs, both look exactly alike from outside, both have same chassis inside, BTX. I got carried away thinking I could plug it in heh, but of course the hardware in the newer machine is completely different.

So I tried doing a repair on the 2003 OS, in the vista machine, where I want the dual boot. it might load the new drivers as you said. I cant boot vista into safe mode, maybe because I dont get a DVD. :frowning: HP puts a partition on Called HP Recovery instead. It seems to be far better than Win System Restore, but not as good as a DVD. Anyway, boot from the 2003 CD, repair appears to be going great. But during the "installing devices" phase, about 2/3 done, it hangs. Yep, its the drivers. Try it again, same thing. disk goes back to 2003 machine so I can use it for now, have to repair it again for 2003 machine. That works great.

Booting Vista machine now says it is corrupted, kicks off HP recovery automatically. But the only restore point is the default factory. I will lose some apps. No biggie. I run that. Now when Vista boots, I get the ntldr missing msg. :frowning: it must think 2003 is the primary OS? Well, maybe if I just copy ntldr it to vista root again, put vista drive in 2003 machine just for copying. now it says bootmgr corrupted or missing or something.
Ok, I no longer think it is possible to plug in a disk, to setup a dual boot. You have to do a clean install on it.
So vista is probably otherwise fine. How do I repair the bootmgr? Cant run bcdedit, cant boot from DVD. Could I run bcdedit on the 2003 machine with the Vista drive temporarily in there? Or clean something up by hand? bootmgr is on the vista root I can see it. bootsect.bak is there. boot folder is there.

Any help would be much appreciated!
 

mqudsi

Mostly Harmless
Staff member
#6
What can you boot into right now?
 
#7
I can't boot the vista machine into anything. The only way I can look at the harddrive is to take it out and put it in another machine. Now it says 'invalid boot.ini file' when I try to boot it which makes sense if the dual boot ini file is still in there I suppose.
 

mqudsi

Mostly Harmless
Staff member
#8
Stick your Vista DVD in the drive and boot from it.
Repair Options -> Command Prompt:
Code:
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd
Let me know how that goes.
 
#9
When I boot from the vista dvd, I still get the 'invalid Boot.ini' msg and thats all, Even when I tell it to boot from the dvd drive. I did get it to boot into safe mode from the F8 boot menu, but it is loading drivers from:

Code:
multi(0)disk(0)rdisk(0)partition(1)\windows\system32\drivers\
and then it hangs.

That partition was the win 2k3 partition, so it seems to insist on looking there.
Why it wont boot from the vista disk is a mystery, but it ignores it.
 

mqudsi

Mostly Harmless
Staff member
#10
It's still trying to load via NTLDR and boot.ini

It looks like the order of your boot devices in the BIOS isn't set right - make sure it's set to boot from the DVD then the hard drive. You should see a message "Press any key to boot from the CD/DVD...." Press a key, and you'll see the dialog I mentioned earlier.