Vista Crash, please help.

#1
Hello. Well just like almost everyone else, I am here to cry for help. First things first I have a Dell Dimension E520 tower with Vista 32. It has a 250 GB SATA HDD, 1GB memory. It is mostly my 13 yr old’s computer cause I can never get him off of it, so I got a laptop. Anyway, to the point. The other day he said He started it up and it went through the BIOS screen, got to the green windows loading bar. Then when the Windows user sign in screen is supposed to come up there is nothing but a blank screen. There was no option in the boot manager to repair computer. The only options are to boot from HDD, CD, or run system setup, hdd diagnostics, or boot to utility partition. Try booting to the HDD or booting in safe mode or normally it ends up back at the same blank screen. So first things first I ran the dell diagnostic CD that came with the computer and it says the whole system checks out fine. I booted to the utility partition and all those tests passed. So I have been reading forum after forum for the last couple days trying to figure something out. So I did like the one forum states and made a Vista recovery disk (because I cannot find my reinstallation disk). I put the recovery disk in the CD drive. Choose boot from CD. It gets to the screen where the loading bar goes across the screen. It gets about 3/4 across the screen and then I get the error stating "an unexpected I/O error has occurred". The one that states there was a problem communicating with one of my devices. I read this is sometimes due to USB devices. The only USB devices attached are my keyboard and mouse. I can’t attach a PS/2 keyboard and mouse because all the ports on my computer are USB. I also went as far as to take the HDD out of my laptop and connect it to my Tower to see if I could get windows up and running to be able to explore the HDD that doesn’t seem to work. But when I do that it makes me go through start up repair. And I don’t want to take it too far because I don’t want to crash the other one. Also I think it has something to do with my laptop HDD is an IDE drive not a SATA drive. I am sure I did not include all the info you need or all the info I have, but that is a start. Please help. Thanks.
 

JustinW

Super Moderator
Staff member
#2
Startup repair and restoring to a previous restore point is about all you can do with our recovery disc. It cannot be used to re-install Windows. Check out recovering the vista bootloader from the dvd for an explanation of the repair proccess.

Press F8 as the computer is loading continually until the advanced boot options menu appears. There should be an option for Windows repair (it's been awhile so not sure what they are calling it now...) there that'll boot to your recovery partition. This will restore the system to the way it was when you first got it, but beware that anything that was not pre-installed and your files well be lost.

If the option doesn't appear there, you can try ctrl+f11 when the Dell logo appears when you first power the computer on, though I don't think this works with pre or upgraded Dell machines running Vista anymore :frowning:.

Other then that, find that disc you've long missplaced or find a friend that can lend you thier vista dvd. It is fine to do that as long as you use the product key found on a sticker on the desktop.
 
#3
ok i tried to manually fix the bootloader. but I am obviously doing something wrong. my CD drive is e. my OS is on c. my recovery drive is d. but it says it is empty. then i have an x drive which says sources. i can run the first command fine. but no matter how i type in the second command it says invalid command parameter etc. should I be at the E:/ promot when typing the commands in, or the x or c? thanks for the help
 

JustinW

Super Moderator
Staff member
#4
The X: drive is for your recovery disc when you have booted from the recovery disc and C: is probably your Vista partition. Some other users have been having problems with getting errors when using the commands from the recovery disc as well. I have not personally tried the steps myself for lack of the need to so I cannot confirm that commands are missing from the recovery disc that would produce these errors.
 

Terry60

Knows where his towel is.
Staff member
#5
It seems that early Vista's shipped with that command, and later ones seem to have omitted it.