Vista doesn't load up

roxy

New Member
#1
I wanted to install XP to another partition (I already had Vista installed), so I loaded up Gparted on an Ubuntu live CD and started to make the vista partition 50GB smaller. Towards the end of the process I got an error that said something like 'failed moving... something', so I pressed OK and it looked like it had worked anyway. I then restarted the computer and tried to get into Vista but it just hangs on the loading screen (with the green bar going across the screen). I left it for 15 minutes with no change.

So I powered off and restarted and it asked if I wanted to repair the startup so I pressed okay and this time the green bar came up and went and I was just left with a black screen. I left this for 15 minutes also before giving up. So now I can't get into Vista at all. If I try to repair the installation the same thing happens, green bar comes and then a black screen that doesn't change.

I would really appreciate any help (or suggestions) anyone might be able to give me.
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Roxy,

Sounds like you corrupted the Vista partition when it got stuck :'(

Only thing to try is put the drive in another machine and attempt to back up your data, then format and reinstll.
 

roxy

New Member
#3
CG, thank you for the reply. :smile:

I do not care about any data on the machine so reformatting/reinstalling will not be a problem in that aspect. However, I don't have a Vista install disc as it was already installed on the PC when I bought it. I do believe I have recovery partition though (not sure if that's the correct term), but when I get to it, I only have the option to repair the installation (or boot into safe mode, etc), which as I said, does not work.

Is my only option now to get hold of an actual vista install disk, do you think?
 

mqudsi

Mostly Harmless
Staff member
#4
It depends. If your recovery partition is also corrupt then I'm afraid that's your only other choice.
 

roxy

New Member
#5
All is fixed. :smile:

I ended up using the latest GParted live Cd which had the option to boot from the first partition (which was my recovery partition -- what I thought was the recovery partition before evidently wasn't) and managed to do a complete reinstall and everything's working fine again.
 

mqudsi

Mostly Harmless
Staff member
#6
Great news!

You might want to do a `chkdsk /r /f` from Windows to make sure your disk isn't damaged though.